Lagging with good PC

Users who are viewing this thread

Gerard_de_reinee

Sergeant Knight
WBWF&S
I've got 8GB RAM, GTX750Ti, AMD-FX8320, lots of space on disk and no idea why I still have 30 fps on IG Battlegrounds, running lowest possible settings. Any ideas?
 

Viktor

Sergeant Knight
First port-of-call would be to check your internet speed and signal strength. As was often the case with me before I got power line adapters; now wifi is no longer a problem. 
 

Rayden

Grandmaster Knight
make sure u turn off v-sync also playing this game with 60fps is terrible u should make it higher
 

Duken96

Grandmaster Knight
WB
I've had the same problem recently, I had huge fps-drops while playing in multiplayer. I reinstalled the drivers of my graphic card but nothing changed. At the end I solved it switching to DirectX 7. No idea what is the issue that causes the problem because I can still run most of the games with full settings.

PS: I'm also using Windows 10, so that might be the problem as with Windows 7 I've never had this issue, but I'm too lazy to switch to the older version.
 

Fietta

buıʇʇǝs uoıʇɔǝɹıp ʞɔɐʇʇɐ
Marquis
M&BWBWF&SNWVC
Well, do you get around 30fps constantly or would it go to 60fps then flicker down to 15fps every couple of minutes?. If you do get the fps drops, there's many different reasons.

- Problem with your motherboard. If you've gotten a motherboard with a phase of 4 + 1, this may have a problem with running your Octocore CPU (8320), Also if you do have a 4 + 1 phase motherboard, try and turn off any power-consumption options in your bios (Press Del on startup, mainly). Most motherboards would give less power to your CPU depending on your load or will have a 'green' feature, which would then draw less power to your CPU. If you were to pick a motherboard that supports an octo-core CPU, I'd suggest any motherboard with the correct watt (I believe 125w, is for your FX-8320 Black Edition). I personally use gigabyte boards.

- Another problem could be your cooling, if your CPU hits high temperatures that means there's either
          - A lack of thermal compound
          - You've got a cheap heat-sink
  What this would do is make your CPU throttle, this basically down-grades your CPU's multiplier from around x14 to around x2, making the 3.6GHz to around 1GHz, causing the horrendous CPU FPS drops in games. (I used to have the same problem). Just make sure you check your temperatures.

All of this is probably, a worst case scenario. I used to have a motherboard (MSI-GM) that supported a 95w CPU, when my CPU was 125w. Also, does this happen in other games?

I believe the 'APM' Feature on the BIOS, as well as AMD ' Cool 'n' Quiet' feature, about 99% of motherboards come with this horrible, power-saving feature, just turn it off. Anyways, I use a gigabyte motherboard, this is why I use 'Del' to access the bios.

EDIT: Having an 8 + 2 power phase, would also allow for better over-clocking, turning your 8320 to basically a 8350 if you overclock it to 4GHz. Placing your motherboard, would also help.
 

Gerard_de_reinee

Sergeant Knight
WBWF&S
It's my motherboard: ASRock 960GC-GS FX AMD3+ AMD 760G 2DDR3/2DDR2 uATX - 960GC-GS F

I've checked the temperatures, CPU is around 50C.

I played Metro Last Light a few days ago, played ARMA 3 and they both worked pretty fine, the problem only appears when I play Warband.

trot888 said:
          - You've got a cheap heat-sink
This!
 

Fietta

buıʇʇǝs uoıʇɔǝɹıp ʞɔɐʇʇɐ
Marquis
M&BWBWF&SNWVC
Well, your motherboard, is appropriate for what you're using, also looking at your temperatures it also seems fine, if you have a piece of software called 'AMD Overdrive' or just 'Overdrive', if you run M&B in windowed then click on the 'CPU Status', which should look like mine http://prntscr.com/9db2wz. If you run Warband and watch this carefully, you may experience anomalies. Here's the screenshot of the software: http://prntscr.com/9db4c8 If you've installed the drivers correctly, you should already have this feature pre-installed. A good way to see if your computer has EVERY up-to-date driver is to use a software called 'MSI Live Updater 6', this software (I believe regardless of your motherboard make' should show everything that needs updating.
Link to MSI Live Updater 6.
http://uk.msi.com/page/live-update-5-manual/
Small Icon saying 'download should be up the top of the page. Also, make sure you've verified Warband's game cache.
 

Gerard_de_reinee

Sergeant Knight
WBWF&S
I partly fixed the problem, the game seems playable now. Installed AdobeAir, GameBooster, reinstalled Warband, turned off v-sync, switched to low details, set fps limit to 75, updated all the possible drivers. Not sure which of these steps helped, but without the fps limit I still could get only around 90-100fps, that's still not good if you look at pc specs. Thanks for help everyone.
 

Fietta

buıʇʇǝs uoıʇɔǝɹıp ʞɔɐʇʇɐ
Marquis
M&BWBWF&SNWVC
Well with your PC specifications, you should easily be able to run Warband at 120+FPS at the highest settings.
 

Envious_Elazul

Sergeant Knight
NW
Someone had this kind of a problem and the reason was his mouse. It somehow screwed everything and the solution was to delete a single process file
 

tomYboy

Knight at Arms
It was most likely your vsync. I had the same problem couldnt reacht higher fps than 60. Turns out it was synched to my screens refresh rate, wich was 60hz.

Vsync synchronizes your fps with your screen refresh rate. When I turned it off, had no problem reaching a higher fps.
 
Top Bottom