Resolved Kicked out of City during Siege.

Users who are viewing this thread

Version number
No, I didn't use any mods.


Summary: I was a Khuzaiti defender of Alakat while the Aseri were besieging it. While waiting, I got a notification that "the Khuzait and Sturgians are no longer at war." And it kicked me out of the city. Khuzait and Sturgia weren't at war. Even if they were, it shouldn't have had any effect on the Alakat siege.
How to Reproduce: Haven't been able to since it's an Ironman save.
Have you used cheats and if so which:
Scene Name (if related):
Media (Screenshots & Video):
Computer Specs:
OS: Windows 11
GPU: GTX 2080
GPU Driver Version: Current
CPU: i9-9820x
RAM: 64 BG
Motherboard: MSI x299
Storage Device (HDD/SSD): SSD
Forwarded to the QA team for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!
This has happened to me as well, exact same way, except i was in a castle. My faction made peace with an unrelated faction, and it kicked me out of a castle while I was defending.

To recreate, your faction needs to be at war with two other factions, and then make peace with the unrelated faction while defending against a siege.
This has also happened to me multiple times now whilst defending a town/castle and I've noticed that it happens both ways of whether your kingdom be the one declaring war/peace or other kingdoms.
I wanted to write about the same problem. Due to war notification, I am kicked out of the besieged city. It's probably a safeguard if we happen to be in a city of a country that has declared war on us, but it accidentally kicks us out of every city.
This bug is not fixed, I just had it happen to me, but worse.
I've been informed that this bug is fixed and the fix will be sent to the game with future patches. Thanks for reporting and sorry for any inconvenience!
Summary: I was in the middle of defending one of my vassal's castles in a siege against one of the empires, when the Aserai declared war on me, followed by me being kicked out of the castle out of nowhere with a popup saying "you are no longer at war with the Battanians", who I was not at war with, and the siege continued on without me in the castle. I tried to reload the save from before the siege, and noticed, huh, its saying "achievements disabled" despite me playing on vanilla with cheat mode disabled, AND having been able to earn achievements on this save as recently as yesterday. I tried restarting the game, and loading from a slightly earlier autosave, and its still saying achievements disabled.
How to Reproduce: Be in a castle your vassal owns while its being besieged, and have a different kingdom declare war on you.
Have you used cheats and if so which: None, cheat mode is off.
Scene Name (if related):
Media (Screenshots & Video):
Computer Specs:
OS: Windows 11
GPU: GTX 3070
GPU Driver Version: Current
CPU: Intel(R) Core(TM) i7-12650H
Motherboard: built in
Storage Device (HDD/SSD): SSD
Top Bottom