Incorrect authorization key with lan game *I've serached*

Users who are viewing this thread


So the day has come, my son is old enough to play multiplayer with me and I want to show him the ropes on our LAN.

I buy him a separate copy (both steam)
I check to make sure we don't use the same keys (we don't)

I set up a server and when he tries to join we get

incorrect authorization key

We CAN join servers on the internet at the same time, just not on the LAN.

So I google this and find a lot of people with this issue and no real solutions I can find, for the last few years.  I turned off firewalls, I made sure the rgl_config.txt was 0, but obviously this is some sort of key thing.

In fact the only hopeful post I could find on this was if you wait, it goes away (no one ever followed up of course to say if its true).

So is there a solution?  I have a 10 year old next to me bouncing off the walls wanting to play  :lol:
Hello Oyclo,

The incorrect authorization key is due to your server not being able to connect with TaleWorlds main server.
This happened a lot in the past when TaleWorlds did not have DDoS protection, when their servers were under attack, no one could join multiplayer servers.
What you could try is opening cmd.txt by pressing [WINDOWS] + [R] keys. Input 'cmd.exe', then in the black screen input 'ping'.
If you get response from the server, the issue might be coming from your own PC.

Are you using the dedicated server package ? Do not host your server directly from the game itself.
Server package can be downloaded by clicking this link.


Ok I pinged taleworlds and its a 21ms ping with no loss so thats not a problem (I'm an old school telnet guy so I understand that part :smile: )

I wasn't using a server package as I was hoping to just use the lan, port forwarding can be an issue for me since the router software was on a bricked PC. 


Section Moderator
The listnen server never worked for me on LAN. But using the dedicated server and running it in online mode actually made it appear on LAN for me.
Alrighty, then that could effectively be the issue.
You do not need to open your port to have the server in your lan.
Simply start it, and allow the port on your PC with your firewall (7240).
You should then be able to access the server from different computers on the same network.


Ok I got it working and decided to put how I fixed it since most people never did over the last 3 years  :facepalm:

What MaHuD suggested is what I had to do too.  You need to run a dedicated server, and that server will show up on the LAN tab.  Hosting a game directly won't work as far as I can tell.  It was made a little more confusing because I had older files for the dedicated server, and of course had a filter on for only modules I could use, which meant it didn't show up on the list. 


I'm having the same problem. My mate and I are trying to play using the server package on LAN with Hamachi. Every time he joins we get the, "Incorrect Authorization Key." We've tried every solution under the sky.
Top Bottom