• Please note that we've updated the Mount & Blade II: Bannerlord save file system which requires you to take certain steps in order for your save files to be compatible with e1.7.1 and any later updates. You can find the instructions here.

BL 3D Art Imported Mesh has normals facing the wrong direction in editor despite being correct in the model

Users who are viewing this thread

Zeus1257

Sergeant at Arms
M&BWBWF&SNW
having a bit of a weird issue bringing in a new mesh in the bannerlord tools. I have a model of a helmet I've exported from blender as an fbx file, which ive imported into my module. however, a large portion of the helmet has its normals the wrong way around. this is despite the mesh having them correctly facing in the file im exporting it from. If i import the fbx used in the module back into blender, the normals also are shown as being correctly facing. However, in the editor itself they always are the wrong way around.

1.png

here's how it appears in the mod tools

2.PNG

here's how it appears in blender
 

NPC99

Baron
M&BWBWF&SVC
having a bit of a weird issue bringing in a new mesh in the bannerlord tools. I have a model of a helmet I've exported from blender as an fbx file, which ive imported into my module. however, a large portion of the helmet has its normals the wrong way around. this is despite the mesh having them correctly facing in the file im exporting it from. If i import the fbx used in the module back into blender, the normals also are shown as being correctly facing. However, in the editor itself they always are the wrong way around.

1.png

here's how it appears in the mod tools

2.PNG

here's how it appears in blender
As I've not heard of anyone else with this problem, I suspect it may be a Blender problem. This link may help https://blender.stackexchange.com/questions/135247/blender-2-8-exports-fbx-with-flipped-normals
 
Upvote 0

Zeus1257

Sergeant at Arms
M&BWBWF&SNW
I've managed to get it to work, i exported it with a new name and imported it as a new asset, and it works fine now. I had originally taken just the part that was messing up and exported it on its own, and then i went back and merged the rest with it again and then tried to reimport that, but it didn't actually change at all in the resource browser or when opened in the mesh editor. it seems like the reimporting just...didn't work?
 
Upvote 0

NPC99

Baron
M&BWBWF&SVC
Glad you got it to work :smile:.
The Resource Bowsers reimport function only works for reimporting assets from your mod's AssetSources folder into the Assets folder. If you have your source file in another folder just import it into the Resource Browser as a new asset. The tools will then recognise it has the same name as an existing asset and ask if you want to update it.
 
Last edited:
Upvote 0
Top Bottom