Resolved I am not able to launch the Multiplayer due to battleeye

Users who are viewing this thread

Version number
1.5.2
Branch
Main

banderolax

Recruit
I have not installed any mods that affect any of the files mentioned below in the game folder, and some of the files are System files, so there is no option of deleting. I removed the Battleeye files, and checked file integrity, installed it again, but it did not help.

23:44:37: Installing BattlEye Service...
23:44:38: Successfully installed BattlEye Service.
23:44:41: Launching game...
23:44:53: Note: File blocks can be ignored if they don't cause problems with the game.
23:44:53: [INFO] Blocked loading of file: "C:\Windows\assembly\NativeImages_v4.0.30319_64\netstandard\e492b4ac0eb7f47d61fcec008e8ee3f2\netstandard.ni.dll".
23:44:54: [INFO] Blocked loading of file: "C:\Windows\assembly\NativeImages_v4.0.30319_64\System.Runt54187d77#\bbf2297e0553210c5752255237d14ee0\System.Runtime.InteropServices.RuntimeInformation.ni.dll".
23:44:56: [INFO] Blocked loading of file: "A:\Steam\steamapps\common\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client\dxgi.dll".
23:44:56: [INFO] Blocked loading of file: "A:\Steam\steamapps\common\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client\dxgi.dll".
23:44:57: [INFO] Blocked loading of file: "C:\Windows\assembly\NativeImages_v4.0.30319_64\System\692cee7f35bc369df5d159f8c5627c5d\System.ni.dll".
 
Last edited:

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Please make sure that your OS is up to date.
Is your game crashing? If so, while doing what? Have you used the crash uploader?
The error you mentioned should not cause any problems. What is the problem here?
"A:\Steam\steamapps\common\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client\dxgi.dll"
This .dll is a Microsoft related .dll file. And is the file pathway valid?
 
Last edited:

banderolax

Recruit
My windows updater is showing: up to date, last check yesterday. My game is not crashing, singleplayer works fine, when i launch multiplayer battleye opens, the above message is printed in it, then it just switches off, steam changes the bannerlord button from "stop" to "play" and nothing more happens. The file dxgi.dll is tied to directx when i googled it, the game opens fine if i remove it but it seems it should be tolerated due to its source.
 
Last edited:

azakhi

Internal Tools Development
Developer
M&BWBWF&S
My windows updater is showing: up to date, last check yesterday. My game is not crashing, singleplayer works fine, when i launch multiplayer battleye opens, the above message is printed in it, then it just switches off, steam changes the bannerlord button from "stop" to "play" and nothing more happens. The file dxgi.dll is tied to directx when i googled it, the game opens fine if i remove it but it seems it should be tolerated due to its source.

Hello, that file shouldn't be there. Could you please delete that file, then update the following dependencies:

Edit: To be sure, could you please delete Mount & Blade II Bannerlord\bin folder completely and verify game files?
 
Last edited:

banderolax

Recruit
This has worked after removing the file, after some diggin it came up that it was part of a shader overhaul that i uninstalled some time ago,. Thanks for the help.
 
Top Bottom