Hosting Server Not working.

Users who are viewing this thread

Hexen_Reaper

I have been Trying to Play Mount and Blade online with my Friend, but when He or I host a Server we can not see said server on the Internet join list. I have tried Diffrent opptions, And have used the Check Boxes, nothing seems to be working. I baught this Game solely for playing Online with my Friend. I whould HATE to think i wasted my Money.
 

waggywags

Recruit
I would HATE to think you forgot to tick Add to official game servers list, or didn't try lan-ing it, or are trying to connect different versions, or are running cracked fail versions.
 

Hexen_Reaper

As i said in the Original post, I Did make sure That was Checked. A LAN game is not possible as my friend is not on my Network. We are running the Same Version. and No, i have the real Game, I got it on Steam, So did he.
 

Ivarr

Squire
WB
If you want to host a game that's accessible from outside of your home network, you must to have the required network ports open for incoming traffic. By default they are not.

When you run the server, Windows should ask you if you want to add the game to Windows' firewall exceptions list or keep blocking the application. If you somehow miss that dialog or it doesn't appear, you need to add the game to the exceptions list in Windows' firewall settings. Or if you are using some third party firewall, you'll have to make the change there.

Another blocker is your router. You need to open the ports in the router. They call it port forwarding for it forwards the data from one machine (your router) to another (your PC) via certain ports. Some routers require that you have set static IP address (fixed IP address in local network that doesn't change) for your computer in your home network to make this happen. That's because they use the PC's IP as target when forwarding ports. There's a site that can guide you and explain what and why: http://portforward.com/. If you are hosting the game inside the game menu, the port used is 7240. Although, they say it's a range of 7240 - 7245. And the protocol is UDP.

Also note that some ISPs have ports closed on their side as well. If that's the case, you can ask them to open the network ports.
 

Hexen_Reaper

Took me Forever to figure out just how to do everything you specified, but I actually found that everything you where talking about is already Done. (My Father Controls the Router and had done all that along time ago). Also, I have No firewalls, None what so ever, i do Anti-virus Manually.

Today, I tried Connecting to a Server, and my Friend was Able to join that Server. I do not understand how We can see every other Server online, join, and play together. But that my Personal server (or his) Is not visible to Eatch other.
 

Ivarr

Squire
WB
You can see each other in someone else's server because that server gets incoming data flow from both of you and then then it just sends back what's required. The clients don't need to have the ports open to make this work. The problem with your server must be that there's something blocking incoming connections to your PC.

So, port 7240 is forwarded to the IP address of your PC in your home network? Long time ago as you said. It must be set for UDP protocol, although, if both are enabled, it'll work too. Make sure that the same port is not forwarded to more than one PC in your network. I once had such problem by overlooking things - only one of them got the connection even when the other didn't use the port.

Have you been able to host servers for other similar games? Games that require direct incoming connections. If you haven't (even if you have, it works weird sometimes, depending on your ISP), there's possibility that your ISP is blocking incoming connections. That's often their default policy but you can request to make it open.
 
I also want to host a game but i fail at some stuff i mean i got name,password and stuff filled in the battle txt. But when i open both MB_Warband_Dedicated and the battle bat file i keep seeing it on lan instead of online i've tried 3 ports i think 1740,1741 and 1742 and idk what im doing wrong really so any help or suggestions would be appreciated.

Thanks in advance
 

The Shadow

Recruit
I too have this problem.  I can't host a dedicated server.  Any incoming UDP connections on ports 7240, 7241, and 7245 are supposed to forward to my PC, which has the server running.  It just doesn't show up in the list!  It's set to, but it won't. 
 

Hexen_Reaper

I have Not Been attempting to host a Dedicated Server. I have just been going into the multiplayer screen, and clicking "host a game" Maybe this is the problem? If it is, where can i get the software to host a Dedicated server?

Also, Yes i am able to Host a Server on Every other game that i have For Steam, and out side Steam and People play and join frequently.

I am baffled as to what is causeing this.
 
Sorry for being 7 years late, but here's the link to dedicated server files : @https://www.taleworlds.com/en/Games/Warband/Download
 
Top Bottom