Hosting a Dedicated Server Guide

Users who are viewing this thread

Since there isn't much traffic there I'll ask here again. What has to be done on the server to allow automatic map downloads? Or:

[quote author=NaglFaar]What I meant is; how do you add maps that you download ingame.

For example:

I played on the 22nd server it seems, on my native module, and the map switched from the current one to Helms Deep. I didn't have that map on Native, ofcourse, so the game downloaded that map for me automatically. Constant messages came up and told me how many KB's on that map I had downloaded until it was finished.

So...
Once again, my question is;
How do I add the maps to a native module so that other people can download it and play on it on a native module?[/quote]

 

Exist-nl-

Veteran
ModusTollens said:
Since there isn't much traffic there I'll ask here again. What has to be done on the server to allow automatic map downloads? Or:

[quote author=NaglFaar]What I meant is; how do you add maps that you download ingame.

For example:

I played on the 22nd server it seems, on my native module, and the map switched from the current one to Helms Deep. I didn't have that map on Native, ofcourse, so the game downloaded that map for me automatically. Constant messages came up and told me how many KB's on that map I had downloaded until it was finished.

So...
Once again, my question is;
How do I add the maps to a native module so that other people can download it and play on it on a native module?
[/quote]

Don't bother the Op is being mean and wont tell anyone.

hooray for the community !
 

Plazek

Master Knight
WB
rofl.

Pro skills. Calling one of the few people that knows how to do it a douche is definitely the best way to leanr how!
 

Exist-nl-

Veteran
Just saying it how it is, enough people have tried to figure it out and send a pm to him.

I can easily retract my comment but I haven't seen a "How to make dowloadable maps work" thread, have you ?

:smile:


Edited my previous comment .......

 

Dark_Star

Recruit
hey guys! plz help me. when i go to forward my ports i put in the 7240-7424 thenit askes me for a port map? wth do i put in it!!! plz help me! i wana host a server for south africa because with our rubbish pings we cannot connect to overseas servers! plz!!!!!!!!!!!!!!
 

Vincenzo

Count
M&BWBWF&SNW
Swadian Man at Arms said:
My server appears as LAN, and don't know my router name, because my network is public. :roll:

Also how to join as admin ?

Ask the admin of your public network to open a port for you.

Fill in the admin password in the password field on the bottom before joining.
 

oltimus

Recruit
Vincenzo said:
Linux
For Linux it isn't that easy.

Use these commands to start the server:
"screen"
"wineconsole --backend=curses mb_warband_dedicated.exe -r Sample_<gamemode>.txt"

The server should be running, detach out of screen with: Control + D
to attach to the screen session again type in console:
"screen -r"

Not fully correct :wink:
1) Other combination used for detaching: Control + A + D (Ctrl+D will do nothing in server console)
2) screen -r will attach the latest screen session and it could be not desirable if you have others :smile:
"screen -ls" will show all opened session and needed should be placed after "screen -r"

Personally, I didn't mention any differences between Linux and Windows in that case. The only reasons  to use Linux  would be a server with it or you are a fan.

In any case, many thanks for the instructions.
 

Vincenzo

Count
M&BWBWF&SNW
Ahh yes, I am using screen so much that I use it automatically that I even forgot the A in Ctrl + A + D  :mrgreen:

After I compiled wine with optimizations into the kernel amongst other stuff it performed better then windows.
 

Rippost

Regular
I apolagize for my ignorance, but i don't know anything about ports. The default 7240 port isn't on that router list, can someone tell me what ports i can use for this?

EDIT: I found my port on there, am i supposed to type in the letters and stuff on the server files too?
 

Rippost

Regular
Interesting thing, I got mine up, and my friends found it on the internet search, but it only shows up as LAN on mine. odd.
 

Mordaunt

Squire
Anyone managed to get two dedicated servers running off the same PC at the same time? I've set different ports for each, when i execute the 2nd batch file I get a "could not start due to network error" message in the cmd prompt then it exits. Help please!

Fixed: Set ports further apart, eg 7240 & 7250 rather than 7240 & 7241.
 

Mordaunt

Squire
Rippost said:
Interesting thing, I got mine up, and my friends found it on the internet search, but it only shows up as LAN on mine. odd.

That's normal for a NAT'd internet connection.
 

todayskiller

Veteran
Well after about 2 hours of trying...I give up, and ask you lads for help :smile:.

I got all the info correct, it just wont show up on the server list or w/e in game (I belive I did the port stuff right)


on the Command Promt it says Input: set_port 7240
Port is set

Input: set_steam_port 7241
Steam port is set

Then it has some other stuff,
Input: start
Starting Mission...
Command File is read.

So I belive that is working fine right?, it just has to do with my opening ports and such?

This is what I put on Linksys, and Norton both...

I went to the Linksys thing, and clicked on applications and Gaming, then went to Port Range Forward:

Application: Start: End Protocol: IP Address: Enable:
Warband:    7240:      7240 (tried 7241 also):          put my IP adress:    check marked enable.

Then after that, I clicked saved, and it said ports enabled or somethign like that...Did I do that right?

Also, I have norton 360...I think this is where I might of went wrong (have the windows Firewall disabled)   

I clicked on NOrton 360...then settings...then firewall...then Traffic Rules (is that correct?) and made it go from 7240 to 7241 like I did on Linksys...Idk if this is the right place or not.

Any help would be appreciated...Thanks :smile:

EDIT: yes I did UDP not both, or TCP or w/e it was.

17:56:39 - SERVER has joined the game with ID: 0 and has administrator rights...It shows that the 6 times I tried it at different times of course.
 

todayskiller

Veteran
scratch that post above...I got it working...For those of you who have The LAN problem...message me or post on this thread, I found the fix (well my Uncle did :grin:)
 

todayskiller

Veteran
Vincenzo...I have a question for ya...Since you guys found a way to get around the max 64 player limit...Do you guys know how to get around the Round Limit? to possibly make it unlimited? or just waayyyy longer...Cause PWMOD doesn't really work out only being 2 hours long per round :/
 
Top Bottom