In Progress Horrible sound breaking and crackling in large battles (save file and recording included)

Users who are viewing this thread

Version number
1.6.4.287129
Branch
Beta
Modded/unmodded
Yes, but I removed mods.

nonnon_non

Recruit
Summary: In large battles, when troops arrive at each other and begin fighting, the sound breaks up really bad. It's like the sound gets mushed together and becomes like static. It only happens when I'm near a clump of infantry that are engaging in combat, and disappears if I'm far enough away from the fight. It happens in e1.6.3, and it still happens when I switch to 1.6.4 beta. One last thing, I'm on the lowest Sound Channel setting. It gets much worse if I turn it up.
Thanks, guys. Please help. I included my save file and audio recording.
How to Reproduce: Get in a fight with a party as large as your own.
Have you used cheats and if so which: I use a few mods, but the problem persists even after I turned them off.
Scene Name (if related):
Media (Screenshots & Video):
Audio Recording: https://drive.google.com/file/d/1dsy1yCkGWh00EV-_pOJlPR1IhV20BEyz/view?usp=sharing
Save file: https://drive.google.com/file/d/1IQ09pubYLDyvoC-LbE_CXtE_7aVJq8XC/view?usp=sharing
Computer Specs:
OS: Windows 10 Pro
GPU: Nvidia GeForce GTX 970M
GPU Driver Version: 496.13 (Latest)
CPU: Intel Core i7-6700HQ
RAM: 12 GB
Motherboard: GL502VT (Asus)
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Forwarded to the QA team for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Have you restarted the game after changing the sound channels setting? Asking just to be sure.
 

nonnon_non

Recruit
Have you restarted the game after changing the sound channels setting? Asking just to be sure.
Hi, thank you for replying. I have, and I'll give you everything I've noticed. I was already on the lowest Sound Channels setting when it happened. Kicking it up midbattle only makes it worse. Restarting after setting doesn't do anything. All I know is that it happens when I'm near a large mass of infantry who are in combat. Everything is fine if they are not in combat. I also noticed that it always happens when a lot of soldiers scream at the same time. In fact, I'm beginning to believe that it's the screaming sound effect from multiple sources at the same time that is the cause of it because the problem was gone when I turned off sound effect in audio setting and let only the music play. But that also means I have to play without battle sound effect :sad:
 

ADash

Recruit
Hello, it seems my audio problem that I posted yesterday about audio crackling when riding on stone pavement is related to this problem because I also experience sound breaking during large battles.
 

nonnon_non

Recruit
Hello, it seems my audio problem that I posted yesterday about audio crackling when riding on stone pavement is related to this problem because I also experience sound breaking during large battles.
Can you try turning down the effect volume completely? If you can still hear the music, then I think it's likely that the cause is the sound of the fighting or the screaming that causes this.
 

ADash

Recruit
Yeah it is related to effect volume, I tested beforehand and the audio seemed perfectly fine when I turned effect volume off. I rather deal with the annoying crackling noises until there is a fix then turn of effect volume completely.
 

ADash

Recruit
After entering a 1000 man battle the audio crackling becomes pretty severe, it seems the audio problems I have in large battles and riding and stone pavement both have to do with effect volume so there is probably a problem with how the game produces effect volumes for certain sounds. I am not an expert in how the games audio works in anyway, I only got the game a few days ago after I finally got a pc that can run it smoothly. I am just making an assumption, I am sure the devs will find out what the problem is. Other then the audio problems and the weird snow glitch I am greatly enjoy this game as much as warband and wish the devs good luck in their continued development of Bannerlord.
 

conleyc86

Recruit
I've had this same issue for months and nothing fixes it. It seems like when hundreds of sound effects try to play simultaneously that's the issue.
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Could you send us the .sedf files located below via the ticketing system?
C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord\Sounds
You can send your save files to us via the ticketing system on the website. To send us a ticket, please visit the www.taleworlds.com site and login to your forum account from the top right. Click to "My Account" and then click to "My Open Tickets". You can create a ticket there and include the save file and as well as the forum link of this thread. You can find more info about how to upload files to us with the new ticketing system here. Thanks for reporting and sorry for any inconvenience!
 

Cavedog

Recruit
I have experienced this same issue multiple times on 1.6.5 beta. Turning number of sound channels to minimum has fixed it immediately for me each time.
 
Top Bottom