Help needed!

Currently Viewing (Users: 0, Guests: 1)

Amagic

Baron
Best answers
0
Ok so i decided to try my hand on modding but unsuprisingly (to myself) I'm stuck at the easiest step. The part where you edit module_info. I'm having difficulties identifing the cause (I'm not into the technical part of this kind of stuff) but I have a few guesses. I replaced the required line with "C:/Program Files (x86)/Mount&Blade Warband/Modules/MyNewModule/". Still, when I run build_module, I first get "variables.txt not found" and then a long line of repeating text. But at the bottom of each repeating section of text, there's this message:
I OError: [Errno 13] Permission denied: 'C:/Program Files (x86)/Mount&Blade Warband/Modules/MyNewModule/(some file that's different in every section)'.

Ok so from this I can assume what might be the problem(s).

The first is that I wrote the module path wrong but I doubt that. Could using spaces in the path name be the problem?

The second guess concerns the "permission denied" line. After reading that it made me want to slam my computer (Windows 7 btw). I guess it allows only an admnistrator to access it. The access denied and "admnistrator required" bull**** is not only with M&B but pretty much everything. I AM the admnistrator. My account is the only account on this laptop and adminstrator type. Still it blocks me from a lot of places with it's fancy shield icon  :evil:. Like it can decide what's best for me.

I tried running module_build in "Run as adminstrator" but then something black flashes on my screen for a sec and then disappears. I'm totally stumped on this one. I'd appreciate any form of help.

EDIT: Edited the folder to give full access to my user. Seems to have solved the problem, tho a few warnings still pop up.