Need More Info Graphical Issues making game impossible to play

Users who are viewing this thread

Version number
1e.6.4.291839
Branch
Main
Modded/unmodded
No, I didn't use any mods.

just_black54

Recruit
Summary: There is a graphical problem that I am having. The graphics continually get worse over time where all the proportions are disproportionate and become basically balls of color. So interaction, fighting all become impossible to do. I had no issues with the main menu and a lot of the times, if I load into the map, my computer is fine. But when I go into a village or when I go out of the village and back into the map, it just keeps getting worse.

How to Reproduce:
After the game is loaded, going into any other loading screen or scene creates the glitch

Have you used cheats and if so which:
None

Scene Name (if related):

Media (Screenshots & Video): https://flic.kr/p/2mM8C7H , https://flic.kr/p/2mMc3yf , https://flic.kr/p/2mMa2aw
Computer Specs:
OS: 19042.1348
GPU: NVIDIA GeForce GTX 1650
GPU Driver Version:

AMD Radeon Graphics
CPU: i5-1135G7
RAM: 12 GB
Motherboard: 11th Gen Intel(R) Core(TM) i5-1135G7 @ 2.40GHz 2.42 GHz
Storage Device (HDD/SSD): 256 GB SSD
 

just_black54

Recruit
Keep in mind, I am not the most tech saavy so if any of the information provided does not make sense, please forgive me lol
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Let's try clean install.
Clean Install
The clean install is removing every single game-related file from your computer and installing the game again. Why do you need to remove the game while you just want to remove the modifications? Unfortunately, some of the modifications do not just add a new modules folder but also change or adds contents to the existent modules folder. Without a reinstall, we can't be sure those files are unchanged.

To perform a Clean Install, Uninstall the game. You can do that by right-clicking the game on Steam Library and selecting Delete Local Content. Delete all folders related to the game that remains after the uninstallation. The folders that might have files inside:
Steam: C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord
Epic: C:\Program Files\Epic Games\Mount & Blade II Bannerlord
C:\Users\USERNAME\Documents\Mount and Blade II Bannerlord
C:\ProgramData\Mount and Blade II Bannerlord

Note: You'll need to allow Windows to display hidden folders and files to see the ProgramData folder and its contents.
 

just_black54

Recruit
Let's try clean install.
I tried that. That didn't work either. I am using the same save file. I don't know if that would affect anything. But every time I load it up, the graphics are fine. The only thing I notice are the trees blinking in the background but that isn't a problem. Once the tutorial village loads where you need to talk to the village head guy does the glitches start. And then most of the time when I go back out to the main map, the map is crazy and then if I load back into the village, then the graphics become even more wonky than the first time. So, it seems to happen and get worse with each loading screen. I can run pretty smoothly on medium graphical settings. I tried all the settings and all of them have the same issue.
 
Last edited:
Top Bottom