Need More Info GPU Crash when starting siege battle at Onira

Users who are viewing this thread

Version number
1.1.6.26219
Branch
Main
Modded/unmodded
No, I didn't use any mods.
Dump identifier (optional)
2023-11-29_06.29.46_41e92edda8d910fed622a2fe813dc440
Summary: d3d_device_context_ -> Map at rglGPU_device::lock_texture Failed! The GPU device instance has been suspended
How to Reproduce: Begin siege battle as attacker at Onira
Have you used cheats and if so which: No
Scene Name (if related):
Media (Screenshots & Video):
Computer Specs:
OS: Windows 10 22H2
GPU: AMD Radeon RX 5700 XT
GPU Driver Version: 23.11.1 (10/25/2023)
CPU: AMD Ryzen 9 5900X 12-Core Processor 3.70 GHz
RAM: 16.0 GB
Motherboard: Gigabyte B550 AORUS ELITE AM4 ATX
Storage Device (HDD/SSD): SSD

Sometimes the crash occurs after a few minutes of the battle, sometimes a few seconds. I have tried:

Deleting \Shaders and verifying game files
Deleting C:\Documents\Bannerlord and relaunching
Reducing graphics quality from Very High to High and to Low
Reducing FPS cap from 144 to 60
 
Last edited:
2023-11-29_06.39.45_41e92edda8d910fed622a2fe813dc440 (60fps cap, high settings)
2023-11-29_06.42.21_41e92edda8d910fed622a2fe813dc440 (60fps cap, low settings)
 
Unfortunately, the crash you have experienced is a GPU crash. Sadly we can't directly offer support on these cases. You can try expanding the swap size on your hard disk but please note that it is not a solid fix. You can find more info regarding this here. Thanks for reporting and sorry for any inconvenience!
 
Yes I posted yesterday about the same issue it seems in my " Game crashes during battles and almost always durning ambush battles." thread. 5700xt seems to be not compatible with this game at the moment.

Can we hope for a patch for this GPU in the future?
 
I do see other threads with the 5700XT, thanks @Remade and @LedoS I'll see if I can try an older driver version or beta drivers - I'll let you know if that resolves it. @MArdA TaleWorlds There are a LOT of complaints of this specific issue across video card manufacturers, different scenes and different gameplay situations. It certainly looks like you have a bug. I wouldn't be so quick to dismiss this issue. I'm happy to give whatever info you need to reproduce this but I'm not satisfied with the suggested solution (which clearly hasn't worked for the majority of players you have responded to)


In fact, in July, it looks like you were investigating this same issue but were unable to resolve.

 
I thinks it's more do with old shaders OR game allocating memory but not testing returning pointer. I eventually had to upgrade my old 1080 8G Nvidia card, that solved my issue, didn't fix the problem, but I found a work around. 24G GPU mem gives more wriggle room.

Here are the locations for Shaders -

(1) Steam / Bannerlord
(2) "C:\ProgramData\Mount and Blade II Bannerlord"
(3) "NVidia also keeps a shader cache located in %LOCALAPPDATA%\NVIDIA\DXCache and %LOCALAPPDATA%\NVIDIA\GLCache ..". probably also AMD.

Reload, reverify.

hope this works.
 
I've continued on the save that was having the crashes, no other crashes outside of the Onira siege scene. Different castle sieges and Tyal siege all worked fine. Came back to Onira at night, managed to get further than I've gotten ever before, but did eventually crash. Changing settings, and deleting shaders folder didn't seem to improve the situation at this one particular town, but after deleting the shaders directory I didn't have any future crashes until coming back to Onira. I think it's likely that the shaders are the culprit, @archaicwarrior's solution isn't a bad workaround, but I'll keep sharing crashes I experience in the hope of an official fix.
 
Back
Top Bottom