• The forum has been updated. For an explanation of some of the changes, head over here.

Get Object Failed For Texture: Error

Currently viewing this thread:

Apollon-04

Alright, today I finally got around to porting over my Galactic mercenary mod to the newest version. I did all my coding, got the resources set up, and I'm pretty sure everything is right. Unfortunately, when i start my mod, I get an error. It occurs right when M&B is loading the INI file. Here's a picture...

errorbq6.png



I went through my whole INI file, and all of my resources, and I can't find anything. i made sure that every mesh had an actual texture, every material had the right texture name, and that there wasn't a texture with no name, but I couldn't find anything.


Anyone know what to do?
 

SPD_Phoenix

Master Knight
The error should be brf related (incorrect texture name? blank field?...) or you didn't have the dds file where it should be.
 

Apollon-04

I'm sure there isn't a blank field, and I'm pretty sure all texture names are correct. I can't figure out wahts causing the error. What do you mean by i don't have the dds file where it should be? If it can't find a file, it would say what file is missing. I can't understand why its just blank. Any more ideas?
 

Arn

Regular
Well, can't say for sure, but Yoshiboy's tutorial points out that when you add a new call to a texture, which will look something like "load_mod_resource = some_texture" you have to add it before the line "load_resource = textures".

Something to check, anyway :neutral:

 

-Peter-

Master Knight
M&BWBVC
It might mean that some of the texture names in the brf file do not match the actuall dds file. I had the same problem with the OSP Swords pack and the weapon_james texture file. All that was wrong was that the textures in the brf were weapons_james when the actual dds file is weapon_james.
 

Nethoras

Knight at Arms
what it means is you have a material with no diffuse set, so go find and root out the problematic material
 

Apollon-04

I did what Arn said, but nothing changed. I've never heard of that eiter. Is that new for version 1? I know you didn't have to do it in the past.

I also went back through and checked all my meshes and materials, but no luck. Everything seems to be in order. I have no idea whats wrong.
 

SPD_Phoenix

Master Knight
Occured to me just once:

After I made a clone of an existing materials/texture, then rename it to a new one, BRF Edit (8.9.5) generated a ghost material/texture which isn't visible in the list. Hence, no name listed in the error message.
 

Llew2

Cheap ass bum
Count
M&BWB
SPD_Phoenix said:
Occured to me just once:

After I made a clone of an existing materials/texture, then rename it to a new one, BRF Edit (8.9.5) generated a ghost material/texture which isn't visible in the list. Hence, no name listed in the error message.
It's happened to me also. Could be your problem.
 

mbfreak2

Knight
-Peter- said:
It might mean that some of the texture names in the brf file do not match the actuall dds file. I had the same problem with the OSP Swords pack and the weapon_james texture file. All that was wrong was that the textures in the brf were weapons_james when the actual dds file is weapon_james.

hey can you help me with that? how did you fix the error? Thanks.

-I put OSP Swords in Resource in my 'Mod'
-and then put the dds files in the Textures.
-Then I went to module.ini and did:

load_resource = textures_face_gen
load_resource = shaders

load_module_resource = OSP_Swords

load_resource = textures


load_resource = materials
load_resource = materials_face_gen

-And then when I open my game with the mod I'm making, I get the get_object failed for texture earthernvmap
 

Nethoras

Knight at Arms
check the material tab of your mesh brf file, that is assuming you have seperate brfs for materials texxes and meshes, (which is a good idea) whenever you import an obj, there is a good chance you will import its material from wings (or whatevr your using), its happened to me many a-time.
 

mbfreak2

Knight
Nethoras said:
check the material tab of your mesh brf file, that is assuming you have seperate brfs for materials texxes and meshes, (which is a good idea) whenever you import an obj, there is a good chance you will import its material from wings (or whatevr your using), its happened to me many a-time.

i went to the material tab and it was weapon1. Should i change it to something else?
 

Apollon-04

SPD_Phoenix said:
Occured to me just once:

After I made a clone of an existing materials/texture, then rename it to a new one, BRF Edit (8.9.5) generated a ghost material/texture which isn't visible in the list. Hence, no name listed in the error message.

This hs to be the error, because I'm sure my materials are all lsited right. What do I do to fix it though?
 

Apollon-04

I've gone through every list, and there is no empty selectable space at the end of any of my brfs. I've checked all materials, and all diffuses are set right. What else cold be solving the issue?

Is there anyone here willing to look through my mod that i can trust to help me try and fix the error? I would gladly appeciate it, and will add a hero of your name in Gmerc, if you can fix it.
 

Apollon-04

Sorry to double post, but I still can't solve the error. Any ideas on what to do? Is there something else I can try?
 

Brum

Recruit
Are you using the same 0.903 BRF file as before? Sometimes I had to re-save the BRF or re-import all my materials, textures, mesh's into a new BRF file, not sure if that may help make the BRF compatible with 1.x.
 
Top Bottom