In Progress Get a BAN message while joining a LAN game.

Users who are viewing this thread


When I try to join a LAN game hosted by my son I get "you are banned from this server". Vice versa it's exactly the same issue. We use two different copies of M&B Warband running on two different steam accounts. Its been like this for only a few days. Before, everything went fine.


Sergeant Knight
1)is this warband? or NW or VC or WFAS?
2) have u tried to put it into internet via "official server list" or simply "local area network"?
3)is this native of what game u play or a mod
4) in case of mod: are u using "WSE" >warband script enhancer"?
5) what sort of serial key are u using? DO NOT put ur key in here! i know u know but saftey 1st:
steam key?= 5X5/////or warband key? = 4x4 hand can u verify "Game owner ship" at front page? : button is in right upper corner. Just login same pass as you looged in here!
5b) have u activated your game on more than one pc via one key? no panic!! I have done so and i think its legit but it might cast a differences!
6) have u or have u had any problems to join games in internet offical server list?

Edit 1) as u c ur not alone! i came about that while trying test my mod :sad:
its 3 or some below ur topic! A forums admin contacted me and told me:
"We are investigating this issue. Thanks!"
taleworlds updated the backend servers and he hoped that might solve but it didnt. Since that no word.............. Friday at 1:43 PM
Last edited:


Thanks for letting me know!
We normally play native but we got the same issue when we tried to go on Napoleonic War. We use different copies with different 4x4 steam keys. We both can join internet server games on the list. It's just then LAN game we can't start.


Haven't tried so far. I haven't read anything regarding a solution. The problem was first time told of weeks ago. Looks like Taleworlds doesn't even care.
Still have the same issue - when a device attempts to join a Server (Hosted or Dedicated) on the same network it gives the error "You are banned from this server". All other public servers work as normal.

Hope they fix the issue soon as it makes Map testing a lonely task :sad:


I haven't figured out a solution to this issue, but I do have a workaround.

For whatever reason, it's impossible to join a game being hosted on the same network, dedicated server or not. This is true even for a dedicated server being hosted on the same computer.

You can still host a dedicated server, port forward, and have it be accessible to friends on different networks at different locations. In order to be able to play with those friends--to connect to your own server--the only workaround I've found is to host a dedicated server on a separate computer and port forward like normal; then on the computer running my game, I use a VPN to trick the game into thinking I'm on another network.

I use Nord ( to do this, it's very simple--just install the windows application, run it, and click on any country. You should be able to connect to your server as normal. Unfortunately Nord isn't free; this might work with other VPN's but I haven't tested any so I'm not sure. For LAN parties, everyone can use the same Nord account to connect to a dedicated server being run on a separate computer.

Hope this helps!

MArdA TaleWorlds

Community Support & Localization
Community Support
Thanks for the report. Forwarded to our server team. We are investigating this issue. Sadly, we can't give any ETA at the moment. Sorry for the inconvenience.
Top Bottom