"Generic application error" Issues after windows 10 update

cryptyknumidium

Recruit
Best answers
0
I have played Warband for a long time now, over two pc's, and never got this.
Everythign was working fine, updated windows 10 last night.

Went to play the game, and after the intro animation, I got this error message.

"Generic application error. Enable debug output for detailed information.

Switching to reference rasterizer, a software device theat implements the entire Direct3D feature set, but runs very slowly."

After pressing ok on that, I then get this

"Warning : Nothing will be rendered.
The reference rendering device was selected, but your computer only has a reduced-functionality reference device installed. Install the DirectX SDK to get the full reference device".

And then the game opens in a small window, nothing happens, and it crashes.

I searched for some answers on google, tried quite a few out, running as admin, compatibility modes, made sure I had DirectX (I do), update your video drivers (I did), a bunch of messing around in video settings, reinstalling, verifying it through steam.

The only way the game launches is in windowed mode. Which isn't particularly good, and when I try to fullscreen it, I just get

"Could not reset the Direct3D device.

This application will now exit."

So I'm stuck, not sure what to do, and I hope someone here can help me resume stabbing some Irish lords in the face.
 

chiefwhosm

Recruit
Best answers
0
Hi,
    I realise I'm jumping forums here to post this but anyway I just posted a response to someone else with the same issue over on the original M&B game forum because I too am getting this since updating last night on every M&B game and like you, I too found windowed mode is now the only fix since upgrading to the 1709 Fall Creators Upgrade.


 

cryptyknumidium

Recruit
Best answers
0
Ah, so it is something to do with the recent update.

As for the playing it in windowed, it is all I have found to work, I messed about with drivers and stuff like you did too.

If you, before the loading screen for the game starts, click and drag (not click the full screen button) the window to fill up your screen, you can play it full screen bordered.

If you find anything that fixed it properly, do tell me.
 

chiefwhosm

Recruit
Best answers
0
Just to keep you and anyone else finding the thread with the same problem up to date, I've submitted a support request through the Taleworlds support site (since the bug submission website didn't work for me) in the hope we can get this resolved.

Hi,
  A couple of us are having problems (see error messages on forums) with Mount & Blade, Warband and Fire & Sword since upgrading to Windows 10 1709 (Fall Creators Update) in that we can no longer run the games in fullscreen mode.

https://forums.taleworlds.com/index.php/topic,372672.0.html
https://forums.taleworlds.com/index.php/topic,373337.0.html

The games were working fine right up until the upgrade installed, and the crash happens before the log files are written.

I have noticed that when in Windowed mode you can change the renderer device and if you do so the game crashes with the same error, so I'm wondering if the game in fullscreen mode isn't finding a valid renderer and falling back to the debug renderer, but that's just a guess.

Please could somebody look into the problem, and rather than post to my email address post to the forums as I suspect there'll may soon be more users experiencing the problem as they get enforced upgrades to 1709.

Thanks.
 

chiefwhosm

Recruit
Best answers
0
Okay so maybe it's all coincidence so I won't point fingers however this is a little odd.......

I discovered that it wasn't just M&B having issues, several older games were no longer working without windowed mode since 1709.
I therefore decided to dual boot linux, and run  the older games through wine.
Linux failed to install a working grub bootloader, windows dvd wouldn't repair its' boot loader.
Reinstalled windows, latest gpu drivers etc.
Tried one of the other games I'd been having issues with - yay! working fullscreen.
Then tried M&B, same crash as before.
Tried the other game again - now only works in windowed mode.

Coincidence?
 

cryptyknumidium

Recruit
Best answers
0
Just gonna bump, see if anyone knows anything yet.

Playing in windowed and hoping to expand the window before the game fully starts every time is starting to get tiring.
 
Best answers
0
Just tried to play yesterday for the first time in a while and I'm getting this, too. Everything I have is updated, googled for 2 days now, all "fixes" don't work. Putting it in windowed mode is the only thing that works, and that sucks. Not that I have many other games, but they all run fine. Only Warband is giving me this problem.
 

cryptyknumidium

Recruit
Best answers
0
Yep, nothing works, and it's definetly a Mount and Blade option.

And I can't find any answers either.

Only windowed works, and even then some of the large mods just refuse to work at all.

Also you have to be real quick about making the window full-screen, or it just crashes.
 

ArnulfFloyd

Knight at Arms
Best answers
0
I not have this problem despite my PC has Windows 10, I playing in borderless windowed mode and large mods as Pendor start flawless because I using Steam version of game
 

Attar

Sergeant
WF&SM&BWB
Best answers
0
ArnulfFloyd said:
I not have this problem despite my PC has Windows 10, I playing in borderless windowed mode and large mods as Pendor start flawless because I using Steam version of game
I remember that when Windows 10 was released back then a lot of gamers had problem with M&B once they upgraded.
 

cryptyknumidium

Recruit
Best answers
0
Right.

The problem fixed itself.

Just today.

Turned my PC on, launched the game, the resolution setting has defaulted, Running in fullscreen 720p, changed it to my native 1080p, works flawlessly, like the problem had never occured.

Nothing changed about my PC overnight, there where no updates, no windows updates, no driver updates.

It just decided to be nice.

I have yet to try a large mod though.
 
Best answers
0
I'm still getting the problem if I try to play the game normally through the game launcher (steam version of the game and even tried the gog version I have as well, since I like gog, same thing). That is, full screen and I get the crash after the Taleworlds intro. Generic application error, Direct3D device and so on.

I've found a fix, for me at least, here on the site.
https://forums.taleworlds.com/index.php/topic,163113.0.html

Put the game in windowed mode and then follow STARik's post on using Autohotkey to put the game into Fullscreen Borderless mode.
 

rowyerboat

Recruit
Best answers
0
Sorry to necro, but I'm having this exact problem and there don't appear to be any reliable solutions posted despite many threads on this issue, dating back years. Played this game a bunch back in the day, but I can't recall whether or not that was pre-Windows 10. Windowed mode does not work for me, as it did for some others. Have tried most/all the other suggestions with no luck. Sad now :sad: One strange thing I noticed about the launcher is t hat although it keeps all other changes I make to the video settings, it always resets antialiasing to "off." Not sure if that's related, but just seemed odd...

Edit: well, now I feel dumb. I noticed that suddenly Stellaris wasn't working either, so I just restarted my computer, which got both games to work. Problem must have been related to playing System Shock 2 earlier, which must have done some funny stuff to my PC's graphics voodoo that required a system reboot. Oh well, at least this game is working!
 
Last edited: