In Progress Game with current update is unplayable. Lags and stutter nonstop

Users who are viewing this thread

Version number
e1.5.9
Branch
Main
Modded/unmodded
No, I didn't use any mods.

Doofus

Veteran
I expect some problems, I realize its early access, but it used to be you could apply to join a beta for free that, quite frankly, didn't have as many problems as this has.

I've been in 'early access' now for almost a year. The first month there was a lot of improvement, but since then it seems like its mostly new content or refined graphics being added, not improvements and fixes, not changes to things so they make more sense (I still don't know whether to laugh or get pissed when they tell me they don't want to fight me when they are raiding one of my villages or besieging one of my towns castles. The least they could do is give me an option to start the attack by saying something like 'Well, if you didn't want to fight me you shouldn't have attacked my holdings').

I don't agree with the comment about paying full price. I believe I paid about $40 for this when full price these days would be around $50-$60. But, $40 is a lot to pay for an unfinished game with worsening lag/crash issues that apparently never will be fixed. If they want to charge for a weak beta they could at least have charged something more reasonable like $15-$20.
 

Zorion_no

Regular
I expect some problems, I realize its early access, but it used to be you could apply to join a beta for free that, quite frankly, didn't have as many problems as this has.

I've been in 'early access' now for almost a year. The first month there was a lot of improvement, but since then it seems like its mostly new content or refined graphics being added, not improvements and fixes, not changes to things so they make more sense (I still don't know whether to laugh or get pissed when they tell me they don't want to fight me when they are raiding one of my villages or besieging one of my towns castles. The least they could do is give me an option to start the attack by saying something like 'Well, if you didn't want to fight me you shouldn't have attacked my holdings').

I don't agree with the comment about paying full price. I believe I paid about $40 for this when full price these days would be around $50-$60. But, $40 is a lot to pay for an unfinished game with worsening lag/crash issues that apparently never will be fixed. If they want to charge for a weak beta they could at least have charged something more reasonable like $15-$20.

But thats the problem though, this isnt BETA stage, this is ALPHA, so its a much more raw game, some features may not yet be there or be implemented as we've since we started 1 years ago.

So if you belived it to be in a beta stage then I get why you can be upset, but still thats on you for not doing enough research prior to buying (Caveat Emptor)

I got the impression(that its in an Alpha stage( from the get go that its as with all Early Acess games(typically, some though sell it as that but its paid beta).

Sorry if I come of as rude/unkind etc, but in this regard I think the fault/blame isnt on the company.

Just take breaks, when its in an unplayable stage, I did with 1.56 or 1.57 when there was that horrible issues where you couldnt play for more than 10-15 min until they patched it(I did figure out some dark magic tricks that did help for me, but they where prolly false positives).

Or as the other guy suggest a nice list of mods if you dont mind doing that, I just want the vanilla experience for EA myself, but I'm acheing to use mods lol
 

Doofus

Veteran
If this is Alpha, then what was the 7 years prior to Early Access? I haven't played an early Access before and wouldn't have this time (particularly with the price high for an uncompleted game), but I enjoyed Warband a real lot. Quite frankly, I expected something between Beta and actual release.

On the actual topic of this thread though, I've noticed an extreme amount of lag just from accessing and closing the Encyclopedia. I sort of wonder if this current lag is coming from the encyclopedia. Think about it...someone dies in a battle, the encyclopedia needs to update. A town/castle gets taken in a battle...the encyclopedia needs to update. You enter a town..the encyclopedia needs to update where everyone was last seen. I crash more after battles when closing the loot screen than I do in the actual battles. I suspect the most recent unplayable stuff is related to a programming bug/glitch in the encyclopedia.
 

Radimov

Recruit
If this is Alpha, then what was the 7 years prior to Early Access? I haven't played an early Access before and wouldn't have this time (particularly with the price high for an uncompleted game), but I enjoyed Warband a real lot. Quite frankly, I expected something between Beta and actual release.

On the actual topic of this thread though, I've noticed an extreme amount of lag just from accessing and closing the Encyclopedia. I sort of wonder if this current lag is coming from the encyclopedia. Think about it...someone dies in a battle, the encyclopedia needs to update. A town/castle gets taken in a battle...the encyclopedia needs to update. You enter a town..the encyclopedia needs to update where everyone was last seen. I crash more after battles when closing the loot screen than I do in the actual battles. I suspect the most recent unplayable stuff is related to a programming bug/glitch in the encyclopedia.
Disclosure: im not an expert (just to avoid ...stuff :meh: ).

The "recent" issue it's not only affecting the Encyclopedia, it's affecting anything that involves reading of data, you notice more on Encyclopedia because it has a lot of information so it's more obvious the issue, but if you have the cheats enabled you have access to almost all items and you can experience the same issue there ( in obvious slow reading stuttery image ).

I also tested this: if you open the Encyclopedia or inventory or whatever and you close right after you will experience the same issue, so it means the even if you don't need the data anymore the game is still reading the stuff you requested before, and until it finishes you are gonna experience the issue, so if the data is being transfered with issues you will get low framerates that's why we can cleary see the "lag" that people are calling, it's just frame drops.

I would say that the process/method of accessing data something went wrong in the middle of e1.5.9, because i'm almost 100% sure that at the beginning of the e1.5.9 i didn't experience this issue and then out of nowhere it started doing...

Again i'm no expert.
 

Zorion_no

Regular
But again this bug/issue though is isolated to pockets of the users, I for one have no such issue at all.
Or not that its noticable unless you "look for it".
While its slower yes, sometimes, its not makeing the game feel less fun for me(as tbh I dont really use the index, and the lag on the overhead map I have nothing).

So its figurering out what specific makes it this bad for certain and thus remedy it, this isnt always as easy if its a general issue where everyone get hit, then its more 1+1=2, here its 1+0 =2 so finding the right number so to speak isnt as obvious(Not sure this is a good explanation at all).

As for the 7 year reference, ehem from what I understand they scrapped the engine a few times, and thus had to reset the progress more or less.
As the first one just didnt deliver what they needed for the game.

Generally speaking makeing games is typically a 3-5 years process for most titles out there though, so if they had to reset after x years, then it depends on how far they are.
 

danudet

Recruit
My game ran perfectly fine until the last graphics hot fix. Then the campaign map, inventory, and troop menus slowed to a stutter. For the first time last night, I ran into an issue on an open battlefield, its taking MUCH longer to load in the troops. I have 141 mixed troops, mostly cav/ horse archers and was facing 90 enemy troops, mostly infantry and archers (I think they had maybe 8 cav total). My setting are set for 500 troops total and I've never had issues like this before. I dont think its the number of troops, as the night before, I took on 250 strong enemy with 114 troops with no problems.
 

momo1

Sergeant
M&BWBWF&SNWVC
My game ran perfectly fine until the last graphics hot fix. Then the campaign map, inventory, and troop menus slowed to a stutter. For the first time last night, I ran into an issue on an open battlefield, its taking MUCH longer to load in the troops. I have 141 mixed troops, mostly cav/ horse archers and was facing 90 enemy troops, mostly infantry and archers (I think they had maybe 8 cav total). My setting are set for 500 troops total and I've never had issues like this before. I dont think its the number of troops, as the night before, I took on 250 strong enemy with 114 troops with no problems.
Which game version are you using?
 

Doofus

Veteran
I'm almost positive that the issue started with the 4/29 update. Something in there killed it. If they would just back that out I'm pretty sure it would fix the issue, at least for me.
 

Zorion_no

Regular
Hm.. looking at settings I dont suffer from this issue, but I was thinking to suggest you could tweak a setting, but I dont find it anymore?

There used to be a setting that let you switch the load between the GPU vs CPU, so if you had a weak cpu but strong gpu(like me) you could make the gpu do all the heavy lifting.

Maybe this is the case for some of you guys that the load is now shifted from a to b and you should have it on the opposite or in the middle?

Just a shot in the dark that might be worth haveing a look at?
 
Hm.. looking at settings I dont suffer from this issue, but I was thinking to suggest you could tweak a setting, but I dont find it anymore?

There used to be a setting that let you switch the load between the GPU vs CPU, so if you had a weak cpu but strong gpu(like me) you could make the gpu do all the heavy lifting.

Maybe this is the case for some of you guys that the load is now shifted from a to b and you should have it on the opposite or in the middle?

Just a shot in the dark that might be worth haveing a look at?

Either that or it has something to do with the internet. Cause if i turn off my router it runs alot smoother (still lots of stuttering and lags but a bit better overall) . For whatever reason that is i have not the slightest idea.
 

Zorion_no

Regular
Either that or it has something to do with the internet. Cause if i turn off my router it runs alot smoother (still lots of stuttering and lags but a bit better overall) . For whatever reason that is i have not the slightest idea.
This latter with the net being an issue, I did have when I suffered from the graphics issue aswell.(But that was in 1.56 or soemthing not the current, theese I'm haveing 0 issues) so it sucks when it happends, but "give it time and they'll fix it"(atleast did for me and the others until that hotfix was applied.

My take on that is that it could be the battleeye? the anti-cheat mechanics messing with things(even if I never play multi at all, so it shouldnt really fire up anways imo).
 
Well i guess i have to wait the next patch and hope for the best as this thread is pretty much dead and the communication is as well. Didn't see anything from dev side adressing said issues anywhere else so i guess we can close this thread and do nothing about it.

Well i liked M&B and Warband. And Fire and Sword as well as Viking Conquest. Hell i even play Napoleonic wars multiplayer from time to time as it is still alot of fun trying to win a siege or defend a castle.

But i guess this is the end for me and Taleworlds.

Thanks for the past games and the wonderful experience in hundreds of hours and mod support to enjoy.

Also Thank you for at least a time i could enjoy M&B2 Bannerlords until it got unplayable for me. I hope that some day i can return and enjoy this game once more. As for now i don't see this happening and like i did with Cyberpunk 2077 i simply have to rethink who i am giving my money to in the future....
 

Zorion_no

Regular
Well i guess i have to wait the next patch and hope for the best as this thread is pretty much dead and the communication is as well. Didn't see anything from dev side adressing said issues anywhere else so i guess we can close this thread and do nothing about it.

Well i liked M&B and Warband. And Fire and Sword as well as Viking Conquest. Hell i even play Napoleonic wars multiplayer from time to time as it is still alot of fun trying to win a siege or defend a castle.

But i guess this is the end for me and Taleworlds.

Thanks for the past games and the wonderful experience in hundreds of hours and mod support to enjoy.

Also Thank you for at least a time i could enjoy M&B2 Bannerlords until it got unplayable for me. I hope that some day i can return and enjoy this game once more. As for now i don't see this happening and like i did with Cyberpunk 2077 i simply have to rethink who i am giving my money to in the future....
Did you try upgrading to 1.60 ?
There was further improvements in it overall.


But keep in mind Early Acess is well not the final release, I have no idea when it will go full retail.

You final conclusion though, is a solid one, be more cautions with buying games etc. Cp2077 had 1 issue from the start for him, so I instantly asked steam for a refund, and got it.
Other than that I'm in BG3 EA which is fun and all, but their pace of content being shipped is "too slow for me" and I didnt find it that "fun to replay" to be fair.

Bannerlord I've clocked in over 2,2k hrs so even before relase I would say that I have got my moneys worth lol.
I'm not suffering from issues that make it unplayable, I'm suffering more from issues on their game design decisions that I makes it unenjoyable(just too much war overall, I wont play with mods during EA, but in retail this will be fixed on my end.)
 
Did you try upgrading to 1.60 ?
There was further improvements in it overall.


But keep in mind Early Acess is well not the final release, I have no idea when it will go full retail.

You final conclusion though, is a solid one, be more cautions with buying games etc. Cp2077 had 1 issue from the start for him, so I instantly asked steam for a refund, and got it.
Other than that I'm in BG3 EA which is fun and all, but their pace of content being shipped is "too slow for me" and I didnt find it that "fun to replay" to be fair.

Bannerlord I've clocked in over 2,2k hrs so even before relase I would say that I have got my moneys worth lol.
I'm not suffering from issues that make it unplayable, I'm suffering more from issues on their game design decisions that I makes it unenjoyable(just too much war overall, I wont play with mods during EA, but in retail this will be fixed on my end.)

Yeah i did but no changes. It still works better when i turn my router off. For what reason that influences the game is beyond me. CP2077 was an issue for me as i pre ordered the deluxe edition so a refund was not really possible as i set it up for myself as christmas gift and with all the family parties etc i didn't get to play till mid january and shut myself out of any reviews to spoiler myself with anything. But once i played a bit i was really mind blown how bad the game was. Never pre order anything in my life except rockstar games. They seem to get the working game on release everytime.

Well i only have 314 hours in Bannerlord but if i could play it i would probably be around 1,5k counting in the time i have. But it is unplayable for me since over half a year so i have given up on getting a fix for any of those problem in the near future. Who knows maybe it gets better in the full retail version. All i can do is wait and pray.

But thanks for the insights man. Glad at least someone can enjoy the game :smile:
 

TKnight

Sergeant
Ngl have the same issue on global map, game stutters here and there permanently, also everytime when opening the inventory, character takes like 5 seconds to load and many items are taking time to load too, until then i see only his hands, same loading time issue is happening when i want to buy something from a city, same stutter,same lag, and more loading time , also when joining some battles it takes more time to load characters in , so for few seconds i am playing as an invisible man vs invisible army (playing on 1.6)
Experiencing this everytime really made me stop playing the game often, its just frustrating...
(Gaming laptop - Gtx - 1080 11 gb / 32gb ram)
(Playing on medium settings)
 
Last edited:

Redsniper6

Recruit
Just came back to the game after a few months and set it to the stable branch. Brand new game, still the same laggy menus. Use to be no issue with menu lag or overhead map and now that basically 70% of the game. Still unplayable. Which is weird because at one point a few months ago I played on a beta patch and it the menu lag was almost virtually gone. Now coming back and setting it to the stable branch is like no improvements have been made to correct these issues at all. I cant stand have to wait 5-7 seconds for the game to catch up and not lag and run smooth before I can open another menu or click on a new settlement on the map before having to wait another 5-7 seconds for the game to catch up and I can continue playing. No lag anywhere else either. Massive field battles and Keep battles are fine. But god forbid I need to open a menu the game can't handle it and now needs to wait 5-7 seconds for it to process what the **** opening a menu is.
 
Just came back to the game after a few months and set it to the stable branch. Brand new game, still the same laggy menus. Use to be no issue with menu lag or overhead map and now that basically 70% of the game. Still unplayable. Which is weird because at one point a few months ago I played on a beta patch and it the menu lag was almost virtually gone. Now coming back and setting it to the stable branch is like no improvements have been made to correct these issues at all. I cant stand have to wait 5-7 seconds for the game to catch up and not lag and run smooth before I can open another menu or click on a new settlement on the map before having to wait another 5-7 seconds for the game to catch up and I can continue playing. No lag anywhere else either. Massive field battles and Keep battles are fine. But god forbid I need to open a menu the game can't handle it and now needs to wait 5-7 seconds for it to process what the **** opening a menu is.

Welcome to the Club. I can play AC Valhalla everything maxed out graphic and performance wise. But god forbid i open a menu ingame or try to run around the map. The game still stutters like hell and while my rig surely can handle big battles the game engine can not. After talking with some friends who are from IT one of them made a good point.

Either the game has issues with multiple CPU`s by failing to either switch between them or adressing the different cores to split work in between them. Which in this day and age is a mere joke as Dualcore was standard almost 10 years ago and quadcore is the new standard if not even octa. This however would be an engine problem and could be fixed software wise.

Combine this knowledge with the fact that the game engine fails to correctly communicate with the RAM as well and simply does not take more if avaliable as it seems to be capped and you start to realize something is very off here.
Which results in the game demanding more resources but not finding any more RAM despite it being there and therefore delegating every need for more resources to the CPU. And if the CPU's are also not handled correctly by the software you get a never ending story till the game crashes to desktop as a single or dual CPU can not work properly without sharing their work correctly in between them. The game will demand more and more till the CPU can not give anymore and the major RAM stays unused bringing the game right back to desktop.

According to my friend this seems to be the most likely case as there is no way this game could overstress 4 cores and 32GB RAM at the same time while AC Valhalla does not.

However he also said. Software wise it sounds easy to fix. But only on paper. In reality thats a real clusterf.... of a game engine bug that you need to find and smooth out. Cause it could be almost anything causing that problem

I already have given up getting a fix for that as regardless the version the game is unplayable for me. But if someone could use that information to find a fix for himself i might share it. Could be totally wrong as well but you never know.

Good Luck man :smile:
 
Top Bottom