Need More Info Game will not start after launcher

Users who are viewing this thread

Version number
e.1.5.7
Branch
Main
Modded/unmodded
Yes, but I removed mods.

tobbentobben

Recruit
Hello

My Bannerlord game doesnt seem to want to start, after the launcher appears when i launch on steam.

After numerous attempts to try to fix this issue, hours has gone by and nothing works.

Im trying to play bannerlord on steam, but the launcher appears, i press singleplayer and play, but nothing appears on screen. Nothing in the task bar, but in task manager the process is up, but nothing physically happens.

When i start it directly from .exe in directory, the launcher doesnt start, and nothing happens.

Ive tried several solutions found online, 15+++

updating windows
updating .net, visual c++ etc.
restarting pc
reinstalling 3+ times, removing mods and have clean install
started game via .exe in directory
firewall exceptions
file opener exceptions
running as admin.


this is only a few of them, but nothing work
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Can you check if you use any anti-virus software to make sure the game is not blacklisted?
Can you try deleting the Configs folder in the documents folder and try again?
 
having problems similar to this too, i've done everything op has done plus what you asked about config as well, no luck, this is ridiculous, why wont my game just start?
 
okay, after deleting config AND launching thru bannerlord.native I can play, but anytime i go thru the launcher the config folder comes back and will not allow the game to get past a black screen after pressing play.
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Can you install these again and try again launching from Steam? Not really related to the black screen but it will at least can help on not launching. We are planning to change that black screen as well, soon.
Installing Missing Necessary Dependencies
These dependencies are installed through Steam with the first time installation. But we have seen reports confirm that there are some players that these dependencies were missing even though they launch the game from Steam.To installing missing necessary dependencies try downloading and running the following executables:
 

brednbudr

Recruit
Hello

My Bannerlord game doesnt seem to want to start, after the launcher appears when i launch on steam.

After numerous attempts to try to fix this issue, hours has gone by and nothing works.

Im trying to play bannerlord on steam, but the launcher appears, i press singleplayer and play, but nothing appears on screen. Nothing in the task bar, but in task manager the process is up, but nothing physically happens.

When i start it directly from .exe in directory, the launcher doesnt start, and nothing happens.

Ive tried several solutions found online, 15+++

updating windows
updating .net, visual c++ etc.
restarting pc
reinstalling 3+ times, removing mods and have clean install
started game via .exe in directory
firewall exceptions
file opener exceptions
running as admin.


this is only a few of them, but nothing work
I have the exact same issue after building a new PC and trying to play Bannerlord 2 on it. Tried everything, including everything posted in this thread. You may be able to spot the game running in your Task Manager > Details. It's always there, doing nothing, and i have to end task just to get steam to stop claiming the game is running.
 

GoyaBeansX

Recruit
Hello

My Bannerlord game doesnt seem to want to start, after the launcher appears when i launch on steam.

After numerous attempts to try to fix this issue, hours has gone by and nothing works.

Im trying to play bannerlord on steam, but the launcher appears, i press singleplayer and play, but nothing appears on screen. Nothing in the task bar, but in task manager the process is up, but nothing physically happens.

When i start it directly from .exe in directory, the launcher doesnt start, and nothing happens.

Ive tried several solutions found online, 15+++

updating windows
updating .net, visual c++ etc.
restarting pc
reinstalling 3+ times, removing mods and have clean install
started game via .exe in directory
firewall exceptions
file opener exceptions
running as admin.


this is only a few of them, but nothing work
I FIGURED IT OUT

I was having this same issue and i was pulling my hair out trying to figure it out but it was simple!

Log into OneDrive. This fixed it for me I swear to god. I figured it out because I couldnt delete the config file as mentioned in this thread because "my cloud service was not open" so i oppened one drive and logged in, and it worked right away.

I hope this helps others.
 
Top Bottom