• Please note that we've updated the Mount & Blade II: Bannerlord save file system which requires you to take certain steps in order for your save files to be compatible with e1.7.1 and any later updates. You can find the instructions here.

In Progress Game Will Not Read GPU, Crash on launch

Users who are viewing this thread

Version number
1.6.4
Branch
Main
Modded/unmodded
No, I didn't use any mods.
Dump identifier (optional)
2021-09-19_15.55.33_36e0a68dd5b830292ccdc20261714a0d
Summary: Game will not read Nvidia GPU but will read intergrated graphics card (Intel (R) HD Graphics Card 4600). Can force launch by going into Config Text file and setting Graphic Adapter = 1, however this only allows it to launch on the Intel card. When attempting to put it on the NVIDIA card in the menu of the game, crash on restart. Only change in recent memory to my computer is the adding of 16 GBs of RAM and updating of drivers to most recent patch. No other changes on my end.
May be related to DirectX 11 as the error message read as: "Direct3D 11 device has been removed or reset. Please restart the game. An internal issue has prevented the Driver from carrying out the specified operation. The Driver's state is probably suspect and the application should not continue." And a second message stating:
"d3d_decive_->CreateTextue2D at rglGPU_Device::create_texture_from_image failed! The GPU device instance has been suspended. Use GetDeviceRemovedReason to determine the appropriate action."

This has been occurring since the last public release

How to Reproduce: Crash on launch
Have you used cheats and if so which: N/A
Scene Name (if related): n/a
Media (Screenshots & Video): n/a
Computer Specs:
OS: Windows 8.1 64 bit
GPU: NVIDIA GeForce GTX 860M
GPU Driver Version: 471.96 (rolled back to 466.77 for testing, still crashed)
CPU: Intel(R) Core i7-4710 2.5 Ghz
RAM: 24 GB
Motherboard: ASUS G751JM
Storage Device (HDD/SSD): Hard Drive
 

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
Hello, can you please have a look at our crash checklist and common workarounds list? If none of the suggestions listed solve the issue please try a clean install and let me know if the issue is persistent.

Clean Install
The clean install is removing every single game-related file from your computer and installing the game again. Why do you need to remove the game while you just want to remove the modifications? Unfortunately, some of the modifications do not just add a new modules folder but also change or adds contents to the existent modules folder. Without a reinstall, we can't be sure those files are unchanged.

To perform a Clean Install, Uninstall the game. You can do that by right-clicking the game on Steam Library and selecting Delete Local Content. Delete all folders related to the game that remains after the uninstallation. The folders that might have files inside:
Steam: C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord
Epic: C:\Program Files\Epic Games\Mount & Blade II Bannerlord
C:\Users\USERNAME\Documents\Mount and Blade II Bannerlord
C:\ProgramData\Mount and Blade II Bannerlord

Note: You'll need to allow Windows to display hidden folders and files to see the ProgramData folder and its contents.
 
Hello, can you please have a look at our crash checklist and common workarounds list? If none of the suggestions listed solve the issue please try a clean install and let me know if the issue is persistent.
Attempted everything in list, including redownloading executables suggested and complete clean install. Same crash. Attempted starting from Win64 Shipping Client application Bannerlord Native. Same Crash. Attempted adding more virtual memory. Crash at start up.
I did manage to get it to work with my intergrated GPU through the config file, but it only can process 1024 MB, not nearly enough for a decent experience. I also went to confirm my Nvidia GPU was still in good condition and it passed tests. It also has been updated to the latest software.
It should be noted it gives me 2 crash reports after the crash if that helps at all... Is there a way for me to submit both?
 

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
Hey, i have forwarded the issue and the Crash ID you have sent to the devs. Thank you for your time and sorry for the inconvenience. I will update the post if our QA team requires more info about the issue.
 

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
Hello, can you reproduce the issue on the version e1.6.5? If you can, please revert the version to e1.6.3 and let me know if the issue is persistent on that version as well?
 
Hello, can you reproduce the issue on the version e1.6.5? If you can, please revert the version to e1.6.3 and let me know if the issue is persistent on that version as well?
Update: Confirmed to happen on both 1.6.5 and 1.6.3, made sure to verify files before attempting. Same crash message
Will also attempt on further previous versions.
 

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
Hello, i have informed the devs about it being persistent. Thank you for your time and sorry for any inconvenience.
 
Top Bottom