• Please note that we've updated the Mount & Blade II: Bannerlord save file system which requires you to take certain steps in order for your save files to be compatible with e1.7.1 and any later updates. You can find the instructions here.

Need More Info Game unplayable: Crashes with error message: “d3d_device_context_-> Map at rglGPU_device::lock_texture failed

Users who are viewing this thread

Version number
e1.5.10
Branch
Main
Modded/unmodded
No, I didn't use any mods.
Dump identifier (optional)
2021-07-28_20.41.31_291044ae4e3f0c1618e55bbd3844ad40

celeby8

Recruit
Summary: Game crashes with a pop-up every time it loads into battle or town.
How to Reproduce: Loading screen transition into any town/fights. (100% Reproducible)
Have you used cheats and if so which: No mods or cheats.
Scene Name (if related): Loading screen
Media (Screenshots & Video): https://streamable.com/70sv36
Computer Specs:
OS: Windows 10 Pro 64-Bit
GPU: AMD Radeon RX 5700
GPU Driver Version: AMD Radeon Adrenalin 21.7.2
CPU: AMD Ryzen 7 2700X
RAM: 16 GB
Motherboard: AsRock B450 Pro4
Storage Device (HDD/SSD): Corsair Force LX SSD

Tried putting graphics setting to very low and disabling any GPU overclocks. Still same error.
Also have tried uninstalling and reinstalling the game and my graphics driver.
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Please make sure that your GPU drivers and OS is up to date. If you are up to date you can try expanding the swap size on your hard disk. You can find more info regarding this here. If you are still experiencing the crashes you can also try enabling Vsync in the game settings.
 

celeby8

Recruit
My OS and GPU drivers are up to date.
I also have followed the paging file tutorial.
Enabled Vsync.
Nothing has changed. Still the same crash.
 

tom784

Recruit
I have similar problem
game crashes with the same error message
I did what I could from tips above and it keeps coming, sometimes just after launching the game.

OS: Win 10
GPU: AMD radeon R7 200 series
GPU Driver Version: 21.4.1 (up to date)
2021-08-09_17.21.34_a01ab0c67d394d5271c7bc92ec29d7e7

Edit: I got it again, few minutes after restarting computer.
 
Last edited:

Mirshko Ordo

Recruit
I've recently found that Vsync on full (video settings tab) and turning on Nvidia DLSS (performance settings tab) significantly reduced the frequency of the error. it only happens every once in a while now instead of every 4 minutes
 

celeby8

Recruit
I've spend alot of time troubleshooting, finding other forum posts here and applying whatever fix that had worked for other users.
Here's what I have tried.

1) Put the game on safe mode and lowest graphics possible.
2) Granted full access and admin permission for Bannerlord.exe, Bannerlord.Native.exe, and Bannerlord_BE.exe. Source
3) Added TdrDelay to registry and set it to 100. Source
4) Turned sharpness to 0.00, set FPS limit to 60.
5) Tried using different resolutions and fullscreen , windowed, borderless mode
6) Tested with Vsync off, on, half.
6) Factory reset my graphics driver (AMD Radeon Ver. 21.7.2)
7) Disabled GPU Autotuning and all the optimization features in AMD Radeon software.

I know its not my graphic card that is faulty because I have ran plenty of graphic intensive games (e.g Monster hunter world, Cyberpunk, Ark) with no errors/crashes. The game is stable and runs fine on the overworld and tutorial (training camp). The benchmark testing is also stable. I just could not get past the loading screen when loading into battles/towns.

I am wondering is this an AMD Radeon graphics specific issue?
 

tom784

Recruit
I've recently found that Vsync on full (video settings tab) and turning on Nvidia DLSS (performance settings tab) significantly reduced the frequency of the error. it only happens every once in a while now instead of every 4 minutes
Setting Vsync to full seemed to help.
I did it before but I guess it got reset after update.

edit:
it helped for a while, now crashes are back, sometimes every 5-15 minutes
2021-08-11_20.01.01_a01ab0c67d394d5271c7bc92ec29d7e7
 
Last edited:

Mirshko Ordo

Recruit
Setting Vsync to full seemed to help.
I did it before but I guess it got reset after update.

edit:
it helped for a while, now crashes are back, sometimes every 5-15 minutes
2021-08-11_20.01.01_a01ab0c67d394d5271c7bc92ec29d7e7
whenever the game crashed like that for me, it would reset all the settings. This would turn vsync back off, so you'll need to turn it back off. to make sure it takes, I always rebooted the game after turning it on, checking to make sure it was still on, then playing. that usually does it for me now, though it will still crash on occasion
 

tom784

Recruit
whenever the game crashed like that for me, it would reset all the settings. This would turn vsync back off, so you'll need to turn it back off. to make sure it takes, I always rebooted the game after turning it on, checking to make sure it was still on, then playing. that usually does it for me now, though it will still crash on occasion
For me it keeps settings after crash and (unfortunately) keeps crashing :wink:
 

celeby8

Recruit
Hope this info helps the Dev:

Comparing the rgl_log, part of a normal log looks like this:

[13:34:20.974] ----------Mission-AddTeam-Defender

[13:34:20.974] ----------Mission-AddTeam-Attacker

[13:34:20.974] ----------Mission-AddTeam-Attacker

[13:34:21.048] -------MissionScreen-OnActivate

[13:34:21.387] Bake Terrain
[13:34:21.520] Bake Terrain
[13:34:21.587] Bake Terrain
[13:34:29.323] I called EndMission

[13:34:29.387] I called EndMissionInternal

[13:34:29.461] -------MissionScreen-OnDeactivate

[13:34:29.556] PopScreen

[13:34:29.556] TaleWorlds.MountAndBlade.View.Screen.MissionScreen::HandlePause

[13:34:29.556] TaleWorlds.MountAndBlade.View.Screen.MissionScreen::HandleDeactivate

[13:34:29.556] -------MissionScreen-OnDeactivate

[13:34:29.556]TaleWorlds.MountAndBlade.View.Screen.MissionScreen::HandleFinalize

[13:34:29.556] -------MissionScreen-OnFinalize


Below is my rgl_log. Seems like it crashes after the first "Bake Terrain".

[15:55:41.990] ----------Mission-AddTeam-Defender

[15:55:41.990] ----------Mission-AddTeam-Attacker

[15:55:41.991] ----------Mission-AddTeam-Attacker

[15:55:42.194] -------MissionScreen-OnActivate

[15:55:42.468] Bake Terrain
[15:55:42.576]
<##########################################################################################>

[15:55:42.576]
ERROR: d3d_device_context_->Map at rglGPU_device::lock_texture Failed!
The GPU device instance has been suspended. Use GetDeviceRemovedReason to determine the appropriate action.

Last Executed Marker: Only supported with nVidia GPUs and Windows 10.
[15:55:42.576] #[email protected]{1AA2F91A53F04AA2BB7952B4CEA4E2C6} (1): 0:6615805
#[email protected]{1AA2F91A53F04AA2BB7952B4CEA4E2C6} (1): 0:991606
#[email protected]{1AA2F91A53F04AA2BB7952B4CEA4E2C6} (1): 0:425803
#[email protected]{1AA2F91A53F04AA2BB7952B4CEA4E2C6} (1): 0:6512938
#[email protected]{1AA2F91A53F04AA2BB7952B4CEA4E2C6} (1): 0:2165580
#[email protected]{1AA2F91A53F04AA2BB7952B4CEA4E2C6} (1): 0:1487432
#[email protected]{1AA2F91A53F04AA2BB7952B4CEA4E2C6} (1): 0:829562
#[email protected]{1AA2F91A53F04AA2BB7952B4CEA4E2C6} (1): 0:796270
#[email protected]{1AA2F91A53F04AA2BB7952B4CEA4E2C6} (1): 0:2064353
#[email protected]{1AA2F91A53F04AA2BB7952B4CEA4E2C6} (1): 0:2069086
#[email protected]{1AA2F91A53F04AA2BB7952B4CEA4E2C6} (1): 0:2094885
#[email protected]{1AA2F91A53F04AA2BB7952B4CEA4E2C6} (1): 0:2092283
#Tale[email protected]{1AA2F91A53F04AA2BB7952B4CEA4E2C6} (1): 0:2096263
#[email protected]{152B3C4F5E1CE0FE6BC36E9F0F2B10E6} (1): 0:138162
#[email protected]{D584D67E76DDF05D4DB0215E8B905F22} (1): 0:94260
#[email protected]{46F6F5C30E7147E46F2A953A5DAF201A} (1): 0:337489
-----------------------------------------------
at TaleWorlds.DotNet.Managed.GetStackTraceStr(Int32 skipCount)

[15:55:42.601] Bake Terrain
 
Top Bottom