MP Fantasy Game of Thrones Roleplay Module [RELEASED] [Source Code released!]

Users who are viewing this thread

What error?
64-bit or 32-bit?

Please insert: wse_crash_log.txt, rgl_log.txt & wse_log.txt.
Rgl_log txt is
Starting new log file.
Version:  1.168

-- OS: Microsoft  (build 9200), 64-bit
-- RAM: Available physical RAM: 4095MB/4096MB
-- CPU: AMD FX(tm)-4300 Quad-Core Processor (AuthenticAMD)
- L1 cache size: 16K
- L2 cache size: 2048K
- CPU Features: FPU MMX SSE SSE2 SSE3 HTT MmxExt
- Number of CPUs: 4 ( Speed: ~3817MHz / ~3817MHz / ~3817MHz / ~3817MHz )

-- GPU:
- D3D9 Adapter: 0 / Driver: nvd3dum.dll / Description: NVIDIA GeForce GTX 650
- Texture Memory: 4095 ( Available Texture Memory: 4061 )

Received stats and achievements from Steam

Processing Ini File {
Module_name =  GoT_Roleplay_Module
Num Hints =  22
Setting Map Min X =  -180.000000
Setting Map Max X =  180.000000
Setting Map Min Y =  -145.000000
Setting Map Max Y =  145.000000
Setting Time Multiplier =  0.250000
Setting Seeing Range Multiplier =  6.500000
Setting Track Spotting Multiplier =  0.800000
Setting player_wounded_treshold =  5.000000
Setting hero_wounded_treshold =  15.000000
Setting Skill Prisoner Management Bonus =  5
Setting Skill Leadership Bonus =  3
Setting Base Companion Limit =  20
Setting player_xp_multiplier =  2.000000
Setting hero_xp_multiplier =  2.000000
Setting regulars_xp_multiplier =  3.000000
Setting damage_interrupt_attack_treshold =  3.000000
Setting damage_interrupt_attack_treshold_mp =  1.000000
Setting armor_soak_factor_against_cut =  0.800000
Setting armor_soak_factor_against_pierce =  0.650000
Setting armor_soak_factor_against_blunt =  0.500000
Setting armor_reduction_factor_against_cut =  1.000000
Setting armor_reduction_factor_against_pierce =  0.500000
Setting armor_reduction_factor_against_blunt =  0.750000
Setting horse_charge_damage_multiplier =  1.000000
Setting couched_lance_damage_multiplier =  0.650000
Setting fall_damage_multiplier =  1.500000
Setting shield_penetration_offset =  30.000000

the wse log text is
WSE Loader by cmpxchg8b, K700 (Build date: Jul 12 2015 00:04:46)
OS version: 6.2.9200 SP 0.0
Command line: -m GoTRP_0.3
WSE path: C:\Program Files (x86)\Steam\SteamApps\common\MountBlade Warband\
Could not find mb_warband.exe or mb_warband_dedicated.exe

and the crash log is

WSE Loader by cmpxchg8b, K700 (Build date: Jul 12 2015 00:04:46)
OS version: 6.2.9200 SP 0.0
Command line: -m GoTRP_0.3
WSE path: C:\Program Files (x86)\Steam\SteamApps\common\MountBlade Warband\
Game executable origin: command line
Game executable path: .\mb_warband_vanilla.exe
Game executable checksum: 2A399540
Library path: C:\Program Files (x86)\Steam\SteamApps\common\MountBlade Warband\WSELib.dll
Failed to create Warband process

Windows API error
Code: 5
Message: Access is denied.

Does this exist?: C:\Program Files (x86)\Steam\SteamApps\common\MountBlade Warband\WSELib.dll
What Windows?
Hey I need your help.
Always I join the server, my game crashes without any error, just the windows "program has an error" (or something like that, have not eng windows) but that one with the green bar from left to right ^^
So what I can do against it? Halp me please!

Okay please go through this step program.
In your main folder, do these files exist: mb_warband_vanilla.exe, msvcp120.dll, run_gotrp.bat, wse_settings.ini, WSELib.dll, WSELibDedicated.dll, WSELibNoSSE.dll, WSELoader.exe, WSELoaderServer.exe.
Go to Modules. Go into GoTRP_0.3.

Check that:
Resource should have 104 files.
Textures should have 2.331 files.

Go back to main folder.
Make right click on run_gotrp.bat go to edit/open in notepad:
WSELoader.exe -p .\mb_warband_vanilla.exe -m GoTRP_0.3
this has to be in there. Is it?

If all that is make this:

right click on them. Properties. Compatibility. Check start program as administrator. Ok.

Start again.
everything is present in your message, except the vanilla file, it keeps destroying itself when I run the program and when I try and run the vanilla file. it has to be the vanilla file problem
Look your virus container, the anti-virus maybe removes it because it thinks it's a a virus and add a exception for the software.
Dude thanks for the link, but I already did that thrice before. I am no newbie in computer stuff^^
So let me explain from beginning:
I installed the patched version as you did in video.
I run the run batch file, then I say yes as admin.
Then I load the game, it says even WSE all right.
Then I click on your server and the game crashes. Installed the mod already three times and tried to start with different settings but I never can join
It's weird because it's the exact game version as I use and for others it works.
Copy wse_crash_log.txt content in here.
> Info
Time: 25/08/2015 09:12:34
Type: EXCEPTION_UNKNOWN (0xE06D7363, 0x19930520, 0x0329DC90, 0x0085BEB0)
> Stack trace
0x75A2812F KERNELBASE.dll+0x812F (RaiseException+0x54)
0x0062A5B3 mb_warband_vanilla.exe+0x22A5B3 (??+0x0)
0x0062A56A mb_warband_vanilla.exe+0x22A56A (??+0x0)
0x00443B19 mb_warband_vanilla.exe+0x43B19 (??+0x0)
0x00445108 mb_warband_vanilla.exe+0x45108 (??+0x0)
0x00445196 mb_warband_vanilla.exe+0x45196 (??+0x0)
0x006328DE mb_warband_vanilla.exe+0x2328DE (??+0x0)
0x00629BD0 mb_warband_vanilla.exe+0x229BD0 (??+0x0)
0x004430A7 mb_warband_vanilla.exe+0x430A7 (??+0x0)
0x00445E3D mb_warband_vanilla.exe+0x45E3D (??+0x0)
0x006328DE mb_warband_vanilla.exe+0x2328DE (??+0x0)
0x00629BD0 mb_warband_vanilla.exe+0x229BD0 (??+0x0)
0x004430A7 mb_warband_vanilla.exe+0x430A7 (??+0x0)
0x00445E3D mb_warband_vanilla.exe+0x45E3D (??+0x0)
0x004460FD mb_warband_vanilla.exe+0x460FD (??+0x0)
0x004460FD mb_warband_vanilla.exe+0x460FD (??+0x0)
Lorraines more like left back to PW because they don't want to kill the player base.
Some of them still play GoTRP.
They are not killing or they dont want to kill it on purpose, its just that no one can fight against them.
We are not sure. The most problems do 32-bit systems have.
E.G: 5 of around 15 32-bit people can't get it running.
      all 64-bit people can get it running.

It's pretty weird.

- remove the man at war class from the Nights Watch, this is to make the fights between the wildlings and the NW more infantry based.
- nerf the wildlings range weapons, but give them stronger armor and melee weapons.
- give the Night Watch and the Wildlings free unlimited starter gear, that isnt effective much but can be used for self defense (****ty basic armor and melee weapon), this is to prevent nude people running (immersion matters) because they dont have money to buy equipment, and it will also encourage wildlings to raid more making them a real threat.
- disallow custom named factions, to preserve immersion.
- remove most of the native items for the same reason.
- nerf mount based spears so the module doesnt become a cav-tincan fest like PW currently is.
- not sure if possible already but allow Castle Black to be captured by wildlings, once that happens they should be allowed to KOS everyone and capture other territory.
- not sure if this option already exists, but capping the bank to 100k would be a good idea.

This is all I can remember so far, module has potential and I had really great fun the first day when we had like a major battle on foot with the wildlings in castle black, when they attacked in waves. Sadly, thats rare now and most of the fights are turning into PW fights now, where cav and archers have most of the fights and its about having better armor and gear instead of tactics and skill. The module will die fast if people dont have a gameplay incentive to play this over PW, by that I mean a different way of combat not just cav, archers and tincans.

Keep in mind I didnt suggest things that I believe are already worked on, like making the outside of the wall a more larger explorable area, and scene improvements to make it even more closer to a game of thrones themed scene.

Good luck with the mod.
Top Bottom