Need More Info Game doesn't launch

Users who are viewing this thread

Version number
No, I didn't use any mods.
Hi, i've reinstalled M&B2 on steam since a long time now, i've click on play, the Launcher appear, i click on play on soloplayer (with and without mods) but nothing launch after that and i can't quit the game until i restart my computer. i've a TalesWorlds.Mountandblade.exe in my task manager that i can't close at all. i've tried to launch the multiplayer as well. thank you. i've also tried to reinstall the game and verify the files of the game.

Computer Specs:
OS: Windows 10 Pro
GPU: AMD RAdeon RX 6700XT
GPU Driver Version:
CPU: Intel Core i7-9700 3.00 GHz
RAM: 48 Go
Motherboard: B360 Gaming plus (MS-7B22)
Storage Device (HDD/SSD): SSD
I had exact same issue.
After deleting the mentioned folder from documents, it worked.

Bro, try it too, it's not in the steam folder, in my case at least it was right in document.

I have windows 11
I have the same issue and deleted the Bannerlord folder by going through steam apps and common, but there isn't anything in my documents folder to delete, it's just empty. If you have fixed your issue please tell me how.
Top Bottom