• Please note that we've updated the Mount & Blade II: Bannerlord save file system which requires you to take certain steps in order for your save files to be compatible with e1.7.1 and any later updates. You can find the instructions here.

Resolved Game Crashing On Launch

Users who are viewing this thread

Version number
e1.6.4
Branch
Main
Modded/unmodded
No, I didn't use any mods.
Dump identifier (optional)
2021-11-26_21.19.35_50e093a59b8ebcec4d310c2ba9c5192b

Squidymon

Recruit
I've tried all the fix suggestions in the Crash Checklist and Common Issues and Workarounds posts.

I purchased the game at launch and played for several months with no issues using the same hardware as listed below. I ultimately uninstalled the game to make space on my PC but last week I got the itch to play the game again so I re-installed and much to my dismay I can't even get the game to start. Since then I've attempted everything in the crash checklist and common issues and workarounds posts including multiple clean re-installs.

Summary: Game crashes on first load screen every time I click play on the launcher.
How to Reproduce: Every time I click play from the launcher and it goes to the first loading screen
Have you used cheats and if so which: No
Computer Specs:
OS: Windows 10
GPU: NVIDIA GeForce RTX 2070 Super
GPU Driver Version: 496.13
CPU: AMD Ryzen 5 3600 6-Core Processor 3.60 GHz
RAM: 16 GB
Motherboard: ASRock B450M/ac
Storage Device (HDD/SSD): Lexar SSD 500 GBs
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Forwarded to the QA team for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
This crash is the same crash as in the thread I quoted. Here is how the other user fixed the issue. You can update your drivers.
Hey there, so I am able to start the game again. I don't know how exactly I managed to do that, but it seems it was connected to my drivers (probably GPU). I did reset the drivers, updated them and tried this like 2-3 times and the problem disappeared for some reason.

Unfortunately, after some time I was able to play the game I now face some severe connection problems due to unknown reason. As this is another thing, I may open another thread on it as the original issue is solved. Thanks anyway!
 

Squidymon

Recruit
This crash is the same crash as in the thread I quoted. Here is how the other user fixed the issue. You can update your drivers.
Thank you !

It appears you were right, the issue was related to my GPU driver being installed incorrectly. I uninstalled and re-installed the driver and now the game is launching without issue !

Please feel free to mark this thread as resolved :smile:
 
Top Bottom