Need More Info Game Crashes while launching or starting a battle

Users who are viewing this thread

Version number
1.2.9
Branch
Main
Modded/unmodded
No, I didn't use any mods.
Dump identifier (optional)
2024-06-01_11.52.11_bd2d1e154e91c14109fae4db45e21684
Summary: Game crashes giving gpu error Direct3D 11 device has been removed. Downloaded the game on 3 Pcs now and still get the same crash on every device. After investigation it seems the game gives command to gpu wich cant be done, this leads into a gpu overload causing a driver timeout causing windows to think gpu got removed ending in the direct 3d error. Pls help i already tried everything.
How to Reproduce: every start
Have you used cheats and if so which: no
Scene Name (if related):2024-06-01_11.52.11_bd2d1e154e91c14109fae4db45e21684
Media (Screenshots & Video):
Computer Specs:
OS:
GPU:rx 5700xt and rtx3070
GPU Driver Version: current
CPU: i7 8700k and i7 9700k
RAM: 64gb ddr4
Motherboard: asos prime z370a
Storage Device (HDD/SSD): ssd
 
Yeah I'm having the same issue as well. Mine keeps happening when I'm about to attack a castle, and it crashes during the loading screen to where you can select troop placements
 
The dump reports shows that it is a GPU crash. You can try updating your GPU drivers and expanding the swap size on your hard disk but please note that it is not a solid fix. You can find more info regarding this here. Thanks for reporting and sorry for any inconvenience!
 
Thx for ure reply, still the game isnt playable sadly. Neither on my pc with amd or nvidia card. Seems like couple people here experience the same crash. I did update the drivers and can run aaa games in 4k without problems on those cards. Is there anything else i can do or maye game related for those crashes. Its sad not be able playing this good game.
 
Are you getting d3d_device_context_ -> Map at rglGPU_device::lock_texture Failed! The GPU device instance has been suspended?
See if reverting to amd driver version 23.5.2 works. Many people have this issue, the fix also works consistently, see this thread
 
Back
Top Bottom