Resolved Game crashes in the middle of every battle

Users who are viewing this thread

Version number
1.2.5
Branch
Beta
Modded/unmodded
Yes, but I removed mods.

Mortilas

Recruit
Summary: in the middle of every battle, the game crashes.
How to Reproduce: attacking villages, attacking lords, attacking bandits.
Have you used cheats and if so which: no
Scene Name (if related): all battle scenes
Media (Screenshots & Video):
Computer Specs:
OS: Windows
GPU: NVIDIA GeForce GTX 1060
GPU Driver Version: 545.92
CPU: Intel® Core™ i5-8300H CPU @ 2.30GHz
RAM: 16 Go
Motherboard: not sure where to find that
Storage Device (HDD/SSD): KINGSTON RBUSNS8180S3128GJ, KINGSTON SNV2S1000G
 
Happens for me as well, particular bigger battles that take a while. Didn't have a single crash on the 1.2.x beta branch until the 1.2.5 update. Started a new campaign on the 1.2.5 as well.
 
Have the same issue windows event display point to.NET Runtime something like:



Anwendung: TaleWorlds.MountAndBlade.Launcher.exe Frameworkversion: v4.0.30319 Beschreibung: Der Prozess wurde aufgrund einer unbehandelten Ausnahme beendet. Ausnahmeinformationen: Ausnahmecode c0000005, Ausnahmeadresse 00007FFF3EA9508B Stapel:


EventData

TaleWorlds.MountAndBlade.Launcher.exe

1.0.0.0

655e04b2

TaleWorlds.Native.dll

0.0.0.0

655e04b0

c0000005

000000000052508b

2f58

01da207d0696a968

F:\steam\steamapps\common\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.Launcher.exe

F:\steam\steamapps\common\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client\TaleWorlds.Native.dll

1c7e7e40-9f25-48d1-8306-3bc5cb2e8a8f


 
I just tested a large siege with 1.2.5, no problem, but I have 24G GPU mem, that seems to make the difference .. sadly to say.

This game dislikes old GPUs with 8G mem or less. Old shader seems to be a main cause of crashes.
 
I just tested a large siege with 1.2.5, no problem, but I have 24G GPU mem, that seems to make the difference .. sadly to say.

This game dislikes old GPUs with 8G mem or less. Old shader seems to be a main cause of crashes.

Deleted all old shaders, and still crashes. Haven't had a single crash on 1.2.x before 1.2.5 dropped.
 
I just tested a large siege with 1.2.5, no problem, but I have 24G GPU mem, that seems to make the difference .. sadly to say.

This game dislikes old GPUs with 8G mem or less. Old shader seems to be a main cause of crashes.
I have 4G mem but i played 1.2.4 with no problems... even in big battles 1000 troops..
 
I also had no problems with 1.2.4 also i have a 6900 xt with 16GB. So i dont see a Problem why it should crash now when with 1.2.4 i was able to have big fights with 1000 troops and now it crash with 200-300 troops on the screen. Also the game crash without any error it just go straight back to windows. But what i noticed is that my graphic card is working much harder with new beta than before even in low troop fights. It is consistently using 80-100% of work load. So definitely there is sth wrong in new Beta.
 
I also had no problems with 1.2.4 also i have a 6900 xt with 16GB. So i dont see a Problem why it should crash now when with 1.2.4 i was able to have big fights with 1000 troops and now it crash with 200-300 troops on the screen. Also the game crash without any error it just go straight back to windows. But what i noticed is that my graphic card is working much harder with new beta than before even in low troop fights. It is consistently using 80-100% of work load. So definitely there is sth wrong in new Beta.

Game been running just fine up to now on my rtx3060 12gb. It's not a hardware issue, this is a issue that 1.2.5 did introduce. Have like uploaded 5-6 crash reports so far, and will just put the game on hold until it get sorted, can't rally roll back to 1.2.4.
 
Hi, could you share a save file right before the battle starts? This goes for anyone in this report who experiences this crash.
Do you have a save file of the session that you experienced this issue? With your save file, we can reproduce the issue much easier and faster. You can find your save file here: "C:\Users\username\Documents\Mount and Blade II Bannerlord\Game Saves"
To send us a ticket, please visit the www.taleworlds.com site and login to your forum account from the top right. Click on "My Account" and then click on "My Open Tickets". You can create a ticket there and include the save file as well as the forum link of this thread. You can find more info about how to upload files to us with the new ticketing system here. Thanks for reporting and sorry for any inconvenience!
 
Hi, could you share a save file right before the battle starts? This goes for anyone in this report who experiences this crash.

It doesn't seem to be save dependent. I mean, I can save, do a battle, it crash, I reload, I complete the battle, it doesn't crash.
 
Hi, could you share a save file right before the battle starts? This goes for anyone in this report who experiences this crash.
I uploaded a save of my game in the following ticket : https://www.taleworlds.com/en/Ticket/Item/1347
The issue happens since 1.2.5. It didn't happen in 1.2.4.
So far, it seems that :
- the game doesn't crash on some battles without an obvious reason, and can happen repeatedly on others.
- the game doesn't crash during sieges (at least, I haven't experienced it in 4-5 sieges)
 
Summary: in the middle of every battle, the game crashes.
How to Reproduce: attacking villages, attacking lords, attacking bandits.
Have you used cheats and if so which: no
Scene Name (if related): all battle scenes
Media (Screenshots & Video):
Computer Specs:
OS: Windows
GPU: NVIDIA GeForce GTX 1060
GPU Driver Version: 545.92
CPU: Intel® Core™ i5-8300H CPU @ 2.30GHz
RAM: 16 Go
Motherboard: not sure where to find that
Storage Device (HDD/SSD): KINGSTON RBUSNS8180S3128GJ, KINGSTON SNV2S1000G. Elevate your Las Vegas event with our premium party rentals, turning every occasion into a memorable celebration. From stylish decor to cutting-edge entertainment setups, our Las Vegas party rentals ensure your event stands out in the city of lights.
  1. Update GPU Drivers:Ensure that your NVIDIA GeForce GTX 1060 drivers are up-to-date. Visit the official NVIDIA website to download and install the latest drivers compatible with your GPU.
  2. Verify Game Files:Steam users can verify the integrity of game files. Right-click on the game in your Steam library, go to Properties > Local Files, and click "Verify Integrity of Game Files." This ensures that game files are not corrupted.
  3. Check for Mod Conflicts:If you are using mods, disable them temporarily to check if they are causing the crashes. Some mods might not be compatible with the current game version.
  4. Lower Graphics Settings:Reduce in-game graphics settings to see if the crashes persist. Lowering settings can sometimes alleviate issues related to GPU strain.
  5. Check for Overheating:Monitor your system's temperature while playing. Overheating can cause crashes. Ensure that your laptop's cooling system is working efficiently, and consider using a cooling pad.
  6. Update Operating System:Make sure your Windows operating system is up-to-date with the latest updates and patches.
  7. Contact Game Support:If the issue persists, consider reaching out to the game's official support channels. They may provide specific guidance or be aware of ongoing issues and potential solutions.
 
I've got ticket answer:

TW Support - 11/29/2023 1:06:45 PM (UTC)​

Hey, i can see the disabled mods on your save file and we do not offer support for the mods or modded games. Can you try to reproduce the issue on a new campaign after manually removing all the mod files and verifying the integrity of the game files. If the issue is persistent on a new, unmodded campaign please let me know.

Did you guys tried a new campaign without mods used in previous version?
 
I've been informed that the issue you have reported is fixed. The fix will be in part of the future patches. Thanks for reporting and sorry for any inconvenience!
 
Back
Top Bottom