• We'll be making a number of structural changes to the forums on Wednesday, 06.12.2023. No downtime is expected. Read more here.

Resolved game crashes e1.4.3 (on version 1.4.2 everything works)

Users who are viewing this thread

I see at least two different crashes in this thread.

Most(%90) of the dumps I checked out here are from Windows 7. Our engine team is investigating why this is happening and working on a fix at the moment.

For crashes that are happening after pressing PLAY and loading the game, I implemented a fix and should be live with the next update. For the meantime players with this crash can delete their LauncherData.xml file in the "C:\Users\{USERNAME}\Documents\Mount and Blade II Bannerlord\Configs" folder.

If your OS is not Windows 7 and you've tried deleting LauncherData.xml and the crash is still happening, post your dump information like @Fala above and I'll take a look.
 
I see at least two different crashes in this thread.

Most(%90) of the dumps I checked out here are from Windows 7. Our engine team is investigating why this is happening and working on a fix at the moment.

For crashes that are happening after pressing PLAY and loading the game, I implemented a fix and should be live with the next update. For the meantime players with this crash can delete their LauncherData.xml file in the "C:\Users\{USERNAME}\Documents\Mount and Blade II Bannerlord\Configs" folder.

If your OS is not Windows 7 and you've tried deleting LauncherData.xml and the crash is still happening, post your dump information like @Fala above and I'll take a look.


Windows 8 os for me.
2020-08-12_14.38.05_1abb694eef2916e2a05a3f8faad79d7b

Crash after contrast or brightness settings selected.
 
I see at least two different crashes in this thread.

Most(%90) of the dumps I checked out here are from Windows 7. Our engine team is investigating why this is happening and working on a fix at the moment.

For crashes that are happening after pressing PLAY and loading the game, I implemented a fix and should be live with the next update. For the meantime players with this crash can delete their LauncherData.xml file in the "C:\Users\{USERNAME}\Documents\Mount and Blade II Bannerlord\Configs" folder.

If your OS is not Windows 7 and you've tried deleting LauncherData.xml and the crash is still happening, post your dump information like @Fala above and I'll take a look.
Windows 8.1

Crash after contrast or brightness settings selected if I choose to launch the game in safe mode (after the game crashed when finished creating my character as in my previous message)

Dump 2020-08-12_15.10.53_3e4ecc9358ef8168a13e88ba1fd5ce1c
 
I'll add my dump to the collection (Windows 7): 2020-08-10_11.43.45_7ab357bfc398218ae12a5e1b2b480808

Verifying files and removing everything Bannerlord related (including LauncherData.xml) and reinstalling the entire game doesn't help.
 
removed LauncherData.xml (Win 10) Dump 2020-08-12_17.25.51_827b867628e94a1904426d71eaf042c4 crashed(((
 
Tried again after the latest hotfix still the same issue. Sent new dump. WIndows 8.1


2020-08-12_19.20.46_3e4ecc9358ef8168a13e88ba1fd5ce1c
 
I have the same crash now it seems, only starting after the hotfix today. I was playing directly before the hotfix, and now it crashes whenever you try and load or start a new game. Also there is an error that comes up about a shader on the initial loading screen. I verified files and removed any mods as well as LauncherData.xml and it still doesn't work.

Windows 10.

2020-08-12_23.55.03_52a073536f6701c2dc07c6edb65ade40
 
Windows 8.1, updated from Windows 8 when the game launched

2020-08-13_03.14.55_3ef88490cfd6baecea565aaea4922b35

This one crashed when entering the campaign from character creation. I had sent a different one a few minutes earlier after installing the hotfix that crashed at Exposure Adjustment but I had closed the dump identifier window too quickly.
To clarify, after the Exposure Adjustment crash I was not prompted to adjust it when I relaunched the game. This allowed me to go through character creation. If I had gone to options and attempted to use Exposure Adjustment then the game would've certainly crashed then.
 
Windows 10 corporate 2016
Crash when changing exposure and creating a new character, deleting the config file did not help.
2020-08-13_05.46.40_35ed83973e6ee7308b7819385078ae76
2020-08-13_05.53.05_35ed83973e6ee7308b7819385078ae76
 
Can users in this thread confirm, is everyone seeing this error before the game crashes?

 
I checked crashing after Brightness setting screen and crashing after creating a character. Neither of those show this error.
 
Have you installed a mod called Fixed Launcher? If so please remove it and try again. There are some reports from the forums that some players have experienced the same shader issue and it got resolved after they removed that modification.
But, we are aware of the Shader issue and currently, our engine team is investigating this issue on our end as well.
 
Have you installed a mod called Fixed Launcher? If so please remove it and try again. There are some reports from the forums that some players have experienced the same shader issue and it got resolved after they removed that modification.
But, we are aware of the Shader issue and currently, our engine team is investigating this issue on our end as well.
I missed that that is also a mod! I disabled everything in modules but skipped that as it isn't installed as a module. Yes I had that installed. I had to dig around a little to remove all the files.

That fixed all the issues. I no longer get the shader error and the game no longer crashes. I was able to start a new campaign now and load other saves.

Strange the the launcher would cause those problems, I really wouldn't have thought. Thanks for the help and sorry for the trouble!
 
Back
Top Bottom