Resolved game crashes e1.4.3 (on version 1.4.2 everything works)

Users who are viewing this thread

I would like to share my experience with this "bug" and the steps I took to fix it, and hopefully it might help some of you to get back in the game.

A couple month ago I "broke" the game by accidentally making all the .sav files to opened by Notepad. Immediately after this I wasn't able to start a new game or click on saved games option in the menu as the game would crash. I've tried everything: unassigned default program(Notepad) to open .sav files in Windows; restored Windows to last checkpoint; verified files via Steam; uninstalled and reinstalled both Steam and BannerLord. Yet, the game still would not work. After that, I copied my saved games in this folder "C:\Users\YOUR USER NAME\Documents\Mount and Blade II Bannerlord " and stored them in a safe place and deleted all the contents in the above mentioned folder. By default I had Steam Cloud Synchronization ON for this game and I noticed that it would restore all the deleted files right away including my saved games folder. So, I disabled Steam Cloud for Bannerlord

, again deleted all the content in the above mentioned folder, and I was able to start a new game and to make a new save. Then I returned my saved games back in the folder and everything was working flawlessly after that. I can't promise that this is a 100% solution, but disabling Steam Cloud definitely worked for me.

Hopefully this will help someone. GL
I would like to share my experience with this "bug" and the steps I took to fix it, and hopefully it might help some of you to get back in the game.

A couple month ago I "broke" the game by accidentally making all the .файлы sav для открытия с помощью блокнота. Сразу после этого я не смог запустить новую игру или нажать на опцию сохраненные игры в меню, так как игра рухнула бы. I've tried everything: unassigned default program(Notepad) to open .sav файлы в Windows; восстановил Windows до последней контрольной точки; проверил файлы через Steam; удалил и переустановил как Steam, так и BannerLord. Но игра все равно не получалась. После этого я скопировал свои сохраненные игры в эту папку "C:\Users\YOUR имя пользователя\Documents\Mount and Blade II Bannerlord" и сохранил их в безопасном месте, а также удалил все содержимое в вышеупомянутую папку. По умолчанию у меня была включена синхронизация Steam Cloud для этой игры, и я заметил, что она сразу же восстановит все удаленные файлы, включая мою сохраненную папку игр. So, I disabled Steam Cloud for Bannerlord

, снова удалил все содержимое в вышеупомянутой папке, и я смог запустить новую игру и сделать новое сохранение. Затем я вернул сохраненные игры обратно в папку, и после этого все работало безупречно. I can't promise that this is a 100% solution, but disabling Steam Cloud definitely worked for me.

Надеюсь, это кому-то поможет. GL

It didn’t help me, I deleted all the files associated with the game and it didn’t help. But on patch 1.4.2 everything works fine, I think this is a bug of patch 1.4.3
Forwarding this issue to the QA team for further investigation. Thanks for reporting.

In the meantime, it would help us better if you can post your computer specs and if you upload the config and rgl_log files as asked here and as the original poster did.

*the files starting with "rgl_log" and "rgl_log_errors" in the following directory: "C:\ProgramData\Mount and Blade II Bannerlord\logs"
*the engine_config.txt file at "C:\Users\YOUR USER NAME\Documents\Mount and Blade II Bannerlord\Configs"

You can upload these at Please paste the link to this thread in the description box on the upload website so I can identify it.

Brief information: the game crashes when you start and when you start a new game, reinstalled the game, did a sytem recovery on my laptop, deleted config files and log files did not help also
How to play: when starting and when starting a new game
Quest / settlement name (if related):
Laptop: Aspire VN7-591G
Version: e1.4.3
Installed community changes: none
computer specifications:
OS: Win 8.1
GPU: Nvidia Geforce GTX 860m
Processor: Intel(R) core(TM) i5-4210 CPU @2.90GHz
RAM: 12 GB
Storage Device (HDD / SSD): ssd
Same problem here. Never had any big issues with Bannerlord before, but the 1.4.3 beta started causing this problem for me. Unable to start a new game beyond character customization. Tried uninstalling reinstalling verifying game files etc etc

Windows 7, 16GB RAM, Nvidia Geforce GTX 1080, i7 4770k cpu.
1.4.2 was fine before and after this update but on 1.4.3 i crash on these conditions:
custom Battle, entering Campaign after Character creation, entering Saved Games with older saved games present, and attempting to change the Exposure setting from the Options menu.

All these options make the game unplayable on 1.4.3 since not even custom battles work.

OS: Windows 7 SP1
GPU: AMD R9 270x, upgraded to RX580
CPU: Intel Core i7-3770k
Storage Device (HDD/SSD): SSD
Last edited:
Same problem (Calibration screen crash & and new campaign/custom battle) with e1.4.3.236299, but 1.4.2 works fine.

OS: Win 8.1 Pro 64x
GPU: Nvidia Quadro K1200 4GB (latest driver for this card 441.66)
CPU: Xeon E3 1225 v2
Motherboard: HP 6300 Pro
Storage Device (HDD/SSD): SSD 120GB

Clean start (Documents & ProgramData folders deleted).

Just uploaded mentioned files to
A day or two will pass by and I'll get an idea to try to solve the problem, or at least make it so I don't have the problem anymore. I updated Windows 8.1. That didn't help. I thought somehow Steam was messing something up with download region so I entirely uninstalled the game including deleting the game folders in ProgramData and /Users/Documents/, changed my download region from Boston to Netherlands and then Turkey - Ankara, cleared my Steam download cache for good measure, and reinstalled. No benefit there either. I tried running from my SSD and then my hard drive. Nothing good there. The obvious things like Running as Administrator and Compatibility Mode were the first things I tried and exhausted.
I'm just so mystified as to how it's not working on all of our varied PC's with entirely different setups while still working fine for other people. Where is the common link?
This sounds like the same issue for me. I tried reverting to an older version, and then this bug kicked in, and now it has completely broken the game for me (any versions tried). After I deleted the bannerlord data in documents, not it crashes after the opening calibration screen.

Game 100% broken after 45 hours into a play through, very sad, I was really excited or this and enjoying it a lot.
Same error, uploaded files, sys specs:
Windows 10 pro Version 1709, build 16299.1087
Xeon W-2145 CPU @ 3.7 GHz
NVidia Quadro P400 graphics card
I'm forwarding every document uploaded. I don't have any news for now, but our developers are hard at work. I will update this thread if I hear back from them about this specific issue.
Exactly the same bug as people described: crashing when trying to adjust exposure levels or just after character creation on 1.4.3
Windows 7 SP1
Top Bottom