Resolved game crashes e1.4.3 (on version 1.4.2 everything works)

Users who are viewing this thread


Brief information: the game crashes when you start and when you start a new game, reinstalled the game, deleted config files and log files did not help
How to play: when starting and when starting a new game
Quest / settlement name (if related):
Media (Screenshots And Video):
Version: e1.4.3
Installed community changes: none
computer specifications:
OS: Win 10
GPU: 1080ti
Processor: i7 8700k
RAM: 32 GB
Storage Device (HDD / SSD): ssd

sent log files to with a link on this topic
Last edited:
My game also crashes when I click "Saved games" and after creating a new character. No mods, all deleted. 1.4.3
I'm in a similar situation. The game crashes whenever I try to start a new game.

How to play: Whenever selecting custom battle or when trying to start a new game. Character creation works but when I try to continue from the difficulty selection screen the game crashes. The game also crashed when attempting to access the Saved Games list but deleting my saves using Windows Explorer fixed that particular issue.
Version: e1.4.3
Installed community changes: None, at first I had BannerPaste but I then deleted it and continue to run into the same issue.
computer specifications:
OS: Win 8.1
GPU: GTX 670
Processor: i5-3570K
RAM: 16 GB DDR3, 1600 MHz, CAS Latency 9
Motherboard: ASRock Z77 Extreme6
Storage Device 1 (HDD / SSD): SSD; Samsung 840 Pro 256GB, location of Windows install and Bannerlord steam library
Storage Device 2 (HDD / SSD): HDD: Western Digital Caviar Black 1TB, location of main Steam install

EDIT: I'd like to add another crash to the list and ask if you guys have encountered similar.
If you go to the Options menu and in the Video section choose Exposure Adjustment, does your game crash as well there? Mine does. So the list of crashes so far for me are: Custom Battle, entering Campaign after Character creation, entering Saved Games with older saved games present, and attempting to change the Exposure setting from the Options menu. All this in the 1.4.3 patch, I was able to play the game in 1.4.2
Last edited:
Everything is the same for me, it's strange that everything works for others, and there is no answer from technical support.:xf-cry:
I have super slow internet, so while I spend 18 hours getting the patch I like to read all the crash reports and remind myself even good internet wouldn't really help me play sooner. Maybe hotfix by the time I'm done.
There are many errors like this in the log file: Can't find the particle system.
Most likely you need to wait for the patch.
But it's strange that they can't tell us that they are aware of the problem, or the problem is on the user's side.
There are many errors like this in the log file: Can't find the particle system.
Most likely you need to wait for the patch.
But it's strange that they can't tell us that they are aware of the problem, or the problem is on the user's side.
I just hope they won't suggest us verifying the game's files, cause that doesn't help (I tried). I also tried reverting the game back to 1.4.2 and updating to 1.4.3 again, so I doesn't help either.
I updated my graphics drivers and even Java to boot, and then did a whole uninstall/reinstall while still opted into 1.4.3
The game still crashes upon entering the Exposure Adjustment screen as well as the other occurrences mentioned previously, so uninstalling then reinstalling didn't fix the problem either.

My rgl log mentions particles like Sanya's, and it has some "Unable to find item to add dependency" lines. I sent a report in using their post-crash report tool.

EDIT: Just as an experiment I rolled my game to the live 1.4.2 version and was able to play then. I then put it back to the 1.4.3 beta and it was still crashing at the same areas. I double-checked that I had the Visual C++ Redistributables and .net Core and Framework mentioned in the stickied Windows 7 Not Launching thread (though I am running Windows 8.1). I tried various combinations of compatibility mode and running as administrator including having neither on the various Bannerlord .exes and it changed nothing. It seems we all have a similar problem but our PCs vary greatly in performance (Sanya's rig blows mine out of the water). I am totally mystified as to what is causing this for all of us.
Last edited:
I also confirm this report. Can't even start the game. Sometimes crashes at launcher when i press on "play" and sometimes during loading screen when i start new game. I had to delete all saved and config files to open the game otherwise it stucks at white screen.
So many people here have this issue that doesn't even allow them to play the game - and we're still enjoying the silence.
Also plagued by the same crash. Win7 / i5-3330 / 1050 Ti / 16GB. Deleted all old mods and saves, verified install. Haven't tried updating drivers or deleting all config for the game but doesn't seem to have helped anyone else. Curious if having Bannerlord installed to a drive different from Windows and Steam is related. Changing my display resolution from 1600x1200 to 1600x900 also got me a weird black box that stole window focus from Bannerlord and it couldn't be maximized again without a relaunch. Just glad I'm not the only one unable to launch 1.4.3, I'm sure whatever's causing it will get hotfixed.
Forwarding this issue to the QA team for further investigation. Thanks for reporting.

In the meantime, it would help us better if you can post your computer specs and if you upload the config and rgl_log files as asked here and as the original poster did.

*the files starting with "rgl_log" and "rgl_log_errors" in the following directory: "C:\ProgramData\Mount and Blade II Bannerlord\logs"
*the engine_config.txt file at "C:\Users\YOUR USER NAME\Documents\Mount and Blade II Bannerlord\Configs"

You can upload these at Please paste the link to this thread in the description box on the upload website so I can identify it.
Top Bottom