Resolved Game Crash a few seconds after opening

Users who are viewing this thread

Version number
1.2.9.38256
Branch
Main
Modded/unmodded
Yes, but I removed mods.
Dump identifier (optional)
2024-06-16_19.03.10_9fc8b4381c511dabdb4b14bcaa205ed8
Summary: Game is crashing after launching single player. The main loading screen will load for a few seconds and then freeze and the crash popup menu appears asking for data.
How to Reproduce: Launch the game from the launcher.
Have you used cheats and if so which: None
Scene Name (if related):
Media (Screenshots & Video):
Computer Specs:
OS: Windows 11 Home
GPU: NVIDIA gtx 3080
GPU Driver Version: 555.99
CPU: Intel 13th gen I9-13900k
RAM: Gskill trident z5 2x16 gb DDR5
Motherboard: MSI MS-7D89 (Z790 Carbon Wifi)
Storage Device (HDD/SSD): 2 Tb 860 EVO Samsung

Fresh install of game. Went into program and documents folder to delete out any leftover files. also deleted all mod files. Just trying to launch vanilla. Computer has been restarted multiple times. Updated drivers as well. I know the 13th gen cpus have been having general instability issues across the board, but didn't know if it was the cause here as I played on it last year. Also followed the common issues and workaround to try launching without launcher and deleting the old files.
 
Solved for now. It seems to have stemmed from my i13900k and the motherboards default power settings causing instability. I followed some guides and have undervolted my cpu by 0.09 and limited some other power settings. Seems good so far. Can load fully into the game and play.
 
Yeah, If you have the same MSI Z790 motherboard the steps should all be identical. If you have a different one, I'd recommend just googling to find out what each line translates into your own.

Screenshots of my settings here:


Voltage settings:
Change Voltage mode to Adaptive+Offset
Change Voltage offset mode to "-" (negative)
Change voltage offset amount to 0.09

CPU Settings:
Change Long Duration Poewr limit to 253
Change short duration power limit to 253
Change CPU AC Loadline to 80
Change CPU DC loadline to 80
One last setting i didn't screen grab, but also unsure if it has impact - i set my CPU load line mode to 8.
I also disabled intel turbo boost, but unsure if that had any impact. Currently using it enabled and havent had issues.

DRAM Settings
unsure if related, but it seemed like my default settings were wacky so i changed them to match what I had installed
XMP Enabled (this does seem to matter)
Set the DRAM frequency to match my installed RAM.

I hope this helps! A lot of the online discourse around these fixes are mixed with even intel and motherboard's recommending different approaches but all see to say don't use default settings and undervolt it for stability. Let me know if you run into any issues!

Also please note you will likely seem some performance drop, albeit minimal, due to undervolting. Honestly I don't mind it and have not had anything crash since making changes.
 
Also have your CPU cooler selected as the smallest. I just tried turning it back to my watercooler setting and crashed within 5 mins of bannerlord launching.
 
Back
Top Bottom