• Please note that we've updated the Mount & Blade II: Bannerlord save file system which requires you to take certain steps in order for your save files to be compatible with e1.7.1 and any later updates. You can find the instructions here.

Resolved FPS drop in menus due to low GPU usage

Users who are viewing this thread

Version number
e1.5.10
Branch
Beta
Modded/unmodded
No, I didn't use any mods.

HMZ

Recruit
Summary: Hello, I don't know if there's already been this discussion but I'm experiencing something weird when opening menus i.e. whenever I open a menu (for example trade menus in towns, character menu etc.) my GPU usage drops to 2% or 3% (something minuscule) and therefore the in-game FPS drops to 2-3 FPS. This persists until all the little icons get rendered at 2% GPU usage (usually around 10 seconds or so, depending on the quantity of "pictures" in the menu) and after that the GPU usage goes back to normal. This happens ONLY in menus. I would appreciate the help and I'll try to provide further information if necessary. Thanks in advance!
How to Reproduce: opening any kind of in-game menu
Have you used cheats and if so which: no
Computer Specs:
OS: Windows 10
GPU: AMD Radeon RX580 Armor 8GB GDDR5 OC MSI
GPU Driver Version: 21.5.1.
CPU: Intel Core i7-7700 @3.6Ghz
RAM: 16 GB DDR3
Motherboard: ASUS B150-m
Storage Device (HDD/SSD): Radeon SSD R3 120GB and Western Digital WD10EZRZ 1TB Hard Drive
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
We have a special performance build to check for these issues by collecting telemetry data. Can you switch to that build, test your performance and send us your data?
  1. Switch to “perf_test” from the Steam betas tab. You can find more info about it here.
  2. Open the game as usual and proceed to the stage where you are experiencing performance issues.
  3. Before the performance issues start, toggle the profiling tool by holding the “right shift” and pressing the “T” key.
  4. Record for 20-30 seconds, press the toggle key combination again. Please keep in mind that, the more you record, the more upload time it will require.
  5. Find the "test.tmcap" file in the "...\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client" folder. You can find the "Mount & Blade II Bannerlord" folder inside Steam’s application library folder.
  6. Finally, upload the file to the "upload.taleworlds.com" site. Please write your username and this threads URL into the description box so that we can find it easier. It is appreciated if you provide more information about your PC, what you were doing while the game was recording and your graphics configuration. If the data you are trying to upload is too big or the site fails to upload, you can use an alternative site to upload your data. If you choose to do that please left a reply to this thread with the download link.
 

Disguisy

Recruit
been having a similar for a while now, not sure when it started, but any menu I open basically freezes the game for multiple seconds, none of my components seem to be working hard either.
 

Flesson19

Not a Cookie
Knight
been having a similar for a while now, not sure when it started, but any menu I open basically freezes the game for multiple seconds, none of my components seem to be working hard either.
If you take the hotfix, it should solve the issue
 
Top Bottom