• Please note that we've updated the Mount & Blade II: Bannerlord save file system which requires you to take certain steps in order for your save files to be compatible with e1.7.1 and any later updates. You can find the instructions here.

Resolved Found the reason for stuttering in battles!(SSD bottleneck) this was tested on the benchmark option in 1.6.4

Users who are viewing this thread

Version number
1.6.4
Branch
Beta
Modded/unmodded
No, I didn't use any mods.
Summary: Heavy frametime sttutering caused by 100% usage even on Crucial bx-500 ssd, this usage is caused by high reads requested by the game even after all assets have been loaded. the bx-500 will rise to 100% immediately after this stutter.
How to Reproduce: Just run a benchmark test and you'll see that when you get a frametime spike your hdd or ssd will rise to 100%
Have you used cheats and if so which: NO
Scene Name (if related): Benchmark test under options
Media (Screenshots & Video): will download shadowplay and post soon
Computer Specs:
OS: Windows 10 21h1 19043.928
GPU: RTX 3070 ti
GPU Driver Version: 472.12
CPU: Ryzen 5 5600x
RAM: 8gbx2(16gb) g skill ripjaws 3666 cl16
Motherboard: MSI B550-A PRO
Storage Device (HDD/SSD): Kingston SUV400 120GB SSD for the OS and Crucial BX-500 240GB SSD for bannerlord. pagefile is on SUV400
I have purchased a crucial p5 1tb 3500mb/s nvme ssd, when it arrives i will install the OS and bannerlord in it too see if there was a difference. It's no wonder that people with traditional mechanical hdd's are reporting heavy stuttering, this game really loves fast storage.
 
For some reason i can't replicate the frametime spike now, maybe it was a shader cache issue. now it's buttery smooth with no hardware changes whatsoever.
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
We are constantly testing for these issues and we try to fix the issues we catch. Where exactly do you experience this issue? On combat? Campaign map or when UI elements getting enabled?
 
We are constantly testing for these issues and we try to fix the issues we catch. Where exactly do you experience this issue? On combat? Campaign map or when UI elements getting enabled?
It has nothing to do with UI elements, it's purely while the benchmark or campaign field battles are running. i will post a video soon
 
We are constantly testing for these issues and we try to fix the issues we catch. Where exactly do you experience this issue? On combat? Campaign map or when UI elements getting enabled?
just sent you the test.tmcap file via pm, as said there are multiple big frametime spikes of up to 50ms which'd already be considered very perceivable hitches, most if not all of them aren't related to storage issues.
 
We are constantly testing for these issues and we try to fix the issues we catch. Where exactly do you experience this issue? On combat? Campaign map or when UI elements getting enabled?
okay just tested this again, it is indeed the ssd on campaign field battles with no ui elements popping that gets maxed at 100% causing stuttering. i am gonna wait for my crucial p5 to see if this is fixed.
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
We were not able to find any spikes on the data. If you can play on SSD you won't be experiencing these spikes. Were Geforce Experience or any other recording app was up and running while you were playing?
 
Last edited:
We were not able to find any spikes on the data. If you can play on SSD you won't be experiencing these spikes. Were Geforce Experience or any other recording app was up and running while you were playing?
no, no other apps except for rivatuner frametime graph were running. i checked and i saw multiple 50ms(and over) frametime graph spikes, also you could feel them as hitches in game, this is not solved. i am sure they were recorded in that file. even without rivatuner you'd feel these spikes. you sure you didn't see them? also in that file most weren't related with ssd usage since i couldn't catch them with test.tmcap since you have to keep an eye for the ssd usage while playing. i know for fact there are multiple hitches left when reinforcements arrive which are very perceivable and game-breaking.
 
We were not able to find any spikes on the data. If you can play on SSD you won't be experiencing these spikes. Were Geforce Experience or any other recording app was up and running while you were playing?
also i don't even have geforce experience installed, i mean it could be my cpu that hitches when reinforcements spawn, but given it's over recommended requirements i guess this shouldn't happen. overall makes the game unplayable in campaign due to reinforcements spawn stuttering and general random stutters. these don't happen in custom battles i guess due to there not being any reinforcements.
 
Forwarded the info, thanks!
great, in case it's needed i can upload another test file, perhaps a bigger one if required, but i am sure the reinforcement stuttering were in the one i gave you. to be clear, the only stutter i have a problem with as of now is the one that happens when reinforcements spawn, other than that, it's more or less fine.
 
Top Bottom