Resolved [Found the issue case close] Application faced a problem window showed up only when clicking 'continue' on launcher.

Users who are viewing this thread

Version number
v1.0.0
Branch
Main
Modded/unmodded
Yes, I used mods.

code_xyster

Recruit
Summary: The 'Application faced a problem' window showed up when clicking 'continue' on launcher to get in a save. Everything seems find when clicking 'play' and manually load the save. Pretty wired.

Turned out one of the mods happened to automatically update through workshop with the bug introduced at the exact same time.

How to Reproduce: As mentioned in summary.
Have you used cheats and if so which: Game is heavily modded, and this problem occurred when i added two new mods into the game. But i dont think mods are the problem maybe, as I detail below.

Description: So I was adding two new mod: 'true relation' and 'player execution edit' into the game. I clicked 'continue' and the window showed up. I tried activated each one of them and the window still showed up. At last, I found that even with these two deleted the window still showed up, which is not the case for days of playing. I also tried deleting some file in My Documents/mb2b folders, no luck.

Then I tried deleting files in Program Data/mb2b and it worked. But when launching using 'continue' button again with the Program Data/mb2b files that were just generated, the window popped up again. The Program Data/mb2b has two folders, logs and shaders. Deleting shaders folder before launching with 'continue' button led to the window not popping up, and newly generated shaders folder would lead to the window popping up.

I took a quick look at a lasted generated file named 'rgl_log_1348.txt' in the logs folders. The only abnormal part was many lines of 'Unable to find particle system with name [many different names, e.g., waterfall_splash, psys_blaze_small_1, etc.]'. I do not know if these lines are normal, as I haven't look into this log file before.

When the window popped up, clicking 'no' led to game exiting. Clicking 'yes' seemed to be fine. The save was loaded, but I didn't play through.

And I also tried verifying game files via steam, no luck. All this time, clicking 'play' and loading the save in game have been fine with no window popping up.

Also, the mods are all gameplay related, nothing visual is added. So if it is something wrong with shader or particle system that causes this problem, mods seem to have nothing to do with it.
 
Last edited:

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
Hey, i am glad the problem is solved. Please keep in mind that we do not offer support for mods or modded games. If you encounter any other issues please try to reproduce the issue on a new campaign after manually removing all the mod files and verifying the integrity of the game files. If the issue is persistent on a new, unmodded campaign please let me know.
 
Top Bottom