Need More Info Formation spacing incorrect

Users who are viewing this thread

Version number
No, I didn't use any mods.


Summary: During the pre-battle setup, if I assign only infantry troops into formation 4, they will have spacing as if they were mounted. However, this does not happen during the first battle you assign the formation during. This only happens after the formation is saved and you start the next battle. Telling them to dismount will fix the spacing, but the little ui flags are still in the incorrect spacing. I saw a similar post related to this bug and companions. I am making this because this happens to me regardless of anything to do with companions.
How to Reproduce: Go into a battle setup. Assign infantry troops to group 4. Continue battle as normal. Go into a new battle. The formation spacing of 4 is now incorrect.
Have you used cheats and if so which:
Scene Name (if related):
Media (Screenshots & Video):
Computer Specs:
GPU Driver Version:
Storage Device (HDD/SSD):

MArdA TaleWorlds

Community Support & Localization
Community Support
Forwarded to the QA team for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!


I have also experience this issue and have worked out a few trigger causes.
1. Having ‘the wainwright’ Companion in a party and giving her a horse.
2. Having ‘the scholar’ Aserai companion in a party and giving him a horse.

Both these companions with either be assigned to the cavalry or horse archer (if given bow/crossbow) group, but they will still effect the spacing of the infantry (group 1).

In the case of the Scholar, assigning him as the cavalry leader will fix the issue.

His is in 1.7.1


I found another companion that caused this (infantry spaced out like cavalry when companion is given a horse even though the companion is not part of the infantry), The Khuzait ‘the knowing’. I found out that if I make them leader of their own units, retreat for battle and then attack again the Infantry spacing returned to normal. If I made him Captain of the Cavalry (group 3) and retreated out the the battle then attack again the infantry spacing returned to being bugged.

Possible fix and cause.
I used the Mod Character Manager to respect ‘the knowing’ attributes, focus and perks. After doing this placed him back on a horse and the issue had fixed itself. So the problem may have been caused by a perk.


Update, the method of using character manager to respect a character did not work on ‘the wainwright’ companion.
If she is mounted and if not armed with a range weapon its possible to temporarily fix the infantry spacing by placing her in a unit group on here own, start the battle and instantly retreat, then start the battle again, she will then be assigned to the cavalry and the infantry will be spaced correctly. But it needs to be done every battle.


I think I’ve found yet another trigger for causing the infantry to be spaced out like cavalry. I discovered it after have one battle without issue and right away another with issue, without changing the companions in my group or their equipment. I thought it might be caused by an perk I had given a newly levelled Comp so took them off their horse to see. It work BUT realised I had taken the wrong companion of their horse. I then tried with another, swapping around which one start the battle uncounted, each time I did the infantry were ok. It’s only when all there mounted didn the infantry spacing bug appear. So one cause might be having too many companions on horses and assigned to the same formation.

One solution would be to allow the player to specifically assign a companion to a group instead of the game doing it automatically based on equipment.
Top Bottom