Fix for some crashes... NOT A BUG THREAD - READ 1st POST

Users who are viewing this thread

Status
Not open for further replies.

Tei

Sergeant at Arms
If you have a 32bit operating system refer to points "1. Fixing" and "2. Adjusting VM".
If you have a 64bit operating system refer only to point "2. Adjusting VM".
If you have a crash while launching the game (or a skybox error) refer to "Early crashes".
You can also refer to Known things that will cause you to CTD or lag heavily for further reading.

And remember to always
mofodg7.gif

(violators will be ignored)

Have in mind that this thread is mainly about AD 1257 module so if you're playing something else and it's still not working then: a) you did something wrong, b) the problem lays somewhere else.

Crucial edit:
If it works for you then don't brag about it creating new posts - just vote. It's easier for me to respond to problems, questions and such when I don't have to dig through irrelevant posts. It's not like I'm not glad about fixing your problems, it's just not needed to inform me about it.
If it doesn't work or you are having a problem with applying it - post your questions and I will do my best to help you guys out. The problem may lay somewhere else and the fix may not be the solution to your problem.
Also keep in mind that it isn't a regular bug thread and I won't be too helpful in issues going over the basic subject of the fix. I'll say more - it will piss me off.

Early crashes:
If you're having a crash at the very beginning of your voyage (right after killing the bandit, after arriving to a town, while loading the mod etc.) then:
- if you're crashing while the game is loading or just after clicking any of the buttons in the menu then you:
  a) have to tick the "Load textures on demand" in Configuration settings (however, it works for few people without having it checked. for me it used to crash before loading everything up).
  b) have to re-download the mod (maybe the installer got corrupted during or after the download)
- if you have modded the files somehow - revert to original. Sometimes editing the files can screw few things up.
- ATI video card owners may have problems with their visuals in the game (with or without this fix). Try reverting to 10.5 or 10.6 version of graphic drivers.
- for some people it's about skyboxes errors. Refer to this thread for a fix.

Things to do before:
Before using this solution make sure that your hardware drivers are up to date (if ATI - read above), same with DirectX. It would be good to have OS updated as well, however it is not mandatory (as long as Microsoft won't make another patch messing everything up). Also, if you're using any kind of program/plug-in modifying your boot file (like Bootskin for example), this solution may not work - deactivate it and try then.


Description:
Probably many of you get crashes while saving a game, sometimes during or after a bigger battle, switching screens (like while going to tavern, etc) or just about 10-20 minutes of playing. It is a fairly common problem with this mod, but there are people who never crash, so the only probable reason was OS or hardware specific. I've been cross-checking issues like that (mainly about saves) with other games and found out a nice solution at JoWood forums. Seems to work - I've asked one of this board's member, Earende, about applying this solution and it worked out nice. Few friends of mine say that it works for them too. I've played for 2 hours yesterday (on Vista) and quit by myself without any crashes so it does seem like a legit solution.
Feel free to comment if you're having problems - I'll try to answer the best way I can. I check this thread every day, so...

! ! !  Using this solution involves editing system settings so watch out what you're doing  ! ! !

Explanation:
If you're running a 32bit operating system and get the crashes while saving or otherwise dumping a lot of memory usage then it is most likely because of the fact that 32bit operating systems only provide an address space of 2GB to every user process running. It means that whenever memory usage for 1257 (filled with lots of textures) goes sky rocket it most likely exceeds 2GB and then you get the crash. The way to avoid crashing is configuring your OS to give more address space to process.
The fix is pretty easy, as it is described, and can be represented in two points:

[list type=decimal]
[*]"Fixing", which is basically making the operating system to put more memory into a single process.
[*]"Adjusting VM" (Virtual Memory), which is needed to be set correctly.
[/list]Skipping any of those two points may most likely change nothing so be sure to apply both of those solutions (64bit OS users do only the adjusting, without the fix). If this workaround will make more harm than good (unlikely to happen) then refer to "Reverting the process" section.


1. Fixing
(32bit OS only)

Windows XP
  • Menu Start -> Run, type sysdm.cpl and press ENTER
  • a window should open, go to tab Advanced -> Startup and Recovery Settings -> Edit
  • at this point you're editing your boot.ini file. Don't mess things up.
    Look for the line with your operating system mentioned and add "/3GB /USERVA=2990" without quotes. Should look like this:
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /3GB /USERVA=2990
    just add only the "/3GB /USER...", don't erase or add anything else as it may corrupt your booting file
  • save changes and reboot
Windows Vista / Windows 7
    • if you are running as an Administrator go to Menu Start -> Run, type cmd and press ENTER
    • if not go to Menu Start -> Programs -> Accessories, press RMB on Command Prompt and select Run as Administrator
  • in Command Prompt type "bcdedit /set IncreaseUserVA 2990" without quotes and press ENTER
  • reboot

2. Adjusting VM
(32bit & 64bit OS)

(Thanks Tina for reminding me about VM)
This solution probably won't work if your RAM and Virtual Memory summary is lower than it should be. You can't do much about RAM (well, if you have cash then you can do much about it) but you can change the values of VM.
Known problems with changing the VM settings:
  • (XP) boot.ini file doesn't exist - there are three possibilities here: first one is that you don't have the administrative privileges to edit the file; second one is that the file, for reasons unknown, actually doesn't exist; third one is that the file is hidden. Solution to the first problem is logging in as an administrator user. Second one is described → here ←. Solution to the third problem is setting the folders to show hidden and system files (I really don't know what will it change but was suggested by some people, so - try it out), but I don't remember where do you change that in XP and Vista so refer to system help (press F1 on your desktop).
  • can't set the VM values over 4096 MBs (4GBs) - most likely the drive you are trying to use for the swap file space is formated with FAT32 file system. This allocation forbids to use files bigger than 4GBs. You'll have to use a hard drive or partition formated with NTFS file system.
  • also, have in mind that we are talking about disk space, so make sure that you have enough disk space to be used as VM

Windows XP, Windows Vista, Windows 7 (or at least I think that the route is the same in each of these systems)
  • Menu Start -> Settings -> Control Panel -> System -> Advanced
  • Performance -> Settings
  • Advanced tab -> Change
    The tricky part is setting the values right. Microsoft suggests (http://support.microsoft.com/kb/308417 , Step 2) to set the minimal value as 1.5x of your RAM and maximal value as 3x your RAM (so if you have, for example, 2GBs of ram then minimal is 3.5GBs and max is 6GBs... so that's 3500MBs and 6000MBs). There's plenty of topics on the web with performances results and such revolving around this subject so... Google.
  • Save, reboot

3. Reverting the process
It may happen that using this fix will make some pieces of software to work differently than before, deviate in some way or produce and error. Luckily, this solution is completely revertible. If you want to get back to your previous settings, then:

Windows XP
  • Menu Start -> Run, type sysdm.cpl and press ENTER
  • a window should open, go to tab Advanced -> Startup and Recovery Settings -> Edit
  • at this point you're editing your boot.ini file. Don't mess things up.
    Look for the line with your operating system mentioned and erase "/3GB /USERVA=2990". Should look something like this:
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
    erase only "/3GB /USERV...", don't delete anything else
  • save changes and reboot
Windows Vista / Windows 7
    • if you are running as an Administrator go to Menu Start -> Run, type cmd and press ENTER
    • if not go to Menu Start -> Programs -> Accessories, press RMB on Command Prompt and select Run as Administrator
  • in Command Prompt type "bcdedit /deletevalue IncreaseUserVA" without quotes and press ENTER
  • reboot


4. Issues
Because some of you are obviously too fkn lazy to use the incredible tool like a search engine:
http://blogs.technet.com/b/askperf/archive/2007/03/23/memory-management-demystifying-3gb.aspx
So... if you're not running any programs, games and such that 'force' you to use the 3gb switch, just turn it off.


If it still isn't working as it should then the problem lays somewhere else, check here -> Known things that will cause you to CTD or lag heavily for an answer. Nothing helps? Check the bugs thread. Nothing? Hmm... run-time errors. Still not working? Oh, I dunno... format c: -> reinstall, the problem lays somewhere else or you are doing something wrong.
 

xat

Sergeant
About memory usage I remember that MB is set to use >2gb of memory.
Atleast the last time I checked with program to edit *.exe's.
 

Tei

Sergeant at Arms
Man, I don't know what to tell you if it actually works for people previously having problems with those crashes. Someone said that it even works for SimCity 4 Deluxe :wink:
 

xat

Sergeant
But it works for only "while saving" rlg errors? Or also for the ones in battle where your game freeze/rlg error exit.
 

Tei

Sergeant at Arms
Like I've said - it worked without any crashes for 2 hours, while saving or battle. No runtime errors, no "to desktop" crashes. I used to get a crash every 20-30 minutes or so. I don't have the video-gaming stamina in me or free time to play longer than that but it is an improvement, it even gave me a bit of performance boost. Bunch of dudes who tested it say the same.
 

Tei

Sergeant at Arms
Gaggalulu said:
How do you know that it worked?

My system is still saying 4,00 GB (2,99 GB available)

what are you referring to by those numbers?

the solution involves the amount of memory which can be allocated to a single process, not the total amount of memory which can be used by the operating system (physical or virtual).
 

Physix

Knight
WB
Tei said:
Gaggalulu said:
How do you know that it worked?

My system is still saying 4,00 GB (2,99 GB available)

what are you referring to by those numbers?

the solution involves the amount of memory which can be allocated to a single process, not the total amount of memory which can be used by the operating system (physical or virtual).

Thanks, thats the information I needed
 

xat

Sergeant
Indeed it does seem to work I turned grass density to 100% and game doesn't go rlg error ape **** on me (at least not in 3 fights). Even though its sometimes stutter and stuff it doesn't error on me (just need to decrease battlesize).
 

Genchou

Recruit
WB
How do you "remove" that workaround ?
I'll try it but I'd like to know how to put things back to normal if it doesn't work/screw other things up.

Also, is it useful for pc with only 2gb of RAM ?
 

xat

Sergeant
Genchou said:
How do you "remove" that workaround ?
I'll try it but I'd like to know how to put things back to normal if it doesn't work/screw other things up.

Also, is it useful for pc with only 2gb of RAM ?
Same as you added it just remove the copied text and restart pc.
And I don't think that workaround which allows system to use "more than 2 gigs of ram" will work on 2 gigs ram rig.
 

Tei

Sergeant at Arms
Genchou said:
How do you "remove" that workaround ?
I'll try it but I'd like to know how to put things back to normal if it doesn't work/screw other things up.

Also, is it useful for pc with only 2gb of RAM ?

1)
Removing this workaround:
In XP? Removing "/3GB /USERVA=2990" from boot.ini
In Vista? Hmm... lowering the 2990 to 2000 probably. But you can always make a restore point and then... just... restore? :wink:

Personally I have no problems with this workaround. Games that used to crash (besides MB) seem to work without them anymore. However I've read in another thread that it messed some other games... Was this workaround the problem? Can't tell or find a reason for but I'm not saying that it won't.

2)
This solution should help you out even with 2GB of ram. Process can assign both physical and virtual memory, so it will work.
 

Genchou

Recruit
WB
I forgot to say I'm with windows7. I wasn't sure about the 2gb of ram. I'll try and well, we'll see what happens.

Thanks anyway.

:smile:

 

Folkzweise

Knight
I'm win7 and tried this out and it definitely helps even with only 2GB of ram :smile: i can play native in maxed out graphics (as long as there are only 100 troops at the battlefield) without problems or crashes. Can't tell how other games will react cuz i don't play them :razz:
 
I need help. :cry:

For me, it's happend to be like this.

[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /usepmtimer

What is the " /usepmtimer" mean? what should I do with it?

And,another question. If I add  /3GB /USERVA=2990 will it really crash other game?

However I've read in another thread that it messed some other games... Was this workaround the problem? Can't tell or find a reason for but I'm not saying that it won't.

According to this message, could you please give me the link of that thread?

I'm sorry if my english skill is bad.
 

Tei

Sergeant at Arms
MariusThePaladin said:
I need help. :cry:

For me, it's happend to be like this.

[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /usepmtimer

What is the " /usepmtimer" mean? what should I do with it?

And,another question. If I add  /3GB /USERVA=2990 will it really crash other game?

However I've read in another thread that it messed some other games... Was this workaround the problem? Can't tell or find a reason for but I'm not saying that it won't.

According to this message, could you please give me the link of that thread?

I'm sorry if my english skill is bad.

http://forums.taleworlds.com/index.php/topic,129403.msg3204662.html#msg3204662 is the link for the "other games crashing" thing-o. the game that tends to crash is the Witcher.

/usepmtimer explanation: http://support.microsoft.com/kb/895980

your line should look like this:
Code:
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /usepmtimer /3GB /USERVA=2990
http://support.microsoft.com/kb/316739
 
Thanks, that's help me a lot. I've go and kill one band of Wales Rebel (27 head of them against my 37 peasant +3 Calvary), then join 3 or 4 melee fight and not suffer any crash anymore.

However,according to this

http://forums.taleworlds.com/index.php/topic,129403.msg3204662.html#msg3204662

He said that his problem happend to texture. I think that the texture problem was not related to RAM , right?  :grin:

EDIT : I test it with The Last Remnant , and It's still function correctly.

http://i293.photobucket.com/albums/mm64/MariusThePaladin/VVV.jpg
 
Status
Not open for further replies.
Top Bottom