• Please note that we've updated the Mount & Blade II: Bannerlord save file system which requires you to take certain steps in order for your save files to be compatible with e1.7.1 and any later updates. You can find the instructions here.

Users who are viewing this thread

uravnobeshen

Recruit
Hello everyone. I have a major problem that doesn't let me play Warband anymore. I have been trying to play it for months now, but I can't. I remember playing it on potato PC and it had no problem running it. So, this problem is on every mod I play on some it’s a bit less, on some it’s more but no mod is playable. Native does this too. So, whenever I try playing, I get extreme stuttering, lags, sounds get distorted.

I have tried to fix those problems by:
- Trying out all the settings in the game launcher
- Veryfing game's files integrity on Steam.
- Reinstalling the game, even reinstalling the PC many times since I first encountered this problem (Months ago, I'm living without Warband for like six+ months now... :sad:)
- Trying out different settings in NVIDA Control Panel
- Making sure Warband isn't using integrated GPU
- Updating all drivers.
- Downgrading GPU drivers (The whatever problem that many players encountered after november update or something)
- Trying the mouse patcher circulating here on forums.

Processor - Intel(R) Core(TM) i5 CPU 650 @ 3.20GHz
Video Card - NVIDIA GeForce GT 1030
RAM - 12 GB
Operating System - Windows 10
 

Eärendil Ardamírë

Subforum Moderator
WBWF&SM&B
Top Bottom