Dusk of the mods

Users who are viewing this thread

Askorti

Master Knight
WB
I'm sorry, but I'm a little frustrated with waiting. This whole NW thing is somewhat troublesome.
So I'd like to ask a rather hard, but yet.... simple question. How long? How long do you plan on to releasing new patches for that DLC? Thanks to this miracle, this greatness I, probably backed by dozens of people have to wait god only knows how long to play our favorite mods.
WSE is used in some of the greatest products, and thanks to new NW/WB patches it will not be upgraded as long, as they come out.
For example:
Brytenwalda
Vikingr
Shogun mod
The Deluge
Battle Time!
Pre-Battle Orders & Deployment
ElvenPath - Forgotten Realms Mod
These mods are quite popular, maybe even the most. But they can't develop. Not because their makers don't want to improve them. They can't make a step forward because of a wall that arose in front of them. The wall is called NW.
So? What's the plan? A Month? Few months? Half a year?
When there was no patch for around a year, it was good. Obviously some people complained, but(I bet) most were glad that everything is calm and stable. Nobody really cared about native anyway, since most people played mods. Now? Waiting. Uncertainty of what new patch will bring.

I'm sorry if this post is too offensive, but I'd really like to know what's going on and how long are we supposed to wait. I obviously do not demand a certain date, but just an overall plan of what you want to do to this game.
 

Kazzan

Count
M&BWBNW
The maker of WSE is waiting to see that the current version of warband is stable and then port it.
It's for him to decide when.
 

Askorti

Master Knight
WB
Kazzan said:
The maker of WSE is waiting to see that the current version of warband is stable and then port it.
It's for him to decide when.
Umm... Tell me something I don't know.
But. How does he know, if current version is stable? If WB 1.154/6/7/8 won't be released next day? WSE developer doesn't want to take that risk and work on something that might be just temporary.
So in fact, fate of new version of WSE lies in hands of NW/WB developers.
 

MadocComadrin

Water-Borne Annelid
Count
M&BWBWF&S
Kazzan said:
The maker of WSE is waiting to see that the current version of warband is stable and then port it.
It's for him to decide when.
No, he's waiting to see if another patch is going to come out so his porting isn't made obsolete in such a short time. Porting WSE isn't the same as porting a mod: each time a new version comes out, he has to find new memory locations for the hooks.
 

WilySly

Grandmaster Knight
WBNW
KuroiNekouPL said:
When there was no patch for around a year, it was good. Obviously some people complained, but(I bet) most were glad that everything is calm and stable. Nobody really cared about native anyway...

Wow...here's to hoping the devs don't share your opinion
 

Argeus the Paladin

Grandmaster Knight
WB
Well, to his defense, a good portion of M&B gamers, owing to bad reflex, crappy internet connection or both can't really enjoy MP.

But in any case, a good advice to OP is to download the 1.143 version and hold out until the devs declare new patch is stable. I, for one, keep my 1.143 version and all's well thus far.
 

Askorti

Master Knight
WB
It's quite ironic, that I have to downgrade my game to have fun playing it... Also, what's the point of a "mod friendly" game if it gets less mod friendly with every patch?
I wont even mention the conspiracy theories I heard about this whole situation...
 

Duh

Duke
M&BWB
You only have to downgrade because you upgraded it. You know that was kinda entirely your call.

As a modder i can tell you that most of us are happy about the patch, the new operations and the bug fixes.
 

Frosty

Grandmaster Knight
M&BWF&SWBNW
You just need to be patient and play something else I guess, they haven't announced a new patch yet, but I think one will come.
 

wrc

Grandmaster Knight
M&BWBWF&S
Although I agree with OP to a certain extent I didn't notice that most of the modders had some complains, and what Duh said, most of them actually eagerly waited the new patch. I support any game improvement because mods will be upgraded as well. Now, correct me if I'm wrong but problem is that this patch was actually intended to improve NW, therefore they needed to upgrade warband first.
I do not own NW, so whenever developers of that DLC make something new, warband will be "screwed" again for a few weeks or more. I'm still running 1.143 version and I wonder when half of the mods move to 1.153 whether we will need also to have "old version" of warband installed for the other half? Not to mention if a new patch comes out. :???:
 

RalliX

Count
M&BWBWF&SVC
Surely you guys knew this was going to happen.

It happened with the original Mount & Blade as well.

When the TW devs ended the project at 1.011(and moved on to Warband), a fair amount of very good mods were left in the dust, made on old versions that everybody dropped for the new one. Examples can be made of mods which pulled themselves up by their bootstraps and updated from older versions, like The Last Days, and then there's mods like Tides of Conquest: Sicily which were unique and great, but forgotten by most. I hear there were some truly great mods for old versions, but I got the game right around when 1.011 was released, and didn't pay attention to, or know of them.

Now, even less mods will be ported to Warband because of the circumstances, and only somewhat active Warband mods will update past 1.143.
Less people are playing Mount & Blade than did a year or two ago.
Plus, we now have two separate kinds of mods, rather than just singleplayer. The multiplayer component requires not just players, but lots of players at any given time to be successful.

The TW devs are doing now what they did about 4 years ago; make the game suitably polished, and then leave it for good.
They're beginning work on Mount & Blade 2.
Frankly, I don't see much left to do with Warband but fix whatever bugs remain, let the modders amaze the community, and hone their skills until the next release of this fine game. Be patient, please.
After all, if you want them to rush this, then we'll be playing a rushed version until 2014.

There might be a board like this eventually: http://forums.taleworlds.com/index.php/board,118.0.html
For every mod that doesn't update to the 1.15x versions.
 

Vornne

Count
M&BWBNWVC
As a modder I also disagree with the original poster: that certain mods don't work with the latest versions is not taleworlds fault, as the WSE is definitely an unofficial hack (a very clever and useful one, none the less) which would break from the tiniest change to the executable, with the responsibility of updating on cmpxchg8b - and I can totally understand why he does not want to tediously find all the memory offsets again and again when the challenge has gone out of it, having another project to work on.

It is hard enough encouraging developers to make new releases to fix bugs or add features, without having other people wanting the game stuck in stone forever - they haven't removed the old versions from the download mirrors, and nobody is forcing you to update except steam, which is not the only (or best, in my opinion) way to play the game.
 

MadocComadrin

Water-Borne Annelid
Count
M&BWBWF&S
I understand where he's coming from. If these were normal patches, I'm sure people wouldn't complain, but they're not. Heck, it would even be semi-ok if we were getting rapid-fire patches instead of being stuck in the patch-no patch limbo that's stalling the WSE update. The devs share some blame in this because they decided to destabilize the system for a quick buck.
 

Vornne

Count
M&BWBNWVC
MadocComadrin said:
Heck, it would even be semi-ok if we were getting rapid-fire patches instead of being stuck in the patch-no patch limbo that's stalling the WSE update. The devs share some blame in this because they decided to destabilize the system for a quick buck.
Nonsense: they just made some updates requested for NW, then decided to freely release the fixes and new operations from WFaS and NW development to people playing or developing Warband mods, as a gift (and then fixed things broken in Warband as well): to play NW you need to use a different executable to run that mod anyway, so Warband being updated was not a necessary requirement. The system is not "destabilized" just because a totally unofficial and unsupported hack doesn't work, which would be "broken" from the most trivial changes to the game executable.

That you are not getting regular status updates from taleworlds developers is quite normal: it has generally been difficult to get official statements and promises from them over the years, even when directly asking - as with game developers in general. The type of personality that makes a good programmer is often not naturally good at public relations (or at least don't enjoy it), and with a larger organisation probably most of the developers don't know the exact release plan, and the rest don't want to come out with public statements they will be held to in the future. Has anyone that wants to know actually asked a main developer directly if more updates are planned, via something like private messages or email? I doubt they read the forums much.
 

Askorti

Master Knight
WB
Vornne said:
they haven't removed the old versions from the download mirrors, and nobody is forcing you to update except steam, which is not the only (or best, in my opinion) way to play the game.
Would you disagree, if I said, that most players use Steam? I guess not. Would you disagree, if I said, that most players are lazy? I guess not. Big part of WSE-based mods are multiplayer, which require many players at once to have fun. Most players were too lazy to downgrade their game and thanks to it we have got much less players than we would have normally. All thanks to a bunch of patches.
 

Frosty

Grandmaster Knight
M&BWF&SWBNW
People who use Steam, like me, can easily download a non-steam version of the game on the Taleworlds website.
 
Top Bottom