Do you ABSOLUTELY have to update the game every other day?

Users who are viewing this thread

Philozoraptor

Sergeant
Funny fact, they sometimes patch even older versions of the game on patch release. For example when they released 1.0.2 live they patched 1.0.1 at the same moment and caused same mod issue for both versions even though 1.0.1 was obsolete by that point and some people might have preferred to stay on that version for the sake of mod compatibility (which they broke). Generally speaking, patch - even minor one should have patch notes, and should be separate version for that matter. The game is no longer EA, but hotcode patching is still hapenning (it should not be hapenning by this point, keep it for beta).
 

Lord Irontoe

Master Knight
Funny fact, they sometimes patch even older versions of the game on patch release. For example when they released 1.0.2 live they patched 1.0.1 at the same moment and caused same mod issue for both versions even though 1.0.1 was obsolete by that point and some people might have preferred to stay on that version for the sake of mod compatibility (which they broke). Generally speaking, patch - even minor one should have patch notes, and should be separate version for that matter. The game is no longer EA, but hotcode patching is still hapenning (it should not be hapenning by this point, keep it for beta).
Yeah, I thought this line was a little concerning when I saw it:
Active live and beta versions will receive updates, other branches typically do not.
Why would they ever need to patch an old version? Thar's just screwing with people for no reason. I'm starting to think TW actually hates modders and does whatever it can to make modding more difficult. This is not a mod-friendly game.
 

Flesson19

Not a Cookie
Knight
For example the latest version is beta, which is 1.0.2(Ignore they might have moved it)then the one behind it is 1.0.1 is live and they can be hotfixed. The 3rd one 1.0.0 is the main branch. that branch isn't touched and while you have to put up with bugs it will never be updated and mods wont break. That is the one I stay on so I can record campaigns. Then once 1.0.3 drops, 1.0.2 will be live and 1.0.1 with be the main branch not touched just follow like that and you'll be fine
 

NPC99

Baron
M&BWBWF&SVC
Why would they ever need to patch an old version? Thar's just screwing with people for no reason. I'm starting to think TW actually hates modders and does whatever it can to make modding more difficult. This is not a mod-friendly game.
AFAIK the third party server host updated Newtonsoft.json from version 11 to 13 forcing TW to follow suit. Presumably custom MP mods on older versions still need compatibility to use the TW hosted lobby.
 

Julio-Claudian

Sergeant Knight
AFAIK the third party server host updated Newtonsoft.json from version 11 to 13 forcing TW to follow suit. Presumably custom MP mods on older versions still need compatibility to use the TW hosted lobby.
I would honestly have been less annoyed if they had explained this to the fanbase when they did it.
 
Top Bottom