Disable Controller Detection?

Users who are viewing this thread

Hello, not sure where this question should be posted. I'm well aware that this is a mouse/keyboard game, but for Warband I used the controller during combat. Was planning to use Xpadder for Bannerlord, but the game seems to detect my controller. It has some default controls that conflict with the ones I set up on Xpadder. Was wondering if anyone knew how to stop Bannerlord from detecting my controller. Hope everyone is enjoying the game!
 

EntropyD

Recruit
Similar problem. Steam gamepad config seems to be ignored/overwritten by the game...any way to have it actually use the controller settings from Steam Controller Configuration?
 
Similar problem. Steam gamepad config seems to be ignored/overwritten by the game...any way to have it actually use the controller settings from Steam Controller Configuration?
Not sure. My solution was to get another program called reWASD. Somehow it gets games to detect it's supported controllers as keyboards. Took some setting up, but now I have a nice Bannerlord profile. They have a 14 day trial, but I paid the $15 once I confirmed that it did what I needed it to do.
 

BaconBeard

Recruit
Not sure. My solution was to get another program called reWASD. Somehow it gets games to detect it's supported controllers as keyboards. Took some setting up, but now I have a nice Bannerlord profile. They have a 14 day trial, but I paid the $15 once I confirmed that it did what I needed it to do.

Hi, i use reWASD already for other games. But i tried it last night with bannerlord and im having similar problems to the posters above. I can bind new actions to buttons but it still carrys out the default controller command at the same time as my new one.
Any idea how you stopped this happening?
 
Hi, i use reWASD already for other games. But i tried it last night with bannerlord and im having similar problems to the posters above. I can bind new actions to buttons but it still carrys out the default controller command at the same time as my new one.
Any idea how you stopped this happening?
This is the video I used to help me(skip to 2:30)

But basically from what I've gathered is that you have to unmap all the buttons on the controller. There's a little wand underneath the controller to unmap all. Then once you've set everything up, hit apply. I usually have Bannerlord's custom battle open, and then Ctrl alt esc when I am testing stuff. You seem to already know about reWASD, but just make sure remap is on when playing. One final note. This may have just been a me problem, but when setting up, the left analog stick gets really messy and constantly tries to remap my WASD controls while playing, causing a loss in movement. My solution to this was to exclude keyboard keys after I was done setting up. It seems like I have to do this every time I start up reWASD, but I suppose that's a minor inconvenience. Hope this helps.
 

BaconBeard

Recruit
This is the video I used to help me(skip to 2:30)

But basically from what I've gathered is that you have to unmap all the buttons on the controller. There's a little wand underneath the controller to unmap all. Then once you've set everything up, hit apply. I usually have Bannerlord's custom battle open, and then Ctrl alt esc when I am testing stuff. You seem to already know about reWASD, but just make sure remap is on when playing. One final note. This may have just been a me problem, but when setting up, the left analog stick gets really messy and constantly tries to remap my WASD controls while playing, causing a loss in movement. My solution to this was to exclude keyboard keys after I was done setting up. It seems like I have to do this every time I start up reWASD, but I suppose that's a minor inconvenience. Hope this helps.

Thanks! Will try it again when im home
 

hamletsdead

Recruit
Hi, i use reWASD already for other games. But i tried it last night with bannerlord and im having similar problems to the posters above. I can bind new actions to buttons but it still carrys out the default controller command at the same time as my new one.
Any idea how you stopped this happening?

You have to unmap the default controller settings for some of the buttons. For example, if you want to remap the standard keyboard bind F (for interaction) to A on your Xbox controller, you have to remap it in the reWASD controller setting icon AND ALSO go down the generic Xbox settings icon and hit unmap. I just remapped F yesterday, and then some of the attack commands to the d-pad, and everything works great so far.
 

MostBlunted

Banned
You know that this thread is 4 months old? :smile:

The OP hasn´t even posted since 8th april, guess he was smart and moved on to some good game.
 

TONSofAG

Recruit
This is the video I used to help me(skip to 2:30)

But basically from what I've gathered is that you have to unmap all the buttons on the controller. There's a little wand underneath the controller to unmap all. Then once you've set everything up, hit apply. I usually have Bannerlord's custom battle open, and then Ctrl alt esc when I am testing stuff. You seem to already know about reWASD, but just make sure remap is on when playing. One final note. This may have just been a me problem, but when setting up, the left analog stick gets really messy and constantly tries to remap my WASD controls while playing, causing a loss in movement. My solution to this was to exclude keyboard keys after I was done setting up. It seems like I have to do this every time I start up reWASD, but I suppose that's a minor inconvenience. Hope this helps.
I know this thread is OLD. Like crazy old, but it helped me out today so I came here to say thanks. Not being able to make my own controller profile for this game because it would keep using the game's control scheme was driving me nuts. Thank you.
 
Top Bottom