In Progress Delayed attack animation bug.

Users who are viewing this thread

Version number
1.7.2
Branch
Main
Modded/unmodded
Unmodded

Krisee

Sergeant
This problem started around 1.6.4 and is still problem to this day.

Summary
: When one performs a block/perfect block and a preclick (to attack) the attack animation gets delayed/bugged.

How to Reproduce:
What actions do I perform with my mouse: block (RMB) / holding block+attack (LMB) (almost simultaneously) = preclick.
What's actually happens in game: block - delay because of stun from enemy strike - perfect attack.

Before the last patch* (*=NOVEMBER 2021) this system (preclick) was working perfectly – it didn’t matter which weapon I blocked with and which weapon I was hit with. Of course, there was a difference because of stun – perfect attack started later or sooner depending on that, but it didn’t have any effect on the preclick.
At the moment after the new patch stuns take effect directly on preclick. The same goes for spear animation in video, including APRISOKENMANN GIF. He also uses preclick, it’s a bit different problem which existed even before this patch, but the essence of the problem is the same.
Usage of preclick right now causes delay +visual bug:
  1. You block enemy strike (doesn’t matter if it was normal block, early block or perfect block)
  2. Right in the moment of your weapons (or enemy weapon and your shield) colliding you press LMB in order to perform preclick.
  3. You pressed LMB and are expecting to start attack animation, but (several options):
  • your character is just standing idle, and then suddenly after like 0,5ms (this time can vary, sometimes it’s longer, sometimes shorter (0.1 ms - 0.5 ms)) he starts attack that you have pressed way earlier. From player’s perspective it looks like your attack input disappeared, and then after some delay your character starts swinging on his own, without any command and sometimes (when 0.1 ms delay happens) much faster than regular attack animation, as if it was sped up.
Media (Screenshots & Video):
Check GIF for bugged animation with delay (0.5ms)
Check GIF for bugged animation with delay (0.1ms)
  • after your LMB click no attack happens, game just ignores it and you stand idle.
Check GIF

You should understand that this problem appears not because of stun, as in video you can see similar weapons, which should cause similar consistent stuns in terms of time, if that was the case.

REMINDER: all of these actions (except 0.1ms gif) are performed with just 2 clicks – 1 click for block and simultaneous 1 for attack (preclick)
BUT – preclick is also possible with holding regular block if you manage to click LMB right before enemy weapon collides with your, and it can still bug out. Check GIF


Read: (As this post is shortened for easier reading, but I highly recommend you read this post by Chao as it goes into much more depth)
I have essentially taken bits from it to make this post. As of right now this issue has not yet been solved even though we reported it in November 2021.
https://forums.taleworlds.com/index.php?threads/delayed-attack-and-animation-bug.448292/post-9768428




NIN3, citing your reply:

“Sadly atm we allow players to go into an attack ready early than they are supposed to. But since the stun is still active, we don't allow them to attack”

In my personal opinion: why don't you make the impact of the stun the same as it was some patches ago with two-handed weapons? Stun extended the ANIMATION OF HOLDING THE BLOCK, which showed perfectly that I was "stunned". Therefore, I could not perform preclick - animation of preparing the weapon didn’t start, because there was an animation of holding the block. There were no visual problems and delays. Now because of visual glitches I can only guess if my preclick is working or I’m in "stun". Are you sure that "stun" should affect preclick rather than block animation?

To sum it up. Delay together with bugged animation happens because of performing preclick. Delay varies from 0.1ms to 0.5ms depending on normal/perfect/early block and amount of time between pressing block and preclick. But this delay is always present. I doubt deeply that it can be called “stun”.
Reasons for that:

  1. Delay can be fixed clicking LMB more times. Check GIF
  2. If instead of preclick you perform normal/perfect attack, there’s no 0,5ms delay+weird animation (or, as you call it, stun). Check GIF
  3. If it really happens because of stun, why does it cause weird animation?
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Forwarded to the QA team for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!
 
Top Bottom