Deactivating Soundcard Acceleration


Best answers
Soundcards, especially onboard, can cause a number of problems. The tricky part is, the card is often not the obvious cause of the problem - sound may work fine, but the game runs slower than usual or crashes.

Direct X isn't the greatest at detecting capabilities or buffer (memory) sizes of soundcards, and never has been. This can cause a number of problems, symptoms including:

Distorted/wierd sound
Slowdown, especially on top of the line PC's (i.e. an FPS of 5, on a system that should get much higher. Especially true if the game is reporting 30 or higher FPS)
Random crashes to the desktop or hanging
Bluescreen crashes (especially protection faults and similar)

Are often down to this. There are two ways to avoid this occurring. The first is to make sure you have the most up to date driver for your sound hardware.
The second is to disable Direct X's sound optimisation. To do this:

1. Go to start. Select run. Type in "dxdiag" and hit enter
2. The Direct X Diagnostic tool will launch. Wait a couple of seconds while it detects hardware information
3. Click on the sound tab
4. Move the hardware acceleration slider all the way to the left (off or none will be displayed)
5. Ok and exit.

The actual perfomance hit on your system is variable. Many manufacturers bypass Direct X's software acceleration in favour of their own hardware or driver based routines. In 99% of cases, you won't notice any difference with how the game plays (except less crashes and more stability). If you do see decreased performance, try moving the slider up a notch and retest the game. Often you can get basic acceleration or better before the initial problem reappears.