Resolved D3D crashes? Don't use Bannerlord shaders, that messes up the game -> RESOLVED!!!

Users who are viewing this thread

Version number
1.8.0
Branch
Beta
Modded/unmodded
Yes, I used mods.

Charly30

Recruit
Summary:
Hello to all Bannerlord frustrated lovers whose fun is ruined by D3D crashes.

I opend a ticket, here what I just sent to the devs :

"As you can see in my previous tickets I have a NASA pc and can't play your game proprely (even with a W10 + Bannerlord clean install all up to date). Weird, is it?
1440p only with very low graphics to don't have D3D crashes ; 1080p without Radeon Super Resolution -> crashes 100% of the time....

Guys, your shader progamming is not good, that spoils this great game you're working on.
I set the shader to low and I downloaded ReShade => no problem anymore (or almost) every settings to the max in game, in Adrenalin, GPU OC (maybe still cause some crashes if the Vgpu is too low, depending, not sure) and the 1st time I tested in a big battle with the CPU OC (PBO) it didn't crash (the 2nd time yes).

So please, throw away ALL your shader home made folders and ask reshade.me to can use their programming, give them a bill or I don't know what."

So, to fix it :

1st : download the executables TW talks about here.
I also have three c++2008 packs, I don't know if that helps ; anyhow, I've looked for every packs (it was weeks ago that I was looking for a solution/fix)
2nd : find the DXSETUP.exe and launch (Bannerlord must be already installed maybe, I don't know). C:\Program Files (x86)\Steam\steamapps\common\Steamworks Shared\_CommonRedist\DirectX\Jun2010
I found the trick
here, some other ones could help.
3rd : Download and install
ReShade.
After the install you'll have to configure it. Select : DirectX 10/11/12, the basic filter packs (I don't remember the names but easy to see), and
TaleWorlds.MountAndBlade.Launcher.exe in Mount & Blade II Bannerlord\bin\Win64_Shipping_Client\
ReShade will be launched automatically with the game ; "Home" to open the menu then do your own cook, that's funny but just keep the
default setting.

There is a good tuto to install it here, just be careful with the .exe name.

EDIT : very important, to can play with a 1440p setting (without crash) I MUST tick Performance Mode on the bottom right of the ReShade window in game.

4th : I think that I forgot nothing now
5th : Enjoy your new game :grin:

Now the game is gorgeous, super smooth with EVERY GAPHIC SETTINGS max (in game and even in adrenalin) ; ok, there are still some crashes, I need to refine things (because of the OC? Because of the setting?), it is still new for me.
No crash anymore with the default setting in Reshade.

Quick look : 1440p, battle with 3000 warriors (not at same time obviously, max 1000), unlimited bodies and rangroll (max setting) :
130fps (I fixed this limit) when you're not inside a human mountain, inside a human mountain it can fall to 65fps, absolutely no lag.
I use mods.

Tell me if that helped you but I'm sure that yes.

RE EDIT : it crashes again when I engage troups in a big battle : TW, you make me crazy!


PS : "Whould you like to always ignore this failure" what are we supposed to answer? Which consequences?

How to Reproduce: KEEP PLAYING WITH TW SHADERS
Have you used cheats and if so which: No
Media (Screenshots & Video):
Computer Specs:
OS: W10
GPU: rog strix 6800XT
GPU Driver Version: 22.5.1
CPU: 5800X3D
RAM: G.SKILL Trident 2*16Go 3600Mhz
Motherboard: rog strix B550-e gaming
Storage Device (HDD/SSD): 2xSSD (OS+Games)
 
Last edited:

Charly30

Recruit
A little up, I've edited my message : I have no crash anymore, max everything, tested for hours in siege or plain battles WITH AND WITHOUT MOD, it's perfect and gorgeous.
2 mods to make the game absolutely more amazingly gorgeous by night : raise your torch and perfect fire arrows, TW must add it to the game and give a nice bill to the guy who made it, for real (y)
 
Top Bottom