In Progress Cursor Flickering in menus and world map. Possible solutions in Replies.

Currently viewing this thread:

Hello, recently I have experienced cursor flickering in the menus and the world map. I will provide screenshots of my settings in the launcher and what I have done to try to resolve the issue. I didn't provide audio settings since I doubt that would have any impact on the matter. There were older threads of this issue but all the things I tried from them didn't work, so that's why I'm making this one, also there was a Reddit post that also didn't help. What Also happens in the world map the game stutters when I try to look around or spin the camera. This isn't present in battles.
Here are the settings:
5ouB3yA.jpg

2ayfRPY.jpg

Previously I used to have my fps locked at 999 and that caused no issues at all, but changing it to 120 seemed to suppress it a little bit, but after a couple of minutes, it appears again.

eoi2N5A.jpg


Things that I have tried:
- Forcing vsync both through the game and through nvidia control panel.
- Locking the fps to 60 with and without vsync.
- Starting windowed then pressing alt+enter to make it fullscreen again.
- Updating DirectX and gpu drivers.
- Changing resolution.
- Reinstalling the game.
- Reinstalling Steam.
- Verifying game files through Steam.
- Disabling Steam overlay.
- Deleting the files in the appdata folder.
- Disabling blood.
- Deleting the .ini file in the Documents folder.
- Increasing the "render_buffer_size" in rgl_config.ini.
- Tried using DirectX 7.
- Forcing Single Threading.
- Tried changing all the settings in-game.
- Running the game as administrator.
- Running the game with Windows xp service pack 2 and 3.

All help will be greatly appreciated. If I need to provide anything else just tell me and I gladly will. Thanks in advance.
 
Last edited:

Cergio

Recruit
I have same problem. Cursor blinking and performance dips. PC confog - win 10, R7 5800X, 32 ГБ ОЗУ и RTX 3080. With the latest drivers and updates, this problem has not disappeared... It's a pity, but this game, also with the Prophecy of Pendor and GOT modules, was one of my favorites.
 
Last edited:
I know what the problem is. It's the drivers. Nvidia drivers i mean in my case. They screwed something up and now i get that cursor flickering and I know how to fix it, but it didn't work for me it might work for you.

First thing, this will reset whatever colors/gamma/vibrance you have on your NVIDIA CONTROL PANEL (If you even changed it from the default NVIDIA settings) if you did then write down what your Gamma/Vibrance/Brightness you set is so you can fix it. If you don't know what I'm talking about then disregard it.

BEFORE YOU DOWNLOAD MAKE SURE YOU RESTART IN SAFE MODE !!!! CUZ IF YOU DON'T YOU MIGHT GET A VIRUS!!!
Here's how to do that: You click on the windows button in your left corner the one you use for shutting down your pc, hold SHIFT key and then restart your pc. Then some options will appear click on Troubleshoot, then click on advanced options and then click on startup settings, then click on restart. After the settings appear click on 4 or F4 doesn't matter, then click restart.

After your pc boots up you do this:

- First step, download DDU (Display Driver Uninstaller)
heres a link: https://www.wagnardsoft.com/forums/viewtopic.php?f=5&t=3403
click on "Official download here".
- After you open the file click on the .exe
- When you open the program it has all of these boxes checked.
- Uncheck everything except for ("Remove "C:\NVIDIA" driver folders.")
- After you're done, click the button in the bottom right that says "Close"
- On the (Middle right) of the program there are two drop downs that say --Select device type---
- You'll choose GPU for the first and if you have an NVIDIA card it should Auto select Nvidia for 2.
- Then you'll hit the button on the left that says Clean and restart (Highly recommended)
- You'll still be able to use your main monitor, all of your "Multiple monitors" if you have more than one, will flash a few times before your computer restarts leaving only your first monitor available to be used for now.

DISCLAIMER: THE STUDIO DRIVERS AND THE GAME READY DRIVERS HAVE NO DIFFERENCE IN FPS!!!
(Atleast for most people)

Then

open up Geforce experience, click drivers. (Stop the auto download)

Once it's stopped you'll see three dots near the top right of G.E to the right of (CHECK FOR UPDATES)

Click those, and click "Studio Driver" instead of Game Ready Driver. <<< MAKE SURE YOU TRY STUDIO DRIVERS

The other option is to wait for Nvidia to release new drivers which fix the issue.

Feel free to ask me any questions if you have any.
 

Cergio

Recruit
I know what the problem is. It's the drivers. Nvidia drivers i mean in my case. They screwed something up and now i get that cursor flickering and I know how to fix it, but it didn't work for me it might work for you.

First thing, this will reset whatever colors/gamma/vibrance you have on your NVIDIA CONTROL PANEL (If you even changed it from the default NVIDIA settings) if you did then write down what your Gamma/Vibrance/Brightness you set is so you can fix it. If you don't know what I'm talking about then disregard it.

BEFORE YOU DOWNLOAD MAKE SURE YOU RESTART IN SAFE MODE !!!! CUZ IF YOU DON'T YOU MIGHT GET A VIRUS!!!
Here's how to do that: You click on the windows button in your left corner the one you use for shutting down your pc, hold SHIFT key and then restart your pc. Then some options will appear click on Troubleshoot, then click on advanced options and then click on startup settings, then click on restart. After the settings appear click on 4 or F4 doesn't matter, then click restart.

After your pc boots up you do this:

- First step, download DDU (Display Driver Uninstaller)
heres a link: https://www.wagnardsoft.com/forums/viewtopic.php?f=5&t=3403
click on "Official download here".
- After you open the file click on the .exe
- When you open the program it has all of these boxes checked.
- Uncheck everything except for ("Remove "C:\NVIDIA" driver folders.")
- After you're done, click the button in the bottom right that says "Close"
- On the (Middle right) of the program there are two drop downs that say --Select device type---
- You'll choose GPU for the first and if you have an NVIDIA card it should Auto select Nvidia for 2.
- Then you'll hit the button on the left that says Clean and restart (Highly recommended)
- You'll still be able to use your main monitor, all of your "Multiple monitors" if you have more than one, will flash a few times before your computer restarts leaving only your first monitor available to be used for now.

DISCLAIMER: THE STUDIO DRIVERS AND THE GAME READY DRIVERS HAVE NO DIFFERENCE IN FPS!!!
(Atleast for most people)

Then

open up Geforce experience, click drivers. (Stop the auto download)

Once it's stopped you'll see three dots near the top right of G.E to the right of (CHECK FOR UPDATES)

Click those, and click "Studio Driver" instead of Game Ready Driver. <<< MAKE SURE YOU TRY STUDIO DRIVERS

The other option is to wait for Nvidia to release new drivers which fix the issue.

Feel free to ask me any questions if you have any.
Unfortunately I tried this and it didn't help. Well, let's wait for the driver. Although I'm not sure if the fix will appear quickly ... The game is far from new, and does it make sense for Nvidia to spend time and resources on fixing this game ...
 
This is a major issue they will HAVE to fix it. Also I found a new potential fix which again didn't work for me.
So you download Process Lasso:
-Now in Process Lasso search for NVDisplay.Container.EXE and right click it and then click disallow process. - This will hopefully stop the flickering for you.

Here's a link: https://bitsum.com/
 
New drivers are up for Nvidia users. Try them now I will update if the problem is fixed for me.

Edit: It didn't work for me,but it may work for some...
 
Last edited:

scarface52

Master Knight
M&BWBWF&SNWVC
I'm having this issue too. It gets increasingly worse every second. Drivers must be the issue as you pointed out.
 

Crytex9

Recruit
I just updated my game ready driver thing through nividia experience and it fixed it for me. im running a 1660 super. Dont know if that helps but. |

V 461.40 01/26/2021


Maybe try reinstalling that particular one?
 
I just updated my game ready driver thing through nividia experience and it fixed it for me. im running a 1660 super. Dont know if that helps but. |

V 461.40 01/26/2021


Maybe try reinstalling that particular one?
No amount of reinstalling drivers or M&B itself will fix this guess I will try the mouse polling rate.
 

scarface52

Master Knight
M&BWBWF&SNWVC
What do you exactly mean by "mitigate the problem"? Does it remove it completely or just partially, or for a period of time?
Partially. The cursor still flickers but much less and the menu lag isn't noticeable. It doesn't seem to get worse over time if it even does.

For the record, I changed my mouse polling rate to 125 from 1000.
 
I want to piggyback on this thread since the devs haven't seemed to mention whether or not they are aware of the issue, or whether or not they intend to work on the issue. Despite being present in one of the two other (1, 2 <MArdA) threads mentioning this particular issue.

I usually play for probably 6 or so hours a day, mostly sort of in the background while developing my mod, and the longer I play the more I notice the stutters, and I think it gets progressively gets worse until you do a full restart of the PC.

So, I wanted to show the devs just how bad this issue has gotten for me.

So I cranked my max FPS to 999 and took it for a spin, recording the gameplay session:
While moving the cursor when it's visible, the game literally pauses rendering until the cursor is still again.

For fairness sake, I booted up Gloiria Sinica, Carribean!,WFaS and Mount&Blade 1.011.

I've never had issues with these other games back when they released, but it's present in each and every one of them.

MB 1.011 is somehow affected the most with the cursor barely moving at all. It is genuinely unplayable so long as this bug exists.


I wish I were lying about this, but I found a fix while writing this post.

A genuinely functional, but absolutely terrible and useless, fix.

Earlier this year I discovered to replace the cursor in your mod you needed to save the texture as an square, uncompressed dds texture named cursor.dds. However, trying a texture with any compression loaded the game without a crash (which trying to load without a cursor.dds in the main texture folder will cause), just without a visible cursor.

Rename cursor.dds inside the to anything else, and make a duplicate of any other texture file and name it cursor.dds. Ta-da! No more lag, no matter how much you move your cursor around. You'll have to rely on muscle memory to find where you are, but it honestly is more playable than the current state.

My guess is the way the engine overwrites the hardware cursor with an uncompressed .dds got changed in a recent Windows or DirectX update (Since AMD card users are seeing it too), and that's what is causing the issue.
 
Last edited:
Hello, a guy from steam said he has spoken with Marda on discord. But that was like 2-3 weeks ago. They should be aware, I didn't have issues too, also the reason I stopped modding was this problem. I just won't have the motivation until Nvidia releases new drivers. But that problem is not like mine, but it still is present. I will maybe try the fix later and inform you if anything happened also if you wish I can post the link to the steam discussion. Also the 999 fps is a big problem go with around 100 to 120 the game runs at the same speed maybe a bit less, but 999 fps causes my gpu to start coil whining and it intensified the flickering, but like 2-3 months ago I ran the game at 999 fps with no coil whining nor flickering...
 
Top Bottom