Crashing.

jason0422

Regular
WBNW
Best answers
0
Mount and Blade 1866 crashes every 15 - 1 hour.
Error message are: Mount and Blade has stopped working/Runtime Error! This application has requested the runtime to terminate it in an unusual way.

Help! I already updated my Microsoft Visual ++, restarted my computer, re-installed Mount and Blade ver. 1.011, re-installed 1866. tried to start a new save.

Computer specs:
Windows 7 Home Premium 64-bit
HP-Pavilion
2048MB RAM
NVIDIA GeForce 6150SE nForce 430
 

CppCoder

Sergeant
WB
Best answers
0
I use the same operating system, so it looks like it might be your RAM. On my laptop 1866 uses up to 2.5 GB (2560 MB) of memory (with my paging file at 934 MB). So if you haven't already you could try increasing your paging file / virtual memory and see if that helps it.
 

jason0422

Regular
WBNW
Best answers
0
CppCoder said:
I use the same operating system, so it looks like it might be your RAM. On my laptop 1866 uses up to 2.5 GB (2560 MB) of memory (with my paging file at 934 MB). So if you haven't already you could try increasing your paging file / virtual memory and see if that helps it.
I tried increasing my virtual memory but the game still crashes. :sad:
 

wrc

Grandmaster Knight
M&BWBWF&S
Best answers
0
jason0422 said:
CppCoder said:
I use the same operating system, so it looks like it might be your RAM. On my laptop 1866 uses up to 2.5 GB (2560 MB) of memory (with my paging file at 934 MB). So if you haven't already you could try increasing your paging file / virtual memory and see if that helps it.
I tried increasing my virtual memory but the game still crashes. :sad:
I think that we all have pretty much the same problem,"save often" seems as the only solution for now.
 

jason0422

Regular
WBNW
Best answers
0
wrc said:
jason0422 said:
CppCoder said:
I use the same operating system, so it looks like it might be your RAM. On my laptop 1866 uses up to 2.5 GB (2560 MB) of memory (with my paging file at 934 MB). So if you haven't already you could try increasing your paging file / virtual memory and see if that helps it.
I tried increasing my virtual memory but the game still crashes. :sad:
I think that we all have pretty much the same problem,"save often" seems as the only solution for now.
Alright then, thanks.  :smile:
 

AD1978

Recruit
Best answers
0
You may uodated the main game as well before playing this mod in  version 1.11.00.

Also I have problem too with Buena Fortuna, every time to try to capture the city crashing to desktop.
Something wrong with this city, any other cities has been captured!
This is my final city to finish the game....

Any solution to this?
 

Honved

Knight
Best answers
0
The solution to the memory issues probably isn't that the computer doesn't have enough RAM, but that the program can't use all of what's there.  Most older programs can only access up to 2Gb of memory, no matter how much your system actually has.  There were frequent crashes with a couple of M&B mods (TLD, 1866), often after doing anything that expanded the amount of stuff tracked by the game.

I ended up running a small free utility that makes programs "4GB memory aware" (some such utilities boost it to 3Gb, which is still a lot more than the 2Gb that the programs were originally written for), and have only seen about 2 crashes in the past 6 months, rather than 2-3 per evening of play.  You run the utility, select a program for it to modify, and it searches for and changes a couple of memory allocation settings.  It worked on M&B, Hearts of Iron 3, and 2-3 other games which occasionally locked up or dumped me back to the desktop, and was actually stated as a requirement to run certain mods that exceed the normal 2Gb memory limit.
 

thezerech

Recruit
M&BWBWF&S
Best answers
0
I have crashes upon trying to enter towns and cities, I'm getting the runtime error program has closed itself hoopla but don't know how to fix it. I've played other M&B mods like Southern Realms/CWiR and had no problems entering cities and towns. I'm not sure why it keeps crashing. Surely it can't be a RAM problem if other mods don't crash in the same situation?
 

Honved

Knight
Best answers
0
See my post directly above yours.  I had crashes in a few particular mods, especially those which used a lot of different assets at the same time, or a large number of non-vanilla assets.  That included TLD, 1866, and Star Wars: Conquest.  Others which had less unique assets or smaller troop trees (less different items to load at the same time) didn't crash, and a few only crashed well into a campaign as it gradually surpassed the available memory.  Before running a 4Gb utility, I had crashes every 10-60 minutes; afterwards I've had perhaps 2 crashes in the past 6 months.

M&B isn't the only program affected, as this problem was present in a few other older games, and the utility ended the crashes.  There are dozens of these 3 or 4 GB "large memory block aware" utilities on the internet available for free download, just Google (or equivalent) the terms.
 

thezerech

Recruit
M&BWBWF&S
Best answers
0
Honved said:
See my post directly above yours.  I had crashes in a few particular mods, especially those which used a lot of different assets at the same time, or a large number of non-vanilla assets.  That included TLD, 1866, and Star Wars: Conquest.  Others which had less unique assets or smaller troop trees (less different items to load at the same time) didn't crash, and a few only crashed well into a campaign as it gradually surpassed the available memory.  Before running a 4Gb utility, I had crashes every 10-60 minutes; afterwards I've had perhaps 2 crashes in the past 6 months.

M&B isn't the only program affected, as this problem was present in a few other older games, and the utility ended the crashes.  There are dozens of these 3 or 4 GB "large memory block aware" utilities on the internet available for free download, just Google (or equivalent) the terms.
Thanks for the quick reply! I'll try downloading one now. I've been getting away with some of the WB ports so far, obviously that doesn't help 1866. I've been desperate to play my favorite mod of all time, so I really hope this works and appreciate your help.
 

thezerech

Recruit
M&BWBWF&S
Best answers
0
I've downloaded one, and applied the patch to all .exe and .dll files in the M&B folder and now it just won't work. How did you actually do it?
 

Honved

Knight
Best answers
0
thezerech said:
I've downloaded one, and applied the patch to all .exe and .dll files in the M&B folder and now it just won't work. How did you actually do it?
Normally, you run the utility and select the program from whatever "browse" function it uses.  The main .exe file for the game would be the target; it shouldn't need to change anything else.  I suspect that altering the .dll files is why it won't run.
 

thezerech

Recruit
M&BWBWF&S
Best answers
0
Honved said:
thezerech said:
I've downloaded one, and applied the patch to all .exe and .dll files in the M&B folder and now it just won't work. How did you actually do it?
Normally, you run the utility and select the program from whatever "browse" function it uses.  The main .exe file for the game would be the target; it shouldn't need to change anything else.  I suspect that altering the .dll files is why it won't run.
Applying the patch to solely the .exe results in an error message every time I select it on steam, or directly from the file.
 

thezerech

Recruit
M&BWBWF&S
Best answers
0
Arnulf Floyd said:
Try 4GB patch from NTcore which is more easier to use
I just used that. I applied it to the Mount&Blade.exe folder and the game wouldn't run and I got the same error message. "Application load error 3: 0000065432". I'm not sure what else, if anything I'm supposed to do. This is driving me crazy. I'm also trying to clean up my drives at the same time, not sure if that's helping, already got 10GBs off but the game still crashes when walking around large cities with the same runtime error.
 

Honved

Knight
Best answers
0
Not sure what else to say.  I haven't had any significant problems since patching, and it went smoothly.  Unfortunately, I'm about to get another try at it myself, because my hard drive went belly up and I've got another drive on order.  That means I'm about to experience the joys of reinstalling Windows and all of the games and other programs that I had, along with the heaps of mods.  It also means losing a couple of high-level characters in several games, and abandoning one massively overinflated country that's about 400 years into a 430 year campaign.

If I have any problems with it, I'll let you know.

Oh, just realized, I'm running the game off of a GamersGate download, not Steam.  Steam may have done something to prevent patching the files, or something like that, but I don't know enough about Steam's modified versions to be positive.
 

ArnulfFloyd

Knight at Arms
Best answers
0
I not have problems with crashing and I play only old games sure Steam versions excepted AOE and AOE2 both userpatched, also I not have encountered lag in demanding mods as Pendor. Steam versions are stable and good in my IMO
 

Miller786

Regular
Best answers
0
I have the same crashing problems, and i too get the error mentioned before when i try to apply the Ntcore 4gb patch
 

Honved

Knight
Best answers
0
Well, since replacing my failed hard drive, I upgraded the machine to Windows 10.  Now it doesn't function at all with original Mount & Blade, patch or not.