Need More Info Crashing in MP after joining the server

Users who are viewing this thread

Version number
e1.5.8
Branch
Main
Modded/unmodded
Unmodded
Dump identifier (optional)
2021-03-31_20.27.54_723316a13f74205e7d16a1df4619867b

Gibkiy_Rafik

Recruit
Summary: For the last month or so my MP games crash with "d3d device context map at rgl gpu lock texture failed" error. Also my GPU drivers crash too, some of the crashes make all system graphics buggy and looking like GPU is dead.

How to Reproduce: join MP server and play for some time. Skala Landing crashes in 5-10 minutes, other maps crash too, just not 100% of the time. I play only sieges, so no info on Skirmish or TDM.
Scene Name (if related):
Media (Screenshots & Video):
Computer Specs:
OS: Windows 10
GPU: Gigabyte Aorus Radeon RX 5700XT 8G
GPU Driver Version: 21.3.1, older versions had the bug too.
CPU: Ryzen 7 2700
RAM: 16GB
Motherboard: Gigabyte X570 I Aorus Pro WiFi
Storage Device (HDD/SSD): m.2 Smartbuy PS5013-2280T 256GB (238 GB)
 
Last edited:

Gibkiy_Rafik

Recruit
Can you try the workaround above?
Created 18 GB of virtual memory on both system SSD and game SSD, so 32 GB of virtual memory now. Crashes became a bit more rare, some rounds can be played fully without a crash, but still almost every game crashes, it just takes more time.

Edit: Read the article again, seems like minimum virtual memory should be like 24 GB for my 16 GB RAM, can having less than 24 GB be an issue? Also, should I increase virtual memory capacity on my system disk ar on a disk where the game is located?
 
Last edited:

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
After talking to the developers i've been informed that this is caused by a memory leak on our end that we are fixing at the moment. The fix does not have an ETA but we are working to make it done by the next patch. Sorry for any inconvenience.
 

Gibkiy_Rafik

Recruit
After talking to the developers i've been informed that this is caused by a memory leak on our end that we are fixing at the moment. The fix does not have an ETA but we are working to make it done by the next patch. Sorry for any inconvenience.
Got it, thanks for the answer.
 

Gibkiy_Rafik

Recruit
After talking to the developers i've been informed that this is caused by a memory leak on our end that we are fixing at the moment. The fix does not have an ETA but we are working to make it done by the next patch. Sorry for any inconvenience.
Seems like the issue have not been fixed in 1.5.9. In fact, game crashes much more fast now. Crash ID is 2021-04-08_20.32.08_723316a13f74205e7d16a1df4619867b.
 
Seems like the issue have not been fixed in 1.5.9. In fact, game crashes much more fast now. Crash ID is 2021-04-08_20.32.08_723316a13f74205e7d16a1df4619867b.
yeah after the official release of 1.5.9 the game is terrible. MP is crashing every time. Can't even play siege at all. Please fix.
 
After talking to the developers i've been informed that this is caused by a memory leak on our end that we are fixing at the moment. The fix does not have an ETA but we are working to make it done by the next patch. Sorry for any inconvenience.
After the official release of 1.5.9 the game is terrible. MP is crashing every time. Can't even play siege at all. Please fix.
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Siege loading crash has been fixed with a hotfix on Friday. Are you still experiencing this?
 
Yes, now i can't even join a server. When i press "Find Game" on siege, it is saying "Please Wait" after about 30 seconds it is displaying "Couldnt find applicable server to join"
Screenshot of the problem: https://prnt.sc/11c1jcz

I tried many times to join, but it just doesn't work since the release of 1.5.9. Now i spend my time playing singleplayer, because I play only siege, but still having fun :smile: .
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Can you send me the contents of this file after reproducing this?
C:\ProgramData\Mount and Blade II Bannerlord\logs\rgl_log_xxxxx.txt
ProgramData is a hidden folder.
 
Can you send me the contents of this file after reproducing this?
C:\ProgramData\Mount and Blade II Bannerlord\logs\rgl_log_xxxxx.txt
ProgramData is a hidden folder.
I veriefied the integrity of the game files and now it is working. I am so sorry for the inconvience, do you want me to still send you the files?
 

Gibkiy_Rafik

Recruit
What do you mean by removing it? What are you going to remove?
I created 24 GB of virtual memory on SSD where my game is installed as you recommended at the start of the topic, and I was wondering if deleting this virtual memory can make my game crash again, gonna test it tonight. The game seems to work fine now, some rare crashes happen, but it's not closely as bad as it was.
 

Gibkiy_Rafik

Recruit
New error, now I just cant even load the game.

2021-05-17_14.17.52_723316a13f74205e7d16a1df4619867b
d3d_device_->CreateShaderResourceView at rglGPU_device::create_rexture_from_image failed.
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
This means that your crash is originated from the GPU when creating a texture. What is your GPU? Also are the drivers up to date?
 
Top Bottom