Need More Info Crashes with error message: “d3d_device_context_-> Map at rglGPU_device::lock_texture failed

Users who are viewing this thread

Version number
No, I didn't use any mods.
Summary: it has happened a hundred times in the last 2 days, and at random times. I can almost never play a fight, often can't load save, and sometimes can't even adjust settings or stay in the main menu. the game freezes then pops up saying d3d_device_context_-> Map at rglGPU_device::lock_texture failed! I've tried a clean install, deleting filed from /documents and /programfiles, I adjusted the page size, I deleted everything in the bin and verified files, I did a completely clean install, I've updated drivers, OS, and firmware. If there's a forum post that suggests it, I've tried it. I'm gonna add the rgl log files in a comment, saw someone asked for those in another thread.
How to Reproduce: hard to say, occurs at almost random intervals, always failing with different markers.
Have you used cheats and if so which: none
Scene Name (if related):
Media (Screenshots & Video):
Computer Specs:
OS: win10
GPU Driver Version: 471.41 (updated yesterday, august third)
CPU: Intel(R) Core(TM) i7-10700F CPU @ 2.90GHz
RAM: 32GB Dual Channel HyperX(FM) FURY DDR4 XMP at 3200MHz
Motherboard: Alienware 0N43JM
Storage Device (HDD/SSD): I've tried in the primary SSD and the secondary HDD, happens on either one (1TB M.2 PCIe NVMe SSD + 2TB 7200RPM SATA 6Gb/s)

MArdA TaleWorlds

Community Support & Localization
Community Support
Please make sure that your GPU drivers and OS is up to date. If you are up to date you can try expanding the swap size on your hard disk. You can find more info regarding this here. If you are still experiencing the crashes you can also try enabling Vsync in the game settings.
I've updated the drivers and OS, my page file is currently incredibly large (changed that 2 days ago), but I'll try with Vsync and get back to you. wait one...
Vsync seems to be working so far, but we'll see if that holds after more playing. if that ends up being the fix, thank you so much, if not, then I'll send the crash log and update the info here
welp, turns out that was only good for one play session. I played a couple hours fine, then left and came back a few hours later, played 15 minutes, then crashed again when engaging some looters. dump id is: 2021-08-06_04.58.20_c5a5f7c121b25346f537efc99ac6c5b5
after a couple days of extra playing with settings, I've found that Vsync on full and turning on Nvidia DLSS significantly reduced the frequency of the error. it only happens every once in a while now instead of every 4 minutes
Top Bottom