Need More Info Crash On Start

Users who are viewing this thread

Version number
e1.7.1
Branch
Main
Modded/unmodded
No, I didn't use any mods.

dalaron

Recruit
Summary: Hello, i have played Bannerlord 2 40h aprox when released and several other times, but there was a patch that just broke the game like 5 months ago, I initialize the launcher and it opens up, then in the next seconds i freezes and then it closes by himself, making me unable to do anything.
I did already open a ticket long time ago and we were unable to solve the problem in this version e1.5.7 on Feb 16, 2021.
Version: e1.7.1
Is the game modded?: NO
How to Reproduce: Just by starting the launcher --- Added a video of the problem
Have you used cheats and if so which: NO
Scene Name (if related):
Media (Screenshots & Video) :
Computer Specs:
OS: Windows 10
GPU: Nvidia Geforce GTX 1050 2GB
GPU Driver Version: 30.0.14.9709
CPU: Intel Core i5-7500
RAM: 8 GB
Motherboard: Gigabyte H110M-S2H-CF
Storage Device (HDD/SSD): SSD 465 and HDD 1T

Here i Post the Log of the launcher:


Try to load dll TaleWorlds.MountAndBlade.Launcher.Steam.dll

Can't reset context
Loading FiraSansExtraCondensed-Regular font, at: C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord\Modules\Native\LauncherGUI\Fonts\FiraSansExtraCondensed-Regular/FiraSansExtraCondensed-Regular.fnt
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.DedicatedServer.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.DedicatedCustomServer.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.DedicatedCustomServer.Official.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.Platform.PS.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.Platform.GDK.dll
Init LauncherModsDLLManager
Total startup time: 0.7270
Exception has been thrown by the target of an invocation.
at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
at TaleWorlds.Library.TypeCollector`1.Instantiate(String typeName, Object[] parameters)
at TaleWorlds.GauntletUI.TextureWidget.UpdateTextureWidget()
at TaleWorlds.GauntletUI.TextureWidget.OnUpdate(Single dt)
at TaleWorlds.GauntletUI.EventManager.Update(Single dt)
at TaleWorlds.MountAndBlade.Launcher.StandaloneUIDomain.Update()
at TaleWorlds.TwoDimension.Standalone.WindowsFramework.MainLoop(Object parameter)


 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Could you try deleting everything under the folder below and verify the game?
"\steamapps\common\Mount & Blade II Bannerlord\bin"
 

dalaron

Recruit
I have done everything you said and i clicked on play and I still have the same problem as before.


The log of the client if it is of any use:

Try to load dll TaleWorlds.MountAndBlade.Launcher.Steam.dll

Can't reset context
Loading FiraSansExtraCondensed-Regular font, at: C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord\Modules\Native\LauncherGUI\Fonts\FiraSansExtraCondensed-Regular/FiraSansExtraCondensed-Regular.fnt
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.DedicatedServer.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.DedicatedCustomServer.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.DedicatedCustomServer.Official.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.Platform.PS.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.Platform.GDK.dll
Init LauncherModsDLLManager
Total startup time: 2.1730
Exception has been thrown by the target of an invocation.
at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
at TaleWorlds.Library.TypeCollector`1.Instantiate(String typeName, Object[] parameters)
at TaleWorlds.GauntletUI.TextureWidget.UpdateTextureWidget()
at TaleWorlds.GauntletUI.TextureWidget.OnUpdate(Single dt)
at TaleWorlds.GauntletUI.EventManager.Update(Single dt)
at TaleWorlds.MountAndBlade.Launcher.StandaloneUIDomain.Update()
at TaleWorlds.TwoDimension.Standalone.WindowsFramework.MainLoop(Object parameter)
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Could you send us the launcher_log.txt file? It should be located in C:\ProgramData\Mount and Blade II Bannerlord\logs pathway.
You can send your files to us via the ticketing system on the website. To send us a ticket, please visit the www.taleworlds.com site and login to your forum account from the top right. Click to "My Account" and then click to "My Open Tickets". You can create a ticket there and include the save file and as well as the forum link of this thread. You can find more info about how to upload files to us with the new ticketing system here. Thanks for reporting and sorry for any inconvenience!
 

dalaron

Recruit
Sure! This is everything the log has since the verification:


Try to load dll TaleWorlds.MountAndBlade.Launcher.Steam.dll

Can't reset context
Loading FiraSansExtraCondensed-Regular font, at: C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord\Modules\Native\LauncherGUI\Fonts\FiraSansExtraCondensed-Regular/FiraSansExtraCondensed-Regular.fnt
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.DedicatedServer.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.DedicatedCustomServer.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.DedicatedCustomServer.Official.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.Platform.PS.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.Platform.GDK.dll
Init LauncherModsDLLManager
Total startup time: 2.1730
Exception has been thrown by the target of an invocation.
at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
at TaleWorlds.Library.TypeCollector`1.Instantiate(String typeName, Object[] parameters)
at TaleWorlds.GauntletUI.TextureWidget.UpdateTextureWidget()
at TaleWorlds.GauntletUI.TextureWidget.OnUpdate(Single dt)
at TaleWorlds.GauntletUI.EventManager.Update(Single dt)
at TaleWorlds.MountAndBlade.Launcher.StandaloneUIDomain.Update()
at TaleWorlds.TwoDimension.Standalone.WindowsFramework.MainLoop(Object parameter)
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Could you try deleting the bin folder as well as LauncherGUI folder? Afterwards please verify the game files!
"\steamapps\common\Mount & Blade II Bannerlord\bin"and "\steamapps\common\Mount & Blade II Bannerlord\Modules\Native\LauncherGUI" are the pathways.
 

Istomol

Recruit
Could you try deleting the bin folder as well as LauncherGUI folder? Afterwards please verify the game files!
"\steamapps\common\Mount & Blade II Bannerlord\bin"and "\steamapps\common\Mount & Blade II Bannerlord\Modules\Native\LauncherGUI" are the pathways.
I just reinstalled game myself and had same problem as this post maker, i got game working after deleting BIN and LAUCHERGUI folder.verifyed and it worked
 

dalaron

Recruit
I have deleted both BIN and Launcher gui, then verified the game, and it didnt work, still have the same problem.
I have also deleted all the files in my secondary HDD, wich i had steamapps\commom\Mount & Blade II Bannerlor and it still doesnt work.
 

dalaron

Recruit
By the way i have initialiced the game from, this file Steam\steamapps\common\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client\Bannerlord.exe and it works as it should, except from the part that i cannots save the game and also have some savefiles which some of them are corrupted.

I dont know if it has got something to be with the other problem.

https://gyazo.com/62d8208e96ad614bc41af6471e3f6e7d -- IMG of corrupted files
https://gyazo.com/749f8f657a9ea59ed46e8fcfbd6d05ed -- IMG of cannot create savefile
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Can you try a clean install? It is the same issue with istomol and he managed to fix it with the same workaround.
Clean Install
The clean install is removing every single game-related file from your computer and installing the game again. Why do you need to remove the game while you just want to remove the modifications? Unfortunately, some of the modifications do not just add a new modules folder but also change or adds contents to the existent modules folder. Without a reinstall, we can't be sure those files are unchanged.

To perform a Clean Install, Uninstall the game. You can do that by right-clicking the game on Steam Library and selecting Delete Local Content. Delete all folders related to the game that remains after the uninstallation. The folders that might have files inside:
Steam: C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord
Epic: C:\Program Files\Epic Games\Mount & Blade II Bannerlord
C:\Users\USERNAME\Documents\Mount and Blade II Bannerlord
C:\ProgramData\Mount and Blade II Bannerlord

Note: You'll need to allow Windows to display hidden folders and files to see the ProgramData folder and its contents.
 
Top Bottom