[Crash] Iyakis - Complete crash if trying to walk in the city

Users who are viewing this thread


City/Settlement: Iyakis
Crash on entry - Loading screen, and then a crash after around 10-30 seconds

There are multiple ways to achieve this one, all resulting in a crash on trying to walk or enter Iyakis.

So, I went to try to get it with the rest of the army from the Western Empire, we had been doing win after win accross the desert. Me being a Vassal, and not having city of my own, only a castle nearby.

After getting to Iyakis, we set up for a siege as usual. Siege engines etc. We go for the attack, loading screen, then a crash.

Okay, so I load up a save from right before the siege. I try again. Same results.
I leave the army, and then form my own and lay siege to the city. Same results again.

Rinse repeat try to do the same thing multiple times, go into the siege and fight. I end up having to make the army fight for me, and we win. I get Iyakis and the accompanying settlements.

The fun thing now is that, I can go into the Tavern, I can use the functions like upgrade the city, give it a governour, garrison parts of my army and so on.

However, I can not walk around in it. It crashes, starts the loading screen as if I were to enter it, and then freezes and crashes.

After that I try jumping into the city by going directly to the merchants. Same results again. Loading screen and crash.

Sadly I don't have much more information then that I can write about. However, last few times I've tried to upload a crash report. Even the crash reporter has crashed. (Little note, I wrote this knowing the crash reporter can crash as it has done previously. However this time it seems like it might have gone through. Would be good if there was a notification saying if it was sent successfully or not and not just auto close)


If hardware is of any interest, then it is this:
CPU: 3800X
GPU: GTX 1070
RAM: 16GB 3200MHz


Having the same problem as you, crashing upon loading into a siege at Iyakis. Tried quite a few different settings to see if that would fix it but no luck so far. Here's hoping it's fixed in a patch soon. Until then I'm just going to avoid the city.
Top Bottom