Resolved Crash in game medium high and very high setting -> certainly because of the famous D3D error

Users who are viewing this thread

Version number
e1.7.2
Branch
Main
Modded/unmodded
Yes, I used mods.

Charly30

Recruit
Summary:
Hello,
My game crash if it's higher than low setting randomly in game on the map, 100% when I start a siege and maybe 100% too when I talk to somebody.
During the benchmark it's ok if I limit the framerate to 60fps (100% sure?) and 30fps (100% sure).

There is no stutter, it's very smooth and suddenly it freeze (crash) :
*I can still move the mouse ;
*The music is still on ;
*No error sound ;
*If I press Tab or the Window key a black screen appear ;
*Can't Alt+F4 nor Ctr+Alt+Suppr (the game mouse changes into Windows one), no other choice than to reboot my pc.

There are mods installed, without it still crash.
I've tried what is adviced in the Crash Checklist thread same but the .net Core wasn't installed and it helped a lot : since I can run the Benchmark at high setting 30/60fps without crashing, 144 crash , I have .net FrameWork every versions of Visual C++
OneNote is desable (doesn't start at pc start), when I desable the Stream Cloud it comes back alone.

With my GPU OC it crashes terribly, even in the menu ; I use PBO average freq 4.5GHz and the temperatures are good, I've tried everything Stock but still crash.

My drivers and W10 are updated, every AMD ones too (chipset,...).
What is weird is that desktop looks ok for this kind of game but it's like the game ask him too much ; my GPU and CPU usage : CPU maybe 70% max (not often), GPU almost everytime 35% (rarely, just for a couple of seconds 55%, weird too, every videos show it 100% used).

Other games played with max setting : Cyberpunk2077 (55fps), Crusader King III, Death Stranding,The Witcher III.

How to Reproduce: setting medium, high and very high and play
Have you used cheats and if so which: NO
Scene Name (if related):
Media (Screenshots & Video):
Computer Specs:
OS: W10
GPU: rog strix 6800XT LC
GPU Driver Version: 22.5.2 and the one before
CPU: 5600X / 5800X3D now
RAM: G.Skill Trident Z Neo 3600 32 GB L16-16-16-36
Motherboard: rog strix B550-e gaming
Storage Device (HDD/SSD): Corsair Force Series MP600 2To for games and SteamLibrary and MP600Pro 1To for W10.
 
Last edited:

Charly30

Recruit
I'm back.
I did a clean install (uninstall then delete every Mount and Blade folders).
Then I started the game, no mod installed : like usually for the 1st launch the game crash at the brightness calibration screen so I must paste a very low windowed setting to can acces the main menu BUT this time I didn't delete "the contents of "C:\ProgramData\Mount and Blade II Bannerlord\Shaders" and "C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord\Modules\Native\TileSets\pages" folders".

Here magic! The game was perfectly working, even in Very High setting, 1000 soldiers, limited at 100fps, my GPU super happy with his 95% usage.
Also I can see now the marks at the destinations (circle, cross) on the map and the areas where you can build engines during sieges.

Then I tried insatlling my mods from my backup folder (up to date for e7.2) : crashes went back and still being even if I unselect every mods in the start window ; painful.

So, I give you here a lot of elements about my mods logs/summaries.
I think we are on a good way, I just need help to understand, dekrypt why it/who makes my game crashing.
EDIT : every .dll are unlocked, every mods are installed manually.







Is there really something wrong about the warning message on the screenshots?
All the mods are up to date and are supposed to work with e.7.2 :







HarmonySummary :

ModLogs :
butterlib20220618 :

default20220618 :

trace20220618 :


EDIT : REINSTALLING THE GAME THEN I'LL INJECT MODS ONE AFTER ONE.
No mod, still crashing even in medium (during a siege battle, after several minutes of intense fights) and I think that I just did the exactly same way than the 1st time when it worked perfectly.
I'm tired.
 
Last edited:

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Were you able to see the crash uploader tool? If you can upload your crash to us we can check it out. Please don't forget to copy the Crash ID and write it here so that we can find it.
More info about the crash uploader tool can be found here.
Have you checked out these threads about our Crash Checklist and Common Issues and Workarounds? They can help you find a solution as well.
 

Charly30

Recruit
No I'm not able to see the crash uploader tool : the pc freeze totally, I can't do anything else but to reboot it, alt+tab makes a black screen.
I've done checked and rechecked many times the different links that you show me.

I just bought a 5800X3D and an other ssd (one for windows and one for games), I reinstalled W10 but can't log to my Steam account :/
I'm waiting for the technical support... °°'
 

Charly30

Recruit
I've ever tried (everything explained in my 1st message) : clean install + no mod the 1st time it works perfectly but the 2nd time no.
I'm still waiting for my Steam ID from their support to try with my new CPU and clean W10.

In my last installation I had ReShade : could it interfer with the game?
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Might be, not really have knowledge on that end sadly. Let's disable it and try to make sure.
 

Charly30

Recruit
OK so, with my new 5800X3D after a W10 reinstal, no mod, it worked perfectly e1.7.2, full setting, 243fps -> Benchmark OK -> Game Crash with d3d errors => same setting but 140fps OK
Then I added Realistic Battle mod OK -> then Raise your torch + raise your banner + Perfect Arrow + Dismemberment Plus -> crash -> unselect all -> still crashing with the same error.
"Expanding the swap size on your hard disk" didn't resolve the problem (32Go RAM => min=1.5*32000=48000Mo and max=32000*4=128000Mo).

No full crash anymore, now I can go back in W10 desktop and send crash reports ; what I don't understand is why when I uncheck the mods in the launcher screen or delete the folders it's still crashing.

So here we got 2 different problems (maybe), perhaps I forgot a step because that works fine for a lot of players.
Remember that when the game is low setting there is no crash.

Anyhow, developers need to work more about optimization/stability : not easy to do, I can guess.

EDIT : this is a shader log file from c:\programs (x86)\Steam\log , maybe that it can help.

RE EDIT : after a C: backup (when it was working perfectly) and deleting the mods in my D: drive it's still crashing : no "corrupted file(s) into the SteamLibrary folder (in D: , games drive)? I've also made a Bannerlord folder backup to original.
 
Last edited:

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Could you send us the contents of this folder after you launched the game after its crashed and you restarted the PC?
C:\ProgramData\Mount and Blade II Bannerlord
You can send your files to us via the ticketing system on the website. To send us a ticket, please visit the www.taleworlds.com site and login to your forum account from the top right. Click to "My Account" and then click to "My Open Tickets". You can create a ticket there and include the file and as well as the forum link of this thread.
Also there is a chance that the mods you installed might corrupted Native module. So trying a clean install to reproduce might help.
 

Charly30

Recruit
Ticket opened.

I just tried a new clean install, even Steam. I also reset my GC shader with Adrenalin but still crash, even in the brightness setting sreen with a d3d error.
Maybe I should reinstall AMD drivers, but why?

Anyhow, thank you so much for your work, I know that there are so many cases to manage, that's huge, good job!
I keep updating the investigations here I guess?

EDIT : it crashed with a popup on the bottom right of Windows main page : The application (taleworlds.mou) couldn't access the video hardware.
RE EDIT : It also appears when the game is not lauched



RE RE EDIT : I think that the big freeze that happened (forced to reboot the pc) was due to the fact that I've added in Regedit TdrDelay Hexadecimal:0 and Decimal:15 and TdrLevel Hexadecimal:0 Decimal:0 (DWORD (32bit) value) to fix the D3D crash.

So, for now, I guess that nobody can help me like many other players.

But what I still do not understand is why it has worked perfectly the 1st time I've reinstalled my whole desktop and then it's still messy.
Let's hope that the devs will can fix it, they better if they want Bannerlord goes further than early access.

But this game is really great, I love it, good job guys even if even :smile:
 
Last edited:

Charly30

Recruit
Good news : I found a solution to manage these damed D3D crashes, I didn't say fix.
I got a G7 32" 1400p, very important detail.

1440p it crashed, 1080p not with Radeon Super Resolution Enable BUT, there's always a but (magic of informatic I guess), the 1st time I tried it was in very high setting 90fps.

So I tried to push my GPU with Adrenalin and then it crashed again, I didn't remember the original setting.
So I tried over and over, remade a clean install and deleted every files (research "mount" and "titleworlds" on C: ), reinstalled my GPU driver with DDU but I didn't find back the 1st result (like usually...).

Getting bored, I installed e1.8.0.
Now it look stable, high setting modified and 60fps (1st I tried without mod to be sure then I added the mods) : fingers crossed.

My engine_config file :
number_of_ragdolls = 2
max_simultaneous_sound_event_count = 1
invert_mouse = 0
foliage_quality = 3
decal_quality = 3
texture_filtering = 4
graphics_adapter = 0
first_time = 0
brightness_calibrated = 2
texture_budget = 2
texture_quality = 2
show_framerate = 0
max_framerate = 60
cheat_mode = 0
localization_debug_mode = 0
water_quality = 2
display_width = 1920
display_height = 1080
display_mode = 2
selected_monitor = 0
force_vsync = 0
enable_cloth_simulation = 0
enable_flora_sway = 0
shader_quality = 2
postfx_dof = 0
postfx_sssss = 1
postfx_ssr = 1
postfx_bloom = 1
postfx_sunshafts = 1
postfx_streaks = 0
postfx_hexagon_vignette = 0
postfx_vignette = 0
postfx_grain = 0
postfx_lens_flares = 0
postfx_chromatic_aberration = 0
postfx_motion_blur = 0
tesselation = 1
particle_quality = 1
particle_detail = 1
terrain_quality = 2
shadowmap_type = 2
shadowmap_filtering = 0
shadowmap_resolution = 2
disable_sound = 0
sound_device = 0
sound_output = 2
enable_dynamic_resolution_scale = 0
dynamic_resolution_fps_target = 60
lighting_quality = 2
antialiasing_technique = 1
dlss_technique = 0
environment_detail = 3
character_detail = 3
animation_sampling_quality = 1
ai_quality = 1
safely_exited = 1
enable_controller_vibration = 1
keep_sounds_when_focused_out = 0
sound_occlusion = 1
weapon_trail_amount = 0.5000
display_refresh_rate = 240.0000
master_volume = 1.0000
music_volume = 0.6500
sound_volume = 1.0000
mouse_sensitivity_coefficient = 0.5000
gamma = 2.2000
sharpen_amount = 0.0000
control_mouse_movement_y_scale = 1.5000
control_mouse_movement_max_accumulation = 40.0000
control_mouse_movement_accumulation_decay_speed = 100.0000
brightness = 0.0000
brightness_min = 0.0420
brightness_max = 1.0000
exposure_compensation = 0.0000
resolution_scale = 100.0000
antialiasing_technique = 1
occlusion_technique = 0

Adrenalin setting :


I had the idea to set 1080 and not 1440 after watching this video, also it made me remember that days ago when it was great with high setting and 90fps I've done same -_-

So the D3D crashes would be because of the VRAM?
If yes, I guess that the devs already know it but that this is a big deal to resolve, good luck to them.
 
Last edited:

Charly30

Recruit
Bad news,
It didn't work far longer. So, I reduced the graph setting to medium/mediumLow and kept the 1080 size.

I have questions :
Is it possible that the perfs decrease (quickly) with time (more you play, less the system stable)?
How does the game affect the computer (software/harware)? Does it affect "root" files of the system?

I ask this because I do not understand why the 1st time I try It works perfectly then the 2nd time not.

An other question too :
Which settings need VRAM and how much (not a lot, medium, a lot!)?
I can see the bar in the menu but when I selected some options that don't encrease the bar (VRAM usage) I had the d3d crash.
 
Top Bottom