Resolved Crash due to rebellion?

Currently viewing this thread:

Version number
1.5.6
Branch
Beta
Modded/unmodded
Yes, I used mods.

Farah

Recruit
Second playthrough this happens in 1.5.6, exact same crash.

Exception information
Type: System.NullReferenceException
Message: Object reference not set to an instance of an object.
Source: TaleWorlds.CampaignSystem
CallStack:
  1. at TaleWorlds.CampaignSystem.Actions.ChangeKingdomAction.ApplyInternal(Clan clan, Kingdom newKingdom, ChangeKingdomActionDetail detail, Int32 awardMultiplier, Boolean byRebellion, Boolean showNotification)
  2. at TaleWorlds.CampaignSystem.Barterables.LeaveKingdomAsClanBarterable.Apply()
  3. at TaleWorlds.CampaignSystem.SandBox.CampaignBehaviors.BarterBehaviors.DiplomaticBartersBehavior.ConsiderClanLeaveKingdom(Clan clan)
  4. at TaleWorlds.CampaignSystem.SandBox.CampaignBehaviors.BarterBehaviors.DiplomaticBartersBehavior.DailyTickClan(Clan clan)
  5. at TaleWorlds.CampaignSystem.MbEvent`1.InvokeList(EventHandlerRec`1 list, T t)
  6. at TaleWorlds.CampaignSystem.CampaignEvents.DailyTickClan(Clan clan)
  7. at TaleWorlds.CampaignSystem.CampaignEventDispatcher.DailyTickClan(Clan clan)
  8. at TaleWorlds.CampaignSystem.PeriodicTicker`1.PeriodicTickSome(Single timeUnitsElaped)
  9. at TaleWorlds.CampaignSystem.Campaign.Tick(Single dt)
  10. at TaleWorlds.CampaignSystem.Campaign.RealTick(Single realDt)
  11. at TaleWorlds.CampaignSystem.MapState.OnMapModeTick(Single dt)
  12. at TaleWorlds.Core.GameStateManager.OnTick(Single dt)
  13. at TaleWorlds.Core.Game.OnTick(Single dt)
  14. at TaleWorlds.Core.GameManagerBase.OnTick(Single dt)
  15. at TaleWorlds.MountAndBlade.Module.OnApplicationTick_Patch2(Module this, Single dt)


It doesn't seem to be triggered by any mods seeing how the crash comes from TaleWorlds.CampaignSystem. Most of them are off right now despite being updated for 1.5.6, I want to test update, not the mods. If it would help I can still list the few mods I have active, but I doubt they are the issue, it's really only MCM and DCC.

I can't see what triggers it on the map, it doesn't always happen at the same time. In the previous save I manage to save everyday and re-load after a crash to push it until the crash happened 100% the day of the save. It was at around day 150 not being part of any Kingdom, the current one is at day 92 I believe, still not part of any Kingdom.

I wonder if that could be because I married a noble, could rebels try to take over her fief but the game didn't register it's no longer her clan?

EDIT: Oops, I thought I clicked on the crash section, I guess not! My bad!
 

MArdA TaleWorlds

Community Support
M&BWBWF&SNWVC
Were you able yo use the crash uploader after the crashes? It is nearly impossible for us to reproduce most of the crashes. With an uploaded dump file of the crash, we can debug the issue. If you are still experiencing this issue please use the crash uploader and send us the crash identifier so that we can find it. You will see the identifier after the upload is completed and you can copy it on the dialogue window.
 

Farah

Recruit
It happened again in a matter of days, it is the same crash report so I won't reupload it.

I forgot I had the mod "Marry Anyone" active, as a female I married Mesui. I turned it off for this and the crash still happens, however Mesui is still in my party. I will do another playthrough without the mod, I'm not sure why I didn't realize it was on, habit...

Here's there crash ID:
2021-01-05_08.15.08_ba534ce2da1cfdacefdf444d1c44be72
 

MArdA TaleWorlds

Community Support
M&BWBWF&SNWVC
Forwarded to the QA team for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!
 

MArdA TaleWorlds

Community Support
M&BWBWF&SNWVC
QA have informed that they they are suspecting the mods are the cause of this crash. Can you remove all the modifications and try to reproduce this on the vanilla game?
You can find more information about how to remove modifications here and more information about what we think about issues related to modding here.
 

Farah

Recruit
I ran a few tests without mods on this same save and it still crashes. It happened during the same day of the save once, other times seemed to be between 3 and 30 days of waiting in Amprela to speed it up.

I do not get an error window at all however, only the option to send the files of the crash, since I can't see I can't confirm if it is the very same crash, but it always crashes nonetheless.
 
I ran a few tests without mods on this same save and it still crashes. It happened during the same day of the save once, other times seemed to be between 3 and 30 days of waiting in Amprela to speed it up.

I do not get an error window at all however, only the option to send the files of the crash, since I can't see I can't confirm if it is the very same crash, but it always crashes nonetheless.
If you want to upload the save to me I would be willing to test it out myself and see if I can get it to crash, I can then record and post the video so the team could see it
 

MArdA TaleWorlds

Community Support
M&BWBWF&SNWVC
I would suggest recreating it on a fresh save, saved game with mods applied can still crash due to the mods installed even though they are not working.
 

CaseyZero

Recruit
I've seen this issue as well. It seems to correlate with another glitch -- after I had created a new kingdom, my clan spontaneously left the kingdom for no apparent reason. I re-formed the kingdom with the same name, and it happened again a couple of days later. Finally I just left myself out of the kingdom for a while, and after a couple more days, I got a crash with the exact same stack trace.

I'm also using the Marry Anyone mod. I'll try reproducing it in a clean save with no mods, but I'll have to cheat a bit to bypass the lengthy grind to Clan Tier 4.

-c.
 
Top Bottom