Need More Info Crash at start

Users who are viewing this thread

Version number
1.8
Branch
Main
Modded/unmodded
No, I didn't use any mods.
Dump identifier (optional)
2022-08-19_16.29.21_9112b38ce84721069b8e4fd315299f94 2022-08-29_18.23.27_9112b38ce84721069b8e4fd315299f94 2022-09-04_20.38.03_9112b38ce84721069b8e4fd315299f94

Skantb

Recruit
Summary:Crash at every start (launcher or executable)
How to Reproduce:Launch the game
Have you used cheats and if so which: no cheats no mods
Scene Name (if related):
Media (Screenshots & Video):
Computer Specs:
OS: Win 7
GPU:GTX 980
GPU Driver Version: 461.09
CPU: i5 7400
RAM: 16 Gb
Motherboard: Asus
Storage Device (HDD/SSD): SSD

Here's some crash reports :

2022-08-19_16.29.21_9112b38ce84721069b8e4fd315299f94

2022-08-29_18.23.27_9112b38ce84721069b8e4fd315299f94

2022-09-04_20.38.03_9112b38ce84721069b8e4fd315299f94

Clean reinstall didn't work , and it was crashing with 1.7 too ...
 

Skantb

Recruit
Hello, thanks for the reply , I have already tried some of these workarounds , delete the language files , perform a clean install , updated the graphic drivers , still no luck ...

Here's one of the last crash reports :

2022-09-21_23.43.43_9112b38ce84721069b8e4fd315299f94
 

Sciohan

Regular
M&BWB
Could you post the last bit of rgl_log (the call stack at the end plus a few lines before it is fine) and tell us more about exactly when it crashes?
 

Skantb

Recruit
Could you post the last bit of rgl_log (the call stack at the end plus a few lines before it is fine) and tell us more about exactly when it crashes?
I'm not sure what you're asking me to paste (I've got multiple rgl_log files) , here a part of the most recent one :


Unhandled Exception Code 0xC0000005 at adress 0x7FED9D10E34
<#######################################################>

#[email protected]{D74D145F9CDD4BE99ECBCA94097E71B0} (1): 0:658996
#[email protected]{D74D145F9CDD4BE99ECBCA94097E71B0} (1): 0:428629
#[email protected]{D74D145F9CDD4BE99ECBCA94097E71B0} (1): 0:2127095
#[email protected]{D74D145F9CDD4BE99ECBCA94097E71B0} (1): 0:2126379
#[email protected]{D74D145F9CDD4BE99ECBCA94097E71B0} (1): 0:2130183
#[email protected]{47F6CCA836BF470B969AA912C45CAAED} (1): 0:426717
#[email protected]{FDF36D27D20A4A47A72E7AF0FD70DA41} (2): 0:87821
#[email protected]{0642F49FE33C4A35B76816A238FF86ED} (1): 0:342109
-----------------------------------------------
No managed frames available.



[01:43:43.677]
[01:43:43.677] Working Memory: 1098 MB
[01:43:43.677] Commit Memory: 1776 MB

[01:43:43.677] Page Allocator Memory:
[01:43:43.677] DumpTimeStamp: /2022-09-21_23.43.43
[01:43:43.677] AutoReport: Disabled

The crash always happens just after launch, I see that big hairy bastard with the progression bar for a second or less before I get the prompt with the new files he needs to download, I click on yes and I get the crash . I'm on Win7 btw , but it used to work on my previous build (Hard disk changed since) . Thank you
 

Sciohan

Regular
M&BWB
I can't recall ever seeing a progression bar in Bannerlord, it's not clear to me exactly when this crash is happening. Is the prompt for new files being downloaded from Steam itself? Does it prompt on every launch? It worked on your previous hard disk but not now, can you tell us more about how you migrated to your new disk? Disk clone, all fresh installs, any copy-pasting?
 

Skantb

Recruit
I can't recall ever seeing a progression bar in Bannerlord, it's not clear to me exactly when this crash is happening. Is the prompt for new files being downloaded from Steam itself? Does it prompt on every launch? It worked on your previous hard disk but not now, can you tell us more about how you migrated to your new disk? Disk clone, all fresh installs, any copy-pasting?
It happens just after the game launch, the screen with some warriors on a snowy mountain background , but there's no progression bar my bad :smile: The prompt seems generated by M&B not steam . It happens everytime wether I try via the launcher or the game executable . It's a new HD with fresh Win7 install yes .
 

Sciohan

Regular
M&BWB
You might want to try reinstalling the game's dependencies, if you're using a fresh install of Windows and copied your old installation of Steam / Bannerlord then you may be missing those. Alternatively even with a fresh Steam install, sometimes it will quietly fail to install them and not notify the user. Steam should have a copy of them in <Steam install directory>\steamapps\common\Steamworks Shared\_CommonRedist\DotNet\4.7 and <Steam install directory>\steamapps\common\Steamworks Shared\_CommonRedist\vcredist\2019

Another quick possible fix that I don't believe is mentioned in the common fix thread is flushing nVidia's shader cache. It's not too likely to help but it only takes a quick minute. %LOCALAPPDATA%\NVIDIA has two folders (DXCache and GLCache) and deleting the contents does it.

If neither helps, posting more of rgl_log would be helpful, the lines immediately before the unhandled exception code should mention what it was working on immediately before crashing.
 

Skantb

Recruit
Hello sir , my steam is a fresh install too but I've tried anyway deleting and reinstalling ms framework and vcredist, no success . I've also tried deleting the Nvidia cache like suggested .
Pasting the rgl_log lines before the crash, last line is about Nvidia indeed :

[13:53:35.426] file: ModuleData/physics_materials.xml
[13:53:35.426] Loading xml file: $BASE/Modules/Native/ModuleData/physics_materials.xml.
[13:53:35.426] Loading xml file: $BASE/Modules/SandBox/ModuleData/project.mbproj.
[13:53:35.426] reading physics_material xml files
[13:53:35.426] Loading xml file: $BASE/Modules/StoryMode/ModuleData/project.mbproj.
[13:53:35.426] reading physics_material xml files
[13:53:35.456] Selected graphics adapter: [0] NVIDIA GeForce GTX 980
[13:53:35.469]

Unhandled Exception Code 0xC0000005 at adress 0x7FECFF20E34
<#######################################################>

#[email protected]{D74D145F9CDD4BE99ECBCA94097E71B0} (1): 0:658996
#[email protected]{D74D145F9CDD4BE99ECBCA94097E71B0} (1): 0:428629
#[email protected]{D74D145F9CDD4BE99ECBCA94097E71B0} (1): 0:2127095
#[email protected]{D74D145F9CDD4BE99ECBCA94097E71B0} (1): 0:2126379
#[email protected]{D74D145F9CDD4BE99ECBCA94097E71B0} (1): 0:2130183
#[email protected]{47F6CCA836BF470B969AA912C45CAAED} (1): 0:426717
#[email protected]{FDF36D27D20A4A47A72E7AF0FD70DA41} (2): 0:87821
#[email protected]{0642F49FE33C4A35B76816A238FF86ED} (1): 0:342109
-----------------------------------------------
No managed frames available.



[13:53:35.859] reading sound_files xml files
[13:53:35.859] file: ModuleData/soundfiles.xml
[13:53:35.859] Loading xml file: $BASE/Modules/Native/ModuleData/soundfiles.xml.
[13:53:36.832]
[13:53:36.832] Working Memory: 384 MB
[13:53:36.832] Commit Memory: 964 MB


Thank you
 

Sciohan

Regular
M&BWB
First time I've seen a crash right after the selected graphics adapter line. Have you tried closing down any non-essential background programs, especially those that may attempt to draw an overlay over games such as Discord or enforce video settings such as GeForce Experience? It also wouldn't hurt to run system file checker ("sfc /scannow" in a command prompt elevated to administrator)
 

Skantb

Recruit
Just tried with discord and nvidia utility closed , no chance . The scan on dos prompt didn't find anything suspicious either .
 

Sciohan

Regular
M&BWB
Unfortunately I'm running out of suggestions here. Might want to double-check Windows Update. Probably worth looking through event viewer for any interesting warning or errors. Maybe check device manager for any driver-related warnings. If you have an onboard GPU you can try disabling that too. You can try getting updated / specific drivers for your motherboard / chipset if Windows handled that one automatically.
 

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
Hey, i have forwarded the issue to the QA team. Thank you for your time and sorry for the inconvenience.
 

Skantb

Recruit
Unfortunately I'm running out of suggestions here. Might want to double-check Windows Update. Probably worth looking through event viewer for any interesting warning or errors. Maybe check device manager for any driver-related warnings. If you have an onboard GPU you can try disabling that too. You can try getting updated / specific drivers for your motherboard / chipset if Windows handled that one automatically.
Thank you anyway for trying sir , all my other games are working, weird ...
 

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
Could you try capturing telemetry data on perf_test branch so that we can check if we can see any data related to the freeze?
We have a special performance build to check for these issues by collecting telemetry data. With that data, we can see exactly where and when the game's performance issues happened.
  • Switch to “perf_test” from the Steam betas tab. You can also use the "perf_test_beta" for the most current beta build-related issues. You can find more info about it here.
  • Open the game as usual and proceed to the stage where you are experiencing performance issues.
  • Before the performance issues start, toggle the profiling tool by holding the “right shift” and pressing the “T” key.
  • Record for 20-30 seconds, press the toggle key combination again. Please keep in mind that, the more you record, the more upload time it will require.
  • Find the "test.tmcap" file in the "...\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client" folder. You can find the "Mount & Blade II Bannerlord" folder inside the games installation folder.
  • Finally, you can send the file to us via the ticketing system. You can find more info about how to upload files to us with the new ticketing system here.
  • It is appreciated if you provide more information about your PC, what you were doing while the game was recording, and your graphics configuration. If the data you are trying to upload is too big or the site fails to upload, you can use an alternative site to upload your data. If you choose to do that please left a reply to this thread with the download link.
 
Top Bottom