Compilation of Solutions for Missing Server List

Currently viewing this thread:

adam19044

Recruit
solutions suggestion don't work... But I found the solution! Enter in windows folders search line --> "%appdata%", and you can see AppData\Roaming. Now, delete MountBlade Warband folder from here, and restart the game, it's work for me! :wink: Sorry for my bad english, I hope I could help :smile:
 

ryanmortal

Recruit
This is a thread full of possible solutions to the Multiplayer server not populating.The developers are working hard on fixing this issue, but for now we have to rely on user made fixes to help the bug. Now these solutions may or may not work for you, they work for some people but not all.

Solution 1
1) from command line digit netsh winsock reset

2) Restart PC

3) Start M&B warband and enjoy multiplayer!

Submitted by Tanfata

Solution 2
1) Go to your routers setup page.

2)Uncheck both block IP flooding and block anonymous connections options

3) Start M&B Warband Multiplayer.

Submitted by Manatic

Solution 3
1.Launch game as usually go to the point where you get ''stuck'' (retrieving server list.. or connecting to a server)

2. aguarde alguns segundos e pressione ALT + TAB para iniciar o logoff e mudar de usuário

3.Faça login novamente em sua conta, volte ao jogo e que surpresa isso TRABALHA

Enviado por Perkunas [/ spoiler]

Solução 4
1) Encontre o RGL_config.txt na sua pasta Warband e abra-o.

2) Encontre o max_number_of_connections e altere o valor de 64 para 20 ou mais.

3) Salve e inicie o Warband

Enviado pelos desenvolvedores [/ spoiler]

Solução 5
1) Encontre o RGL_config.txt na pasta Warband e abra-o.

2) Encontre o use_secure_connection = 1 e altere-o para 0.

3) Se já é 0, mude para 1

4) Salve e inicie o Warband.

Enviado pelos desenvolvedores [/ spoiler]

Solução 6
1) Entre no Multiplayer.

2) Hospede seu próprio jogo, inicie o Mapa e crie.

3) Saia e pressione iniciar pesquisa.


Enviado por TreeBeard [/ spoiler]

Se todo o resto falhar
1) Feche todos os aplicativos que acessam a Internet.
2) Inicie o Warband na janela e vá para a página MP onde você pode clicar em 'Ingressar em um servidor'.
3) Inicie o Wireshark.
4) Na janela 7, meu adaptador sem fio está listado simplesmente como "Microsoft", portanto, inicie a captura na interface: Microsoft (no XP, acho que listou o tipo de adaptador)
5) Clique em Ingressar em um servidor.
Você verá um monte de entradas coloridas aparecendo na tela do Wireshark; esse processo normalmente é concluído em alguns segundos.
6) Clique em Capturar, Parar. Arquivo, Saveas, etc.
Você pode compactar e anexar o log inteiro ao relatório de erro, não é muito grande ou procurar o "GET /handlerservers.ashx?" um Daegoth solicitado, clique com o botão direito do mouse e selecione 'Seguir fluxo TCP'.

Adereços para Nood
Um dos desenvolvedores solicitou que você faça isso e, depois de fazer isso, poste os resultados no rastreador de erros, localizado abaixo. [/ Spoiler]

Aqui está o rastreador de erros desse bug: http://bugs.taleworlds.com/edit_bug.aspx?id=1758

Se você tem uma solução e ela ainda não está aqui ou se uma solução resolveu seu problema, poste aqui.
Atualizações
Adicione instruções passo a passo para o Wireshark​
[/ CITAR] meu pc e windows 10 depois de um reset nao esta pegando mas ja fiz tudo isso nao esta pegando
O que outras pessoas estão dizendo
 

Barteg

Recruit
none of them helped :sad:
This is a thread full of possible solutions to the Multiplayer server not populating.The developers are working hard on fixing this issue, but for now we have to rely on user made fixes to help the bug. Now these solutions may or may not work for you, they work for some people but not all.

Solution 1
1) from command line digit netsh winsock reset

2) Restart PC

3) Start M&B warband and enjoy multiplayer!

Submitted by Tanfata

Solution 2
1) Go to your routers setup page.

2)Uncheck both block IP flooding and block anonymous connections options

3) Start M&B Warband Multiplayer.

Submitted by Manatic

Solution 3
1.Launch game as usually go to the point where you get ''stuck'' (retrieving server list.. or connecting to a server)

2.wait few secs than press ALT+TAB go to start log off and switch user

3.Log back in in your account go back to game and what a surprise it WORKS

Submitted by Perkunas

Solution 4
1) Find the RGL_config.txt in your Warband Folder and Open it.

2) Find the max_number_of_connections and change the value from 64 to 20 or so.

3) Save and Start Warband

Submitted by the Developers

Solution 5
1) Find the RGL_config.txt in your warband Folder and Open it.

2) Find the use_secure_connection = 1 and change it to 0.

3) If it's already 0 change it to 1

4) Save and Start Warband.

Submitted by the Developers

Solution 6
1) Go into Multiplayer.

2) Host your own game and start Map and spawn.

3) Quit and press start search.


Submitted by TreeBeard

If all else fails
1) Close down any apps accessing the internet.
2) Start Warband windowed and go to the MP page where you can click 'Join a server'.
3) Start Wireshark.
4) On Window 7 my wireless adaptor is listed a simply "Microsoft", so Start capture on interface: Microsoft (On XP I think it listed the adaptor type)
5) Click on Join a server.
You will see a load of coloured entries showing up on the Wireshark screen, this process normally completes in a few seconds.
6) Click Capture, Stop. File, Saveas, etc.
You could zip and attach whole log to the bug report, its not very big or look for the "GET /handlerservers.ashx?" one Daegoth requested, right-click and select 'Follow TCP Stream'.

Props to Nood
One of the Dev's requested for you to do this and after doing so please post the results at the bug tracker which is located below.

Here is the bug tracker for this bug: http://bugs.taleworlds.com/edit_bug.aspx?id=1758

If you have a solution and it's currently not in here or if a solution has solved your problem please post here.
Updates
Add a Step by Step instructions for Wireshark​
 
Top Bottom