Resolved Companion led parties just stay in town and don't leave and don't patrol

Users who are viewing this thread

Version number
No, I didn't use any mods.
Summary: My apologies if this is a known bug. I checked and did a search and didn't see it mentioned. The party just rests int he town and just stays there and doesn't patrol. I set my wage limit to slightly more than what they are currently costing. I have two parties and one of them just stays in the town. The party has about 100 people mostly heavy horse archers and lancers. The other one is normal but still doesn't seem very active. I have tried changing the behavior (defensive, aggressive, etc...). Doesn't work. The leader is the bloodaxe companion but I don't think that has anything to do with it. I noticed his leadership goes up on occasion I guess from resting in the town. I tried disbanding in an earlier save and its kinda weird. The troops are lost and don't get recovered. The companion just stays inactive and takes a few weeks to actually disband and then you have to grab him from whatever town he's in. I don't want to go through that again. I'm going to try to create an army and get them to join and see if that helps. I did a google search and it seems others are having the same problem but those posts are 2 years old so the problem still exists.
How to Reproduce: Create new party using a companion as a leader.
Have you used cheats and if so which: Yes but none related to this issue.
Scene Name (if related): Akkalit (I have my own kingdom and conquered the bottom two cities of the Kuzaits)
Media (Screenshots & Video):
Computer Specs:
GPU: RTX 2060
GPU Driver Version: Updated
CPU: i7 6700
RAM: 16
Motherboard: Dell XPS
Storage Device (HDD/SSD): HDD

MArdA TaleWorlds

Community Support & Localization
Community Support
Do you have a save file of session that you experienced this issue? With your save file, we can reproduce the issue much easier and faster. You can find your save file here:C:\Users\username\Documents\Mount and Blade II Bannerlord\Game Saves
You can send your save files to us via the ticketing system on the website. To send us a ticket, please visit the site and login to your forum account from the top right. Click to "My Account" and then click to "My Open Tickets". You can create a ticket there and include the save file and as well as the forum link of this thread. You can find more info about how to upload files to us with the new ticketing system here. Thanks for reporting and sorry for any inconvenience!
In my campaign I have three parties which do this as well. My sandbox has similar issues, but the parties venture out after a long wait. Would you like me to upload my saves to help in this effort?

Edit: I am on e1.7.2.316284
OS: Windows 10 Pro
GPU: RTX 2080
CPU: i7 9700
RAM: 16
Motherboard: AORUS
Storage: SSD
Last edited:
If it is the same issue it would help yes.
It's very similar, I've tried the Army workaround and it brings the parties out, but once I disband the army, the parties go back to Town and sit. The parties have been disbanded before and reformed with no troop or companion issue, but they go back to Town. First with Seonon then with Ostican (Yeah, I used cheats). I'm seeing this with two wanderer types and one silent type.

MArdA TaleWorlds

Community Support & Localization
Community Support
Forwarded to the QA team for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!
Sorry for the late response. I will upload my save file when I create another party. I have since disbanded my parties.
I do know that the issue I believe is in recruiting. They go to a fief (I've seen this happen in both town and village) and they are recruiting but seem "stuck" in recruiting mode and don't wanna leave. I know this because I tried inspecting the troops and taking away some troops and they automatically fill up again while they are stuck. This may or may not have to do with the recruiting cash limit that you impose on them. I always try to adjust the limit a few denars higher than what they currently have but maybe I should widen the gap.

It happens most with my "Golden" companion, although my "Bloodaxe" companion started doing it eventually as well.

MArdA TaleWorlds

Community Support & Localization
Community Support
I've been informed that this bug is fixed and the fix will be sent to the game with future patches. Thanks for reporting and sorry for any inconvenience!
Top Bottom